VPN client connects but can't ping any hosts

Answered Question

Below is the configuration of a PIX 501, which I want to accept connections from VPN software clients.  I can successfully connect to the PIX using the VPN client 5.0.0.7.0290, and I can ping the PIX at 192.168.5.1, but I can't ping or connect to any hosts behind the PIX.  Can anyone tell me what I'm missing in my configuration?

Thanks for your help.

chi-pix# sh conf
: Saved
: Written by enable_15 at 03:49:39.701 UTC Fri Jan 1 1993
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password encrypted
passwd encrypted
hostname chi-pix
domain-name .com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list internet-traffic permit ip 192.168.5.0 255.255.255.0 any
access-list ping-permit permit icmp any any
access-list 101 permit ip 192.168.5.0 255.255.255.0 10.10.11.0 255.255.255.0
access-list 102 permit ip 192.168.5.0 255.255.255.0 10.10.11.0 255.255.255.0
pager lines 24
logging on
logging buffered debugging
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.5.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.10.11.1-10.10.11.254
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 102
nat (inside) 1 access-list internet-traffic 0 0
access-group ping-permit in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set GvnPix-set esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set GvnPix-set
crypto map toGvnPix 10 ipsec-isakmp dynamic dynmap
crypto map toGvnPix interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp keepalive 60
isakmp nat-traversal 20
isakmp policy 9 authentication pre-share
isakmp policy 9 encryption des
isakmp policy 9 hash md5
isakmp policy 9 group 2
isakmp policy 9 lifetime 86400
vpngroup chiclient address-pool ippool
vpngroup chiclient dns-server 192.168.5.1
vpngroup chiclient wins-server 192.168.5.1
vpngroup chiclient default-domain com
vpngroup chiclient split-tunnel 101
vpngroup chiclient idle-time 1800
vpngroup chiclient password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
management-access inside
console timeout 0
vpdn group chi request dialout pppoe
vpdn group chi localname net
vpdn group chi ppp authentication pap
vpdn username net password ********
dhcpd address 192.168.5.2-192.168.5.33 inside
dhcpd dns xx
dhcpd lease 86400
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 100
Cryptochecksum:
chi-pix#

I have this problem too.
0 votes
Correct Answer by Jennifer Halim about 6 years 2 months ago

The configuration on the PIX looks correct.

I assume that you are trying to access hosts in 192.168.5.0/24, and those hosts default gateway is the PIX inside interface 192.168.5.1?


How are you trying to access those internal hosts? If you are trying to ping those hosts, please kindly make sure that there is no personal firewall enabled on the inside hosts as personal firewall normally does not allow inbound connection from ip address from different subnet.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jennifer Halim Thu, 09/16/2010 - 23:00

The configuration on the PIX looks correct.

I assume that you are trying to access hosts in 192.168.5.0/24, and those hosts default gateway is the PIX inside interface 192.168.5.1?


How are you trying to access those internal hosts? If you are trying to ping those hosts, please kindly make sure that there is no personal firewall enabled on the inside hosts as personal firewall normally does not allow inbound connection from ip address from different subnet.

ngravely Fri, 09/17/2010 - 05:11

Check the router that lies between the pix and the internet. It must allow esp traffic to pass. Esp is not enabled by default, but can be added using an acl.

Actions

This Discussion