No audio with internal CME call

Unanswered Question
Sep 17th, 2010

Hello,

i'm using CME (version 12.4(15)T5) togethet with 2 softphones (xlite and eyebeam). When i place an internal call between both softphones I dont get any audio.

Also with an external call I dont get any audio.


Can someone help/advise?


regards, Marty


####


voice service voip
no notify redirect ip2ip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.3
no supplementary-service h450.7
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip     
  registrar server expires max 3600 min 3600
   localhost dns:ccme.mydomain.com
  no update-callerid
!        
!        
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
!        
voice register global
mode cme
source-address 192.168.1.12 port 5060
max-dn 25
max-pool 20
authenticate register
authenticate realm brightconnect.nl
time-format 24
date-format D/M/Y
tftp-path flash:
create profile sync 0015020029507154
!        
voice register dn  1
number 561
allow watch
!        
voice register dn  2
number 564
allow watch
name XLITE MAC
label 564
!        
voice register dn  3
number 560
allow watch
name EYEBEAM PC
label 560
!        
voice register pool  1
id mac 0026.BB56.7FE0
type 7970
number 1 dn 1
dtmf-relay sip-notify
voice-class codec 1
username 561 password *******
!        
voice register pool  2
id mac 0000.0000.0000
number 1 dn 2
dtmf-relay sip-notify
voice-class codec 1
username 564 password *********
!          

voice register pool  3
id mac 0000.0000.0000
number 1 dn 3
dtmf-relay sip-notify
voice-class codec 1
username 560 password veerd003
!

!
telephony-service
max-ephones 20
max-dn 100
ip source-address 192.168.1.12 port 5060
calling-number initiator
time-zone 23
time-format 24
date-format dd-mm-yy
max-conferences 12 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
transfer-system full-consult
transfer-pattern .T
secondary-dialtone 9
!

ephone-dn  3  dual-line
number 561
label line 1
name MAC communicator
!        
!        
ephone  1
device-security-mode none
mac-address 0026.BB56.7FE0
type CIPC
!        
!        
!        
ephone  11
device-security-mode none
!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dksingh Fri, 09/17/2010 - 05:22

Assuming both are sip line side/endpoints registered with CME.

Doubt if these softphones are tested/officially supported with CME but if they are

able to register fine and follow the protocol, u shd be able to get it to work.


Grab following for one call between the two phones:


deb ccsip mess | err

deb voip ccapi inout


include:


sh run

sh voice register all

sh sip-ua register status


DK

Steven Holl Mon, 09/20/2010 - 07:45

Do you have audio in at least one direction if a soft phone calls the PSTN?


Media is built for the following streams for this call:

192.168.1.106<->192.168.1.12
192.168.1.12<->192.168.1.108


You don't have any Layer3/Layer4 issues on those flows, do you?  Can they ping each other?  No software firewalls are running on the PCs, are they?


If you get a packet capture on the endpoints, do you see RTP being received?  Can you get a capture off CME's switchport that faces the PCs with the soft clients?  Do you see RTP packets in/out there?


DK is correct, the CME BU does not support third party SIP client registration to CME.  Other than with community support, you're on your own if you run into defects/bugs on these devices, or if they don't work.

martyveerdonk Mon, 09/20/2010 - 09:44

I do have L3/L4 connectivity between these 2 softphones. I also see RTP streams reported by the CME


ccme#sh voip rtp connections
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP      
1   153        154        18934    64482  192.168.1.12    192.168.1.107 
2   154        153        16614    64160  192.168.1.12    192.168.1.106 
Found 2 active RTP connections


But still no audio.


I also see ICMP errors on the CME. Can this be related to my issue?


# rtp_udp_unreachable:Entered: ICMP unreachable for dest port

Steven Holl Mon, 09/20/2010 - 09:48

It's common to get a few ICMP unreachables as stream gets established.


Get a packet capture off the soft phone in parallel with a SPAN session off the switchport CME plugs into, and see where RTP is/isn't.


Can you test with a Cisco IP phone and see if that works?  What about calls into voicemail?

Actions

This Discussion

Related Content