VTP transparent between server & client

Unanswered Question
Sep 18th, 2010


Can I have a VTP transparant switch betweeen a vtp server and vtp client? Will vtp transparent still pass vlan's received from vtp server to client.

I tried it in lab but client don't receive anything. Just wondering if someone else has tried too.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
glen.grant Sat, 09/18/2010 - 02:48

  Yes it should pass those vtp advertisements .

  • Transparent—VTP transparent switches do not participate in VTP. A VTP           transparent switch does not advertise its VLAN configuration and does not           synchronize its VLAN configuration based on received advertisements, but           transparent switches do forward VTP advertisements that they receive out their           trunk ports in VTP Version 2.

    Peter Paluch Sat, 09/18/2010 - 02:48

    Hello Shahzad,

    It is indeed possible to have a VTP Transparent switch placed between a VTP Server and a VTP Client switches. However, in order for this VTP Transparent switch to pass VTP messages, its VTP domain name must either be unconfigured (i.e. NULL) or it must precisely match the VTP domain name used on the VTP Server/Client switches. And of course, all switches must be interconnected with working trunk ports because VTP messages are not sent through access links, only over trunks.

    Best regards,


    Jon Marshall Sat, 09/18/2010 - 02:49

    If you are running VTP version 2 then yes you should be able to use the setup you have and the client should still receive the vlan database from the server.

    Check that the VTP domain is the same, the VTP password (if you have one), that all the trunk links are working correctly and that the VTP revision number on the server is greater than the client.

    If none of the above helps can you post the configs.


    mshahzadqadir Sun, 09/19/2010 - 01:29

    Thanks All,

    I changed domain name on transparent switch to 'null' and then changed it to domain name of other switches and it is working now.

    The problem was I didn't set trunk to no-negotiate so vtp domain name was going in the DTP packets and that was causing trunks to go down. I changed trunk to nonegotiate and bounced trunk ports. Changed domain name to match and then it is all working ok.




    This Discussion