ASA 5505 and 3660 Router

Unanswered Question
Sep 19th, 2010

Please help me out here....

I am stuck, I am trying to configure my home lab and I can't seem to find out how to do the following:

Internet -->ASA5505-->3660Router-->2900XL Switch --->ASA5505--->Wireless AP

Attached is an image  with a better idea of what I am wanting to do.

I have read that any router with the ASA is usless, but I would like to have the ASA just be a firewall/VPN and not much else.  Any help with this would be apprciated.

***All Cisco Equipment has basic configs loaded on them, if needed I can provide a show ver.

Home_Network.jpg

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nagaraja Thanthry Sun, 09/19/2010 - 14:53

Hello,

From the diagram, it seems like you would like to assign 192.168.1.x address all across the board. You cannot do it with a router in between. Different router interfaces should have different IP addresses. So, in your case, it could be 192.168.1.x on the LAN side of 3660 and 192.168.2.x on the firewall side.

On the ASA:

interface vlan 1

nameif inside

security-level 100

ip address 192.168.2.1 255.255.255.0

exit

interface Ethernet 1

switchport access vlan 1

exit

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

route inside 192.168.1.0 255.255.255.0 192.168.2.2

On the 3660:

interface FastEthernet 0/0

description connection to ASA5505

ip address 192.168.2.2 255.255.255.0

no shut

exit

interface FastEthernet 0/1

description connection to 2900XL

ip address 192.168.1.1 255.255.255.0

no shut

exit

ip route 0.0.0.0 0.0.0.0 192.168.2.1

In this case, you do not need to make any changes on the ASA for the outside interface or the NAT settings. You are just introducing another subnet on the inside to make sure that you do not need to change IP address settings on the LAN.

Hope this helps.

Regards,

NT

woodjl1650 Sun, 09/19/2010 - 15:18

I did all the config as you stated but got this on the ASA

ASA2(config)# route inside 192.168.1.0 255.255.255.0 192.168.2.2
ERROR: Cannot add route, connected route exists

Not sure how to solve this.

Nagaraja Thanthry Sun, 09/19/2010 - 15:20

Hello,

Can you post the output of "show run interface" and "show run route" commands here?

Regards,

NT

woodjl1650 Sun, 09/19/2010 - 15:42

Got the route comman to go, but now not internet access.  Cable modem is connected to 0/0

ASA Version 8.2(3)
!
hostname ASA2
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Vlan5
no nameif
security-level 50
no ip address
!
ftp mode passive
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 192.168.2.0-192.168.2.36 netmask 255.255.255.0
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route inside 192.168.1.0 255.255.255.0 192.168.2.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.2.5-192.168.2.36 inside
dhcpd dns 68.87.68.166 interface inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:1a1353fe23c3450240b068138904822d
: end

Nagaraja Thanthry Sun, 09/19/2010 - 15:50

Hello,

Please remove the following line:

global (outside) 1 192.168.2.0-192.168.2.36 netmask 255.255.255.0

the command is

no global (outside) 1 192.168.2.0-192.168.2.36 netmask 255.255.255.0

That should fix the internet connection issue.

Regards,

NT

woodjl1650 Sun, 09/19/2010 - 16:11

removed it, but still no internet access....looking at my ip config on the PC, my default gateway is 192.168.1.1, is that correct?

Right now I have the cable modem ---> ASA 0/0 ---> ASA 0/1 ---->Router0/0----->Router0/1---->Switch 2900XL

Router Show Run

Router#show run
Building configuration...

Current configuration : 1244 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$.7Q9$mJ4Y0sVUoAw8QZ/33g1JD/
enable password henry999
!
no aaa new-model
no ip routing
!
!
no ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.7
ip dhcp excluded-address 192.168.1.1 192.168.1.10
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 8.8.8.8 8.8.4.4
!
!
!
username woodjl privilege 15 secret 5 $1$w.xT$cFJweRcOx29N9hKafqu4h1
!
!
!
!
interface FastEthernet0/0
description connection to ASA5505
ip address 192.168.2.2 255.255.255.0
no ip route-cache
speed auto
full-duplex
!
interface FastEthernet0/1
description connection to 2900XL
ip address 192.168.1.1 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
!
snmp-server community 192.168.1.1 RO
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
password henry
login local
!
!
end

Nagaraja Thanthry Sun, 09/19/2010 - 16:18

Hello,

Please issue the following command on the Router:

ip routing

Then, please issue the following command on the ASA:

clear xlate

This should clear out the incorrect xlate entries and allow internet connection.

Hope this helps.

Regards,

NT

woodjl1650 Sun, 09/19/2010 - 16:40

still no internet.....grrr....any ideas?

ASA current show run

SA Version 8.2(3)
!
hostname ciscoasa
enable password DQucN59Njn0OjpJL encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp
!
ftp mode passive
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route inside 192.168.1.0 255.255.255.0 192.168.2.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 8.8.8.8 8.8.4.4 interface inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:59c3d18363d20a207a02bf8b79a27069
: end

woodjl1650 Sun, 09/19/2010 - 16:34

Sorry, here is the corret show run:

Building configuration...

Current configuration : 1175 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$.7Q9$mJ4Y0sVUoAw8QZ/33g1JD/
enable password henry999
!
no aaa new-model
no ip routing
!
!
no ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.7
ip dhcp excluded-address 192.168.1.1 192.168.1.10
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 8.8.8.8 8.8.4.4
!
!
!
username woodjl privilege 15 secret 5 $1$w.xT$cFJweRcOx29N9hKafqu4h1
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
no ip route-cache
speed auto
full-duplex
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
!
snmp-server community 192.168.1.1 RO
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
password henry
login local
!
!
end

woodjl1650 Sun, 09/19/2010 - 16:46

Show Run of the router after ip route command:

uilding configuration...

Current configuration : 1120 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$.7Q9$mJ4Y0sVUoAw8QZ/33g1JD/
enable password henry999
!
no aaa new-model
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.7
ip dhcp excluded-address 192.168.1.1 192.168.1.10
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 8.8.8.8 8.8.4.4
!
!
!
username woodjl privilege 15 secret 5 $1$w.xT$cFJweRcOx29N9hKafqu4h1
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
speed auto
full-duplex
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
!
snmp-server community 192.168.1.1 RO
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
password henry
login local
!
!
end

Nagaraja Thanthry Sun, 09/19/2010 - 17:20

Hello,

Can you try pinging 192.168.2.1 from any of the inside clients? If that works, that means the connection is good. Then please try to ping 4.2.2.2 from the ASA. That tells you if you have internet connectivity from the ASA or not. On the ASA, please try the following commands:

access-list outside_access_in permit icmp any any echo-reply

access-group outside_access_in in interface outside

Hope this helps.

Regards,

NT

woodjl1650 Sun, 09/19/2010 - 17:39

I can ping the ASA and Router, but I don't get a reply from the internet.....

What could be wrong?

Thanks.

August Ritchie Sun, 09/19/2010 - 18:37

Just to clarify, did you try to ping 4.2.2.2 from the ASA itself?

Can you get a "show ip" and "show route" from the ASA?

Nagaraja Thanthry Sun, 09/19/2010 - 20:55

Hello,

Can you please try the following command:

icmp permit any outside

Then, try to ping 4.2.2.2 and see if that works.

Regards,

NT

woodjl1650 Mon, 09/20/2010 - 00:22

Show IP

System IP Addresses:
Interface                Name                   IP address      Subnet mask     Method
Vlan1                    inside                 192.168.2.1     255.255.255.0   CONFIG
Vlan2                    outside                174.56.139.62   255.255.248.0   DHCP
Current IP Addresses:
Interface                Name                   IP address      Subnet mask     Method
Vlan1                    inside                 192.168.2.1     255.255.255.0   CONFIG
Vlan2                    outside                174.56.139.62   255.255.248.0   DHCP

Show Route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    174.56.136.0 255.255.248.0 is directly connected, outside
S    192.168.1.0 255.255.255.0 [1/0] via 192.168.2.2, inside
C    192.168.2.0 255.255.255.0 is directly connected, inside

Ping 4.2.2.2

Sending 5, 100-byte ICMP Echos to 4.2.2.2, timeout is 2 seconds:
No route to host 4.2.2.2

Success rate is 0 percent (0/1)

August Ritchie Mon, 09/20/2010 - 02:10

Ahh, it looks like you have no default route.

Usually the command in the interfaces config for the outside "ip address dhcp setroute" will allow you to be assigned a default route by your ISP, but it either looks like that isn't happening or the ISP isn't sending that.

To remedy this you can add in

"route outside 0 0 " where next hop is the IP address of the ASAs next hop. You can find this out by doing either calling your ISP or taking a look at your "show arp" and see if there is another IP in the outside range (174.56.136.0 255.255.248.0) *Not really a surefire method, but can be faster than getting a hold of your ISP.

woodjl1650 Mon, 09/20/2010 - 02:59

Wow, Comcast is horrible with tech support....I am trying to explain what I need with no luck at all....

Should I just ask what the default route is? or is there something else I should be asking for?

August Ritchie Mon, 09/20/2010 - 07:12

Yeah, you should be asking what the IP address of the next hop should be, it should be in the 174.56.136.0 255.255.248.0 subnet. My guess is that it may be 174.56.136.1 as that is the first IP after the subnet ID, but this is just a common convention and may not be true in your case.

woodjl1650 Mon, 09/20/2010 - 12:50

Finally......it works...final question.  I would like to take the other ASA and put in between the phyical network and the wireless AP as shown in the picture above, is that overkill or smart sence it is dealing with wireless.  I want that more for intrustion detection....

Thanks.

August Ritchie Mon, 09/20/2010 - 14:19

Design questions are a little bit trickier as we can't really know the full scenario of your network, I.E. what you want the wireless for, is it just a guest network, do you need inside users to access it. Do you consider it to be more or less secure than the inside?

I'll throw out an idea, not a professional recommendation, but you may want to look into placing this as a DMZ on your current ASA depending on your license and whether you want the inside to communicate with it or not.

There are just so many unknowns to the scenario that we just can't say what is best.

woodjl1650 Mon, 09/20/2010 - 14:34

No DMZ on my license ...just an extra one I have...my network is a home network that I just want secure.  So I was wondering if the ASA would provide that with the access point connected to it.

August Ritchie Mon, 09/20/2010 - 14:56

Adding another security device might add a small amount of protection. To me, this firewall would mean that you don't trust the rest of the objects in the 192.168.1.0 network and want to restrict their access to your wireless network. I would guess that if you do trust them, then the firewall isn't going to do much as the internet facing firewall should be doing all the filtering that the second firewall would do.

Another thing you have to consider is your addressing scheme:

1. If you want to keep the 192.168.1.0 on both sides of the second ASA you will need to run it in transparent mode.

2. If you decide that you want to keep it the second ASA in routed mode, you may run into asymmetric routing issues.

Actions

This Discussion