Multicast not received by receiver.

Answered Question
Sep 20th, 2010

Hi

I have two layer3 switches, one vlan, and one routed port at 3550-1.

1. fa0/15 of 3550-2 is a routed port connecting only to one host which only know how to send broadcast.

2. 3550-1 and 3550-2 only have one vlan 10.

At fa0/15 of 3550-2:

no switchport

ip address 192.168.1.1 255.255.255.0

no shut

ip pim dense-mode

ip directed-broadcast

ip multicast help-map broadcast 239.5.5.5 mcxlate

exit

ip forward-protocol udp 65000

ip access-list extended mcxlate

10 permit udp host 192.168.1.10 any eq 65000

int vlan 10 of 3550-1

ip address 172.30.10.1 255.255.255.0

no shut

ip pim dense-mode

ip igmp join-group 239.5.5.5

int vlan 10 of 3550-2

ip address 172.30.10.2 255.255.255.0

no shut

ip pim dense-mode

ip igmp join-group 239.5.5.5

Broadcast was translated into multicast address, but multicast was not received on any vlan 10 access ports.

I captured the debug from 3550-1

*Mar 1 03:51:31.303: FIBipv4-packet-proc: route packet from Vlan1 src  192.168.1.10 dst 239.5.5.5

*Mar 1 03:5

3550-1#1:31.303: FIBfwd-proc: Default:224.0.0.0/4 multicast entry

*Mar 1 03:51:31.303: FIBipv4-packet-proc: packet routing failed

*Mar 1 03:51:31.303: FIBipv4-packet-proc: route packet from Vlan1 src  192.168.1.10 dst 239.5.5.5

*Mar 1 03:51:31.307: FIBfwd-proc: Default:224.0.0.0/4 multicast entry

*Mar 1 03:51:31.307: FIBipv4-packet-proc: packet routing failed

*Mar 1 03:51:31.623: FIBipv4-packet-proc: route packet from Vlan1 src  192.168.1.10 dst 239.5.5.5

*Mar 1 03:51:31.623: FIBfwd-proc: Default:224.0.

3550-1#0.0/4 multicast entry

*Mar 1 03:51:31.623: FIBipv4-packet-proc: packet routing failed

*Mar 1 03:51:31.623: FIBipv4-packet-proc: route packet from Vlan1 src  192.168.1.10 dst 239.5.5.5

*Mar 1 03:51:31.623: FIBfwd-proc: Default:224.0.0.0/4 multicast entry

*Mar 1 03:51:31.623: FIBipv4-packet-proc: packet routing failed

*Mar 1 03:51:31.923: FIBipv4-packet-proc: route packet from Vlan1 src  172.30.10.10 dst 79.111.108.122

*Mar 1 03:51:31.923: FIBfwd-proc: Default:0.0.0.0/0 proces level  forwarding

I  saw the src address from 192.168.1.10 and destination to 239.5.5.5 but  it was not seen on wireshark. And it said packet routing failed....  Anything which I have done wrongly?

I have this problem too.
0 votes
Correct Answer by Lei Tian about 6 years 2 months ago

Hi,

You haven't provided the output of 'show ip igmp snooping group' yet, and whether there is vlan 1 configured on 3550-1.

debug ip igmp snooping group will tell you whether the switch receive IGMP group message.

Regards,

Lei Tian

Correct Answer by james-worley about 6 years 2 months ago

Cool - Statics, like all things, work well when you have one or two groups and/or a small network. However this soultion does not scale if you plan to be usign lots of multicast groups as the outbound flooding can fill uplinks ans swamp client NICs.

This indicated an issue with IGMP joins.

Correct Answer by james-worley about 6 years 2 months ago

Hi

Looking at your config it appear asn though there is no (S,G) entry for this group on 3550-2 and there is no incoming Interface (IIL) for the (*,G) entry. How does switch 3550-2 connect to 3550-1? Is it via a layer 2 link or a layer 3 routed port? If the two switches are conected via a routed link you will need to configure an RP address to pass the mroute data around.

I've spent a lot of time recently with multicast and found the following commands to be very helpful to me:

sh ip mroute count- This is very useful to show you RPF failures and Outgoing Interface Null (OIL) drops. This will also show you the number of received packets.

Depending on the IOS, sh mac-address-table multicast vlan x or sh mac address-table multicast vlan x- you should be able to see which port the group is forwarding on. Given you are using dense mode I would expect the switch to be flooding on all ports for that vlan. If needed I believe you can add static mac entries but i've never done it.

A quick google search for a multicast mac address calculator will help confirm you have the right address. From memory the addresses should starte 0100.5e

Do you know if your clients support IGMPv2?

Correct Answer by Lei Tian about 6 years 2 months ago

Hi,

You don't need to configure static MAC group either. The PIM interface will send out query and learn the IGMP group from IGMP report automatically. Configuring ip igmp snooping vlan x static x.x.x int is equivalent to configure static MAC entry in mac-address table. Unless your multicast listener doesnt send out IGMP group message, you shouldn't need the static multicast MAC group.

HTH,

Lei Tian

Correct Answer by Lei Tian about 6 years 2 months ago

Hi,

No igmp join required. After helper-map converts broadcast into multicast, the multicast stream will follow all the multicast rules. igmp snooping is enable by default on this switch with or without you have pim or join-group configured.

As other people mentioned, igmp join-group will make the switch simulate as listener; it is used a lot for testing. You don't need this command to make your multicast work.

HTH,

Lei Tian

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
Lei Tian Mon, 09/20/2010 - 07:47

Hi,

Can you provide the output of 'show ip mroute' and 'show ip igmp snooping group' from both switches?

Regards,

Lei Tian

rakyomin78 Mon, 09/20/2010 - 19:16

I redo everything, the information as follows.

3550-1#sh ip
*Mar  1 00:55:30.211: %SYS-5-CONFIG_I: Configured from console by consolemroute 239.5.5.5
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.5.5.5), 00:36:43/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/15, Forward/Dense, 00:31:17/00:00:00
    Vlan1, Forward/Dense, 00:36:43/00:00:00

(192.168.1.10, 239.5.5.5), 00:03:17/00:02:43, flags: LT
  Incoming interface: FastEthernet0/15, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan1, Forward/Dense, 00:03:18/00:00:00, H

3550-2#sh ip mroute 239.5.5.5
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.5.5.5), 00:37:25/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan1, Forward/Dense, 00:37:25/00:00:00

(192.168.1.10, 239.5.5.5), 00:03:59/00:01:59, flags: PLTX
  Incoming interface: Vlan1, RPF nbr 172.30.10.1
  Outgoing interface list: Null

3550-2#sh run int vlan 1
Building configuration...

Current configuration : 110 bytes
!
interface Vlan1
ip address 172.30.10.2 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.5.5.5
end

3550-2#

3550-2#sh run int fa0/7
Building configuration...

Current configuration : 81 bytes
!
interface FastEthernet0/7
switchport mode access
spanning-tree portfast
end

port 7 is the member of default vlan 1 which cannot receive the multicast.

3550-1#sh
*Mar  1 00:58:27.779: %SYS-5-CONFIG_I: Configured from console by consolerun int fa0/7
Building configuration...

Current configuration : 81 bytes
!
interface FastEthernet0/7
switchport mode access
spanning-tree portfast
end

Port 7 is the member of default vlan 1 which cannot receive the multicast.

3550-1#sh ip access-lists
Extended IP access list 100
    10 permit udp any any eq 65000 (50 matches)

The broadcast should be translated into multicast.
I sent one broadcast udp 65000 and is translated as shown in debug ip mpacket

3550-1#debug ip mpacket
IP multicast packets debugging is on
3550-1#
*Mar  1 00:59:31.415: IP(0): s=192.168.1.10 (FastEthernet0/15) d=239.5.5.5 (Vlan1) id=32276, ttl=127, prot=17, len=29(29), mforward

But the host from fa0/7 of 3550-1 and 3550-2 did not see any multicast in wireshark.

Lei Tian Tue, 09/21/2010 - 03:23

Hi,

Does 3550-1 has vlan 1 as well? Do you have listener on vlan 1? Why do you need 'ip igmp join-group 239.5.5.5' to simulate a listener? Can you post the output of 'show igmp snooping group' from both switches?

Regards,

Lei Tian

rakyomin78 Tue, 09/21/2010 - 05:07

Hi Lei Tian,

I did not know igmp snooping was enabled by default, after I found out that ip igmp snooping was enabled by default I did a global configuration:

ip igmp snooping vlan 1 static 0100.5e05.0505 interface fa0/7

host at fa0/7 can receive multicast.

There will be no impact if I disable ip igmp join-group 239.5.5.5 right? Because IOS by default will join the group for me automatically once i configured ip multicast helper-map broadcast 239.5.5.5 mcxlate, am I right?

by the way both switches will have vlan 1, this default vlan cannot be removed anyway.

Julio Garcia Tue, 09/21/2010 - 05:11

hi rak,

I know you are probably quite used to it , but it is not recommended to use ip igmp join group command in a permanent solution,  try to design around doing this if you can because i think using that command causes your switch/router to process the multicast , i think ip igmp static group is a better command to use if you really  need to do this.

rakyomin78 Tue, 09/21/2010 - 05:13

hmm... ip igmp static group... I did not explore this yet.. not sure if my 3550 has this or not the switch is current in my office.

so ip igmp static group ?

Julio Garcia Tue, 09/21/2010 - 05:20

possibly the 3550 wont have  , it is ip igmp static-group xxxxx

on your 3550 , check  , sh ip pim neighbour , one of them should be the DR that sends queries, if your hosts just joins the multicast group , you wont need to do static joins everywhere

rakyomin78 Tue, 09/21/2010 - 05:28

well to clarify again, is ip igmp join-group command needed since I use ip multicast help-map command.

i was wondering was the ip igmp snooping enabled as soon as I use ip pim dense-mode? or as soon as i use ip igmp join-group?

Correct Answer
Lei Tian Tue, 09/21/2010 - 05:41

Hi,

No igmp join required. After helper-map converts broadcast into multicast, the multicast stream will follow all the multicast rules. igmp snooping is enable by default on this switch with or without you have pim or join-group configured.

As other people mentioned, igmp join-group will make the switch simulate as listener; it is used a lot for testing. You don't need this command to make your multicast work.

HTH,

Lei Tian

rakyomin78 Tue, 09/21/2010 - 05:44

thanks. Which means I only need ip igmp snooping vlan 1 static interface to receive multicast then.

Correct Answer
Lei Tian Tue, 09/21/2010 - 05:59

Hi,

You don't need to configure static MAC group either. The PIM interface will send out query and learn the IGMP group from IGMP report automatically. Configuring ip igmp snooping vlan x static x.x.x int is equivalent to configure static MAC entry in mac-address table. Unless your multicast listener doesnt send out IGMP group message, you shouldn't need the static multicast MAC group.

HTH,

Lei Tian

rakyomin78 Tue, 09/21/2010 - 08:18

Hi Lei Tian,

My mc receivers did not receive any multicast at all. However after I configured ip igmp snooping vlan 1 static commands I saw multicast received by the mc receivers in vlan. So... does this mean mc listener did not send out igmp group msg?

Correct Answer
Lei Tian Tue, 09/21/2010 - 08:31

Hi,

You haven't provided the output of 'show ip igmp snooping group' yet, and whether there is vlan 1 configured on 3550-1.

debug ip igmp snooping group will tell you whether the switch receive IGMP group message.

Regards,

Lei Tian

rakyomin78 Tue, 09/21/2010 - 09:52

Hi Lei Tian,

You are extremely helpful. I got my problem resolved. Thanks!

Lei Tian Tue, 09/21/2010 - 10:06

Hi,

Glad problem solved. Thanks for the great rating.

Cheers!

Lei Tian

rakyomin78 Tue, 09/21/2010 - 10:10

Hi Lei Tian,

I must give you good ratings because finding people who will answer a multicast question is hard and very rare. Only a handful of people answered multicast questions and most of the people I know either has no solid knowledge on mc or hated the mc completely....

Lei Tian Tue, 09/21/2010 - 10:16

I am sure there are lot mcast experts on the forum. For me, yea, I like multicast and qos:)

Glad to help.

Lei Tian

Correct Answer
james-worley Tue, 09/21/2010 - 07:45

Hi

Looking at your config it appear asn though there is no (S,G) entry for this group on 3550-2 and there is no incoming Interface (IIL) for the (*,G) entry. How does switch 3550-2 connect to 3550-1? Is it via a layer 2 link or a layer 3 routed port? If the two switches are conected via a routed link you will need to configure an RP address to pass the mroute data around.

I've spent a lot of time recently with multicast and found the following commands to be very helpful to me:

sh ip mroute count- This is very useful to show you RPF failures and Outgoing Interface Null (OIL) drops. This will also show you the number of received packets.

Depending on the IOS, sh mac-address-table multicast vlan x or sh mac address-table multicast vlan x- you should be able to see which port the group is forwarding on. Given you are using dense mode I would expect the switch to be flooding on all ports for that vlan. If needed I believe you can add static mac entries but i've never done it.

A quick google search for a multicast mac address calculator will help confirm you have the right address. From memory the addresses should starte 0100.5e

Do you know if your clients support IGMPv2?

rakyomin78 Tue, 09/21/2010 - 07:52

Hi JAmes,

I did a static mac address entry, and I saw multicast in wireshark of the host.

Before that no multicast was seen at all...

Correct Answer
james-worley Tue, 09/21/2010 - 08:03

Cool - Statics, like all things, work well when you have one or two groups and/or a small network. However this soultion does not scale if you plan to be usign lots of multicast groups as the outbound flooding can fill uplinks ans swamp client NICs.

This indicated an issue with IGMP joins.

rakyomin78 Tue, 09/21/2010 - 08:09

Hi James.

Not sure why there's no multicast received by the host, I have to do a static using igmp snooping command...

rakyomin78 Tue, 09/21/2010 - 09:52

Hi James,

I got it all wrong, I should not use static at all.. I got my problem solved... Thanks.

Actions

This Discussion