cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
576
Views
0
Helpful
4
Replies

Is Router Bridging My Only Option?

mchiaravalle_2
Level 1
Level 1

Hi all,

I've been reading through this support community for about a week now and found  many discussions similar to my question about using fa/0 & fa/1 on my 2811's.

Attached is a drawing of our typical remote locations.  Left side is current configuration, right side is what I'm trying to accomplish.  Basically one 2811 router and two 3560 switches, and I'm looking for some type of solution that would keep switch2 up should switch1 fail.  All Vlans (voice, data, and soon wireless AP) on both switches.

Thanks

4 Replies 4

Jon Marshall
Hall of Fame
Hall of Fame

mchiaravalle wrote:

Hi all,

I've been reading through this support community for about a week now and found  many discussions similar to my question about using fa/0 & fa/1 on my 2811's.

Attached is a drawing of our typical remote locations.  Left side is current configuration, right side is what I'm trying to accomplish.  Basically one 2811 router and two 3560 switches, and I'm looking for some type of solution that would keep switch2 up should switch1 fail.  All Vlans (voice, data, and soon wireless AP) on both switches.

Thanks

You could bridge but if these are 3560 switches then they are capable of routing. So what i would do is make the links between the 3560 switches and the 2811 router L3 P2P routed links, run a dynamic routing protocol such as EIGRP between the 3560s and the 2811 and then if one switch fails the other will continue to pass traffic. Your HSRP/GLBP if you are running it, would be on the 3560 switches eg -

router 2811

========

int fa0/0

ip address 192.168.5.1 255.255.255.252  <-- to switch1

int fa0/1

ip address 192.168.5.5 255.255.255.252 <--- to switch 2

router eigrp 1

network 192.168.5.0 0.0.0.7

no auto-summary

switch1

======

int gi0/1

no switchport

ip address 192.168.5.2 255.255.255.252

router eigrp 1

network 192.168.5.0 0.0.0.3

+ the vlans/subnets for the clients on the 3560 switch

no auto-summary

switch 2

=======

int gi0/1

no switchport

ip address 192.168.5.6 255.255.255.252

router eigrp 1

network 192.168.5.4 0.0.0.3

+ vlans/subnets on the 3560 switch

no auto-summary

Note, as i am sure you are aware, any device that is only singly connected to one of the 3560 switches will lose it's connection if the switch fails ie. your diagram shows an AP connected to switch1. If switch1 fails then you have lost the AP.

Jon

HI,

Thanks for the quick response and sorry for my late response.  I think I understand most of your config and will give it a try as soon as I can and let you know.

Nagaraja Thanthry
Cisco Employee
Cisco Employee

Hello,

You can configure HSRP at the switch level and then configure different default gateways on each switch. In that way, when the link between the switch 1 and the router goes down, Switch 2 will takeover and then route the traffic via 2800 to internet.

-------------------------------------------------------------------

On the switch 1:

interfaceVLAN 1
description Data VLAN
ip address 192.168.1.2 255.255.255.0
standby 1 ip 192.168.1.1
standby 1 priority 254
standby 1 preempt
standby 1 mac-address 0020.2222.1111

interfaceVLAN 2
  description Voice VLAN
  ip address 192.168.2.2 255.255.255.0
  standby 2 ip 192.168.2.1
  standby 2 priority 254
  standby 2 preempt
  standby 2 mac-address 0020.2222.2222

interface VLAN 3

description Connection to 2800

ip address 192.168.3.2 255.255.255.240

interface FastEthernet 0/24

switchport access vlan 3

ip route 0.0.0.0 0.0.0.0 192.168.3.1

On the Switch 2:

interfaceVLAN 1

  description Data VLAN
  ip address 192.168.1.3 255.255.255.0
  standby 1 ip 192.168.1.1
  standby 1 priority 100
  standby 1 preempt
  standby 1 mac-address 0020.2222.1111

interfaceVLAN 2
  description Data VLAN
  ip address 192.168.2.3 255.255.255.0
  standby 2 ip 192.168.1.1
  standby 2 priority 100
  standby 2 preempt
  standby 2 mac-address 0020.2222.2222

interface VLAN 3

description Connection to 2800

ip address 192.168.3.130 255.255.255.0

interface FastEthernet 0/24

switchport access vlan 3

ip route 0.0.0.0 0.0.0.0 192.168.3.129

On the Router:

interface FastEthernet 0/0

description Connection to Switch 1

ip address 192.168.3.1 255.255.255.240

ip nat enable

interface FastEthernet 0/1

description Connection to Switch 2

ip address 192.168.3.129 255.255.255.240

ip nat enable

interface serial 0/0

description Connection to internet

ip address

no ip nat outside

ip nat enable

ip route 192.168.1.0 255.255.255.0 192.168.3.2 track 1

ip route 192.168.2.0 255.255.255.0 192.168.3.2 track 1

ip route 192.168.1.0 255.255.255.0 192.168.3.130 254

ip route 192.168.2.0 255.255.255.0 192.168.3.130 254

access-list 10 permit 192.168.1.0 0.0.0.255

access-list 10 permit 192.168.2.0 0.0.0.255

ip nat source list 1 interface Serial 0/0 overload

track 1 ip sla 1 reachability

delay down 10 up 30

ip sla 1
icmp-echo 192.168.1.2

ip sla schedule 10 life forever start-time now
----------------------------------------------------------------------------
Hope this helps.

Regards,

NT

HI Nagaraja,

Thanks to you and Jon I have some good configs to work from.  Sorry for my late response back to you.  As soon as I get working on this I'll let you know how it goes.

Again thanks!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: