Upgrade issues migrating NAC 4.1.6 to 4.8.0

Unanswered Question
Sep 20th, 2010

Upgrade issues migrating 4.1.6 to 4.8.0 passing through 4.6.1 here the

procedure that I followed:

[[email protected] store]# tar xzvf cca_upgrade-4.6.1-NO-WEB.tar.gz

<<Information not displayed>>




[[email protected] store]# ls
cca_upgrade-4.6.1  cca_upgrade-4.6.1-NO-WEB.tar.gz
[[email protected] store]# cd cca_upgrade-4.6.1
[[email protected] cca_upgrade-4.6.1]# ls
agent-version.sh          dmidecode           RPMS               version.sh
cca_upgrade-4.1.6.tar.gz  initrd.img          server-upgrade.sh
checksum.txt              manager-upgrade.sh  showstate.sh
checksum.txt.sig          notes.html          UPGRADE.sh
[[email protected] cca_upgrade-4.6.1]#
[[email protected] cca_upgrade-4.6.1]# ./UPGRADE.sh
Please choose whether to upgrade Windows Agent to (It's highly recommended to upgrade) (y/n)? [y]
Please choose whether to upgrade Mac Agent to (It's highly recommended to upgrade) (y/n)? [y]

...stopping CCA Manager...
Start upgrading database's encoding to UTF8...

Welcome to the CCA Manager migration utility.

...Upgrading to newer rpms of 4.6.1...done.
...Upgrading CCA files...done
Windows Agent version upgraded to
Mac Agent was upgraded to version
Clearing Tomcat cache...checking ssl configuration...done.
[[email protected] cca_upgrade-4.6.1]# cd ..

[[email protected] store]#
[[email protected] store]# ls
cca_upgrade-4.6.1                cca_upgrade-4.8.0-from-4.6.x.tar.gz
[[email protected] store]# tar xzvf cca_upgrade-4.8.0-from-4.6.x.tar.gz
[[email protected] store]# ls
cca_upgrade-4.6.1                cca_upgrade-4.8.0
cca_upgrade-4.6.1-NO-WEB.tar.gz  cca_upgrade-4.8.0-from-4.6.x.tar.gz
[[email protected] store]# cd cca_upgrade-4.8.0
[[email protected] cca_upgrade-4.8.0]# ls
nac.iso  UPGRADE.sh
[[email protected] cca_upgrade-4.8.0]# ./UPGRADE.sh
Identified platform is 3310
Checking for a free partition to use for upgrade
Found free partition to use at /dev/sda3
Free partition size is 1044225 KB
Free partition doesn't have enough disk space for upgrade
Upgrade needs free partition of at least 1 GB.
[[email protected] cca_upgrade-4.8.0]# cd ..
[[email protected] store]#

looking for answers, does any one pass throught this? I just recently made an upgrade from 4.6.1 to 4.8.0 without this problem the difference basically is that the CAM/CAS originally has the 4.6.1 from factory.

It looks like a bug, am I right??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
JUAN HUICAB Tue, 09/21/2010 - 07:12

I´ve tried both ways, in one of them I reboot the appliance applying "Service Perfigo Reboot" and the other without rebooting, same result "not enogh space in partition"

JUAN HUICAB Thu, 09/30/2010 - 10:44

We´re working in a "workaround" the thing is that the partition  4.1.6 --> 4.6.1 upgrade use for any reason the space reamin ocuped with something that we dont´know, making imposible upgrade to any version over this one.

Once we finsh the upgrade I´ll put the result for you could see the procedure that we followed.


Prasanth Mathews Sun, 11/21/2010 - 21:40

Can you tell me the status of the workaround? did it work? what did you do?


Prasanth Mathews

JUAN HUICAB Tue, 11/23/2010 - 22:45


Finally I could tell you that the upgrade script  to  take 4.1.6 to 4.6.1 has something that affects the CAM Lite edition that´s why any other procedure after that fails.

In my case this was only a Lab to prepare to a mayor movement over a HA-Supercams(2) with 10 HA-CAS (20) OOBVG/IBVG.

We start the procedure with three choices: (our main option was b)

a) Start the normal upgrade steps then if the failure occurs take option "b" or "c" , if not, finish the upgrade following the documentation.

b) We prepare the movement by open a TAC SR in wich the engineer convert the data base in their labs and then, in case "a" fail we could apply the ISO of 4.8.0 and then restore the snapshot.

c) Start the procedure  first go from 4.1.6 to 4.6.1 then make a snapshot, backup that file, apply the ISO for 4.6.1 then restore the snapshot and continue the upgrade to 4.8.0.

Conclusion: The "bug" only affect the CAM Lite Family, option "a" works for Super Cams



This Discussion