Unable to change tftp address in IP Communicator 7.0.5

Unanswered Question
Joseph Martini Tue, 09/21/2010 - 10:24

Are you logged in or running CIPC 7.0.5 as an administrator and/or the same user that installed it?

rtrees Tue, 09/21/2010 - 14:28

I have the same problem.  New laptop, logged in as myself (Domain Admin), installed the software, rebooted and after going through the audio tuning wizard it goes directly into the phone and can't finish connecting.  Looking at the network properties it is all greyed out also.

rtrees Wed, 09/22/2010 - 14:31

We just installed this on a nother machine and it did the same thing.  On the first one I ended up having to right-click on IPC and say run as Administrator then the settings were not greyed out.  I made changes and closed then reopened IPC and it removed my settings and greyed everything out again.  The only way I got it to stick was to export the settings from my laptop then modify the reg file and put in their MAC address then import it to the problem laptop, then it worked.  I even tried going back to 7.0.4 and it did the same thing.

rtrees Thu, 09/23/2010 - 10:02

Good to know that worked but hopefully Cisco will fix it, adding our users to the administrators group is not an option :-).

Matthew Kaufman Thu, 09/23/2010 - 18:26

These settings will require administrator access to change.  I believe this change was made because of users inadvertently changing their settings.  IPC is intended to be deployed by an administrator as would something like AV software.


rtrees Fri, 09/24/2010 - 08:11

I can understand this however if I start IPC as an administrator and it allows me to change the settings I would expect it to save those settings which it does not.  I would also expect that if I log in as an administrator (Domain Admin in my case) that it would allow me to change and save my settings but it didn't do that either.  I did not try to re-enable the local administrator which is disabled by default and try to log in with that.  I would not expect to have to do that just to set this the first time, not when Win7 has better ways of running as administrator without having to enable any disabled accounts.

rtrees Fri, 09/24/2010 - 08:18

Yes, when you add a computer to the domain the Domain Admins AD group is automatically added to the local Administrators group.

Joseph Falba Thu, 12/16/2010 - 12:12

Just had this same problem.  I could chane my network adapter settings and tftp servers, but other network engineer could NOT.

The difference was the setup file.  I used the CiscoIPCommunicatorSetup.exe (Application) installation and COULD change adapter and tftp.

Other network enginer used the CiscoIPCommunicatorSetup.msi (Windows Installer Package) and COULD NOT change adapter and tftp.

Hopefully checking your setup file will help ?!

rtrees Thu, 12/16/2010 - 15:51

Now that's interesting. Thanks, we'll give it a try.

dankennedy Thu, 12/23/2010 - 08:45

Made no difference on Windows 7 using .msi or .exe

However, if you run in XP compatiblity mode you can access all of these settings without problem.

I have tried this on Windows 7 32 and 64bit and it works fine.

jcheisel84 Mon, 09/12/2011 - 07:54

This worked for me. I was already part of the Administrators group, which I read above would fix it, but it was still grayed out for me. It wasn't until I changed the compatibility mode to operate on XP that I was finally able to change the TFTP.


michael mack Sun, 01/16/2011 - 13:25

Same issue.  Installed with the .msi and could not change any network settings no matter what I tried.  Uninstalled the application, then reinstalled using the .exe.  No problems, everything seemed to work fine.  Didn't have to mark it as XP compatible or run as administrator at all.

I noticed that the install seemed to do a lot more things in the background when I used the .exe installer.

j.manley Tue, 02/01/2011 - 08:42

I had the same problem with the options being unavailable.

Once I uninstalled and reinstalled the IPC using the .exe.  Everything was visible again.

antonio.vazquez Wed, 05/18/2011 - 03:31


other solution to solve this is execute IP COmm software as a Administrator (I have tested it on Windows 7).


Mark Walters Thu, 07/28/2011 - 09:40

One small note:  Selecting 'run as administrator' didn't appear to work for me at first.  Turns out I wasn't closing the application all the way before trying to run it again as adminstator. 

In the preferences pane I unchecked "close hides application", closed the app, then ran as administrator.  viola.



dianareyes Fri, 02/26/2016 - 12:45

After trying several troubleshooting steps, this worked for me!  

Great post, thank you!

rubendehaas Thu, 02/09/2012 - 22:31

I had the same problem with IP Communicator 8.6 installed on Windows 7 32 bit.

Totally Close Ip communicator. Just go to the original program in menu start. Go to All Programs ==> Ip Communicator ==> right click ==> Run as administrator. Start CIPC. Now you are able tochange the TFTP and other netwotrk settings.

mariolink Fri, 05/11/2012 - 09:26

Runing it as administrator works perfectly, I guess that's the only easy option, so everytime you need to change the tftp server or something run th IP Communicator as administrator

Armando De La Torre Wed, 10/03/2012 - 09:56

I installed the .exe file and had the network setting grayed out.  I unistalled that and reinstall the .msi and keep having the same problem.

I still had the .msi installed and close it out and then run it as Administrator , it took few seconds to reload and now I was able to modify network settings (tftp server)

Im sure that the same procedure can be done on the .exe file, but since it's working for me now. I would remain with the msi.  good luck

Ben Morgan Tue, 11/20/2012 - 17:32

I disabled UAC on the my Win7 PC. After that, I dont have to login via the right-click run as adminstrator, just click on the shortcut as per normal and can change profiles now between SIP and SCCP.

No re-install required.

Essam H Fri, 02/21/2014 - 15:57

Unless local access is disabled, users can also specify this setting in Cisco IP Communicator (right-click > Preferences > Network tab > TFTP Servers section), but you must tell them which TFTP server addresses to enter.

  If your company uses Cisco IP Communicator in  an environment where users do not have administrative privileges, and if  multiple users share a PC, this task cannot be completed by the user.  You must use an administrator account to run Cisco IP Communicator one  time after installation on each machine and select the network interface  (if this selection is required). This instruction also applies to  selecting network interface (device name) in this circumstance.

roberts02 Fri, 08/05/2016 - 08:43

One other thing to consider. Windows 7 on up defaults the local administrator as disabled. The account has to be enabled in order for the run as administrator to work. That's where I ran into trouble.


This Discussion