Bonjour Services doesn't work in WLC based wireless network

Unanswered Question
Sep 21st, 2010

Hello,

i have problem with bonjour services in Cisco WLC based network.

i have wlc 2106 running 6.0.182.0 firmware and some LAP1252 acess points.

I have 802.1x based authetication with ACS server enabled to distribute domain users in different subnets according to their privileges, but in this case in case i have problem with users in same subnet, e.g. Macbook has ip 192.168.14.10 and Iphone has 192.168.14.15 and they couldn't connect to each other using bonjour Services.

i found this on cisco site and done it but id didn't help.

A. Bonjour is a general method used to discover services on a local area network (LAN). This technology is widely used with Mac OS X and allows users to set up a network without the need to configure printers and file sharing servers (and so forth) on a LAN.

Bonjour uses broadcast, multicast, and multicast Domain Name System (mDNS) service records in order to locate devices, such as printers, other computers, and the services that those devices offer.

In order to correct this issue, use these commands to enable broadcast and multicast on your WLC:

config network broadcast enable

config network multicast global enable

https://www.cisco.com/en/US/products/hw/wireless/ps4555/products_qanda_item09186a0080192f97.shtml

This Bonjour services work in other D-link or some third party wifi environments, but not in Cisco WLC based...

Can anyone help me?

Thank You!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
fziliott Tue, 10/12/2010 - 10:53

Hello,

From the output of "show network summary" you should be able to confirm the brodcast/multicast settings on your WLC. For example

Ethernet Multicast Forwarding............... Enable
Ethernet Broadcast Forwarding............... Enable
AP Multicast/Broadcast Mode................. Unicast

In particular, if you are using the "AP Multicast/Broadcast Mode" to Multicast, it would be a useful test to change it to unicast:

config network multicast mode unicast

If this mitigates the issue, there may be a problem in the multicast configuration of the wired network behind the WLC/AP.

If the AP multicast mode is already set to unicast, and both broadcast and multicast modes are enabled, it would probably be more efficient to open a TAC case.

Regards,

Fede

ccna-viva Tue, 10/12/2010 - 23:47

Hello Federico,

Thank you for reply,

in config file i have

Ethernet Multicast Forwarding............... Enable
Ethernet Broadcast Forwarding............... Enable

but in AP multicast mode i have only multicast mode option, no unicast

Network Information

RF-Network Name............................. GGGG

Web Mode.................................... Disable

Secure Web Mode............................. Enable

Secure Web Mode Cipher-Option High.......... Disable

Secure Web Mode Cipher-Option SSLv2......... Enable

Secure Shell (ssh).......................... Enable

Telnet...................................... Enable

Ethernet Multicast Mode..................... Enable   Mode: Mcast  235.0.0.1

Ethernet Broadcast Mode..................... Enable

AP Multicast Mode........................... Multicast   Address : 235.0.0.1

IGMP snooping............................... Enabled

IGMP timeout................................ 60 seconds

User Idle Timeout........................... 300 seconds

ARP Idle Timeout............................ 300 seconds

Cisco AP Default Master..................... Disable

AP Join Priority............................ Disable

Mgmt Via Wireless Interface................. Enable

Mgmt Via Dynamic Interface.................. Disable

Bridge MAC filter Config.................... Enable

Bridge Security Mode........................ EAP

Mesh Full Sector DFS........................ Enable

i have changed multicas ip several times, i have read it was an issue for some people, but in my case it didn't help...

also i havent't got smartnet for this wlc, so i cant open TAC case...

Regards,

Irakli

fziliott Wed, 10/13/2010 - 02:22

Hi Irakli,

2100 series controllers in fact do not support multicast-unicast mode, apologies for not having read correctly your very first post.

The configuration should be just fine, but I'd suggest to further the check the wired infrastructure behind too.

Some useful tips to verify the multicast communications should be available from the config guides:

http://www.cisco.com/en/US/docs/wireless/controller/6.0/configuration/guide/c60ccfg.html#wp1243876

Regards,

Fede

Actions

Login or Register to take actions

This Discussion

Posted September 21, 2010 at 6:10 AM
Stats:
Replies:3 Avg. Rating:
Views:9686 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard