SPA50x - XML Directory Service - Next softkey not working.

Unanswered Question
Jul 20th, 2010

I am attempting to use the XML Directory Service on a SPA508g with firmware 7.4.3 and 7.4.4.

Our directory service is working correctly with the Cisco 79x0 devices. However when we try the same feature on the newer SPA508g everything appears to work correctly except for the Next softkey.

The Next softkey uses the 'refresh' header to figure out how to get to the next page and we are passing something like

refresh: 0; url=http://oururl/directoryscript.cfg?mac=$MA&someotherthings=blah

Via syslog I see that the phone has seen that I pressed the next softkey. syslog: "A<134>CMX:NEXT", yet it does not attempt to contact our server for the next page (checked with wireshark at the phone side).

Has anyone had any success with this on this series of devices? Any suggestions?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
alexanderlitvak Fri, 07/30/2010 - 14:10

I am still having this issue... Works fine on older Cisco phones not on the new 50x series.

Anyone?

alexanderlitvak Mon, 08/16/2010 - 12:35

I have now tried the just released 7.4.6 version because of the comment in the change notes:

"Added support for HTTP refresh header in Cisco XML"

Sounded like it might be related, however it still does not fix the issue I am having. The Next button appears to fail to function with this device, yet functions correctly with the 79xx.

Anyone have ideas?

alexanderlitvak Tue, 09/21/2010 - 09:55

I am still stuck here!

Hey Cisco any suggestions? I think it is a bug. Can you confirm that it is functioning correctly? Is there any more information you need?

Thanks,

nseto Fri, 09/24/2010 - 11:15

Please enclosed the entire xml config file so that we can take a look. Thanks.

Patrick Born Mon, 09/27/2010 - 11:03

Hi Alex,

Steve supplied me additional information which I shared with Nelson [nseto] and the team.

I have opened CDETS CSCtj16034 and CSCtj16200 for the SPA525G and the SPA50x respectively and will keep Steve updated.

Regards,

Patrick

----------

Patrick Born Tue, 11/30/2010 - 09:48

Hi Alex,

I've sent Steve an email with a link to SPA525G and SPA50xG test firmware.

Please verify that we've resolved the reported issue.

Regards,

Patrick

----------

Actions

This Discussion

Related Content