Netflix streaming issues on Ironport

Unanswered Question
Sep 21st, 2010

Hi All,

I'm having some issues getting Netflix to stream with Ironport properly.  It seems to stream intermittently, sometimes it works poorly and sometimes I get an error message in the browser.  The error seems to occur when Netflix is determining my video quality.  Even when it works the video quality is extremely poor, which further leads me to believe that there is a problem with the determining video quality step.

I ran a GREP and found this right about the time where the video quality is determined and right before the error message pops up.  The GREP is below.

Any ideas?  Thanks!

1285100677.171 265 TCP_MISS/200 896 GET "USM\[email protected]" DIRECT/ - ALLOW_WBRS-UnfilteredWebAccess-RestrictedWebAccess_Identity-NONE-DefaultRouting <-,6.7,-,-,-,-,-,-,-,-,-,-,-,-,-,-,-> - "Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.59 Safari/534.3"
1285100677.879 218 TCP_MISS/200 641 GET "USM\[email protected]" DIRECT/ - ALLOW_WBRS-UnfilteredWebAccess-RestrictedWebAccess_Identity-NONE-DefaultRouting <-,6.7,-,-,-,-,-,-,-,-,-,-,-,-,-,-,-> - "Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.59 Safari/534.3"
1285100679.610 3931 TCP_MISS/200 616832 GET "USM\[email protected]" DIRECT/ - ALLOW_WBRS-UnfilteredWebAccess-RestrictedWebAccess_Identity-NONE-DefaultRouting <Shop,7.3,-,-,-,-,-,-,-,-,-,-,-,-,-,Shop,-> - "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.2; MS-RTC EA 2)"
1285100681.001 353 TCP_MISS/200 3020 TCP_CONNECT - DIRECT/ - PASSTHRU_WEBCAT-DefaultGroup-UA_Exempt_Identity-NONE-DefaultRouting <Ente,0.0,-,-,-,-,-,-,-,-,-,-,-,-,-,Ente,-> - -
1285100681.273 264 TCP_MISS/200 2700 TCP_CONNECT - DIRECT/ - PASSTHRU_WEBCAT-DefaultGroup-UA_Exempt_Identity-NONE-DefaultRouting <Ente,0.0,-,-,-,-,-,-,-,-,-,-,-,-,-,Ente,-> - -
1285100681.913 306 TCP_MISS/200 6316 TCP_CONNECT - DIRECT/ - PASSTHRU_WEBCAT-DefaultGroup-UA_Exempt_Identity-NONE-DefaultRouting <Ente,0.0,-,-,-,-,-,-,-,-,-,-,-,-,-,Ente,-> - -
1285100682.342 308 TCP_MISS/200 2924 TCP_CONNECT - DIRECT/ - PASSTHRU_WEBCAT-DefaultGroup-UA_Exempt_Identity-NONE-DefaultRouting <Ente,0.0,-,-,-,-,-,-,-,-,-,-,-,-,-,Ente,-> - -
1285100682.759 374 TCP_MISS/200 14481 TCP_CONNECT - DIRECT/ - PASSTHRU_WEBCAT-DefaultGroup-UA_Exempt_Identity-NONE-DefaultRouting <Ente,0.0,-,-,-,-,-,-,-,-,-,-,-,-,-,Ente,-> - -
1285100705.203 56863 TCP_MISS/200 7367 TCP_CONNECT - DIRECT/ - PASSTHRU_WEBCAT-DefaultGroup-UA_Exempt_Identity-NONE-DefaultRouting <Web-,6.1,-,-,-,-,-,-,-,-,-,-,-,-,-,Web-,-> - -

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
edadios Thu, 09/23/2010 - 21:55

The logs you provided suggest no blocking from the ironport.

TCP Miss means the request is not in cache

Can you maybe try to disable the caching, and see if that makes it work better?

In the GUI > Security Services > Proxy settings > edit settings > remove the check in the box for cache , submit and commit.


cshannahan Thu, 09/06/2012 - 08:20

I'm getting the same thing with my Ironport and Netflix, it seems to be mainly on the Ipad app though.

Did you ever figure this out?

joewilker Mon, 10/15/2012 - 06:11

I'm having similar issues.  It did start around the same time as we installed the ironport, although all tests through the ironport suggest that its not the ironport that is blocking it.   Our issues seem to be through our wireless with the Wii, and the Reko.  Our wireless goes through a Cisco Wireless Lan Controller.  Could it be the ironport is slowing down the connection for the netflix streaming connection tests and Netflix is assuming a bad connection? 

cshannahan Mon, 10/15/2012 - 06:15

I was able to resolve my netflix issues by turning off what I think is called free range requests via the command line.  It was a known issue.

Also, I was told that they have fixed this so it will work with that on with the latest version.  Good luck.

joewilker Mon, 10/15/2012 - 18:02

Updated to the latest version, but still no luck.  Do you have any instructions on turning off the "free range requests"?  I did a google search and came up with nothing.

cshannahan Tue, 10/16/2012 - 06:26

SSH to the box and disable "rangerequestdownload".

Just do a ? when you log in and you will see it at the bottom.  Disable it then try.

I had issues and Ironport told me to turn that off which worked.

joewilker Wed, 10/24/2012 - 13:09

Checked and it was already disabled.  I've opened up a case with IronPort support last week.  Hopefully, they will get to it sometime this century.  Thanks for your help though.

joewilker Tue, 12/11/2012 - 17:21

Netflix streaming, and iTunes downloads seems to be a known issue with Ironport.  We ended up just creating a custom URL and dumpped all the IP ranges for Netflix and iTunes, which fixed the problem for us.  Ironport support said that was the best option.

Andrius Ajauskas Wed, 01/16/2013 - 04:20

Hi Joseph,

could you please share the IP ranges for Netflix ? i am facing the same problem.

joewilker Wed, 01/16/2013 - 04:36

Netflix IP Range:,,,,,,,,,,,,,,,


This Discussion