cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1433
Views
3
Helpful
1
Replies

witch etherchannel load-balance?

eugene.fit
Level 1
Level 1

Hi all!

I have 3 L2 links between offices. Each of them caonfigured as 10mb/s. I tryed to use etherchannel and load-balance, but didn't meet real balance. Is it because of traffics flow, or misconfiguration? I just can't catch equal load-balance between links. May be there are any problems on provider side, but I am not sure. May be I should change balance algorithm?


SW1

SW1#sh run int Gi2/7
Building configuration...

Current configuration : 169 bytes
!
interface GigabitEthernet2/7
switchport
switchport access vlan 301
switchport mode access
speed 10
duplex full
flowcontrol send on
channel-group 2 mode on
end

SW1#sh run int Gi2/8
Building configuration...

Current configuration : 169 bytes
!
interface GigabitEthernet2/8
switchport
switchport access vlan 301
switchport mode access
speed 10
duplex full
flowcontrol send on
channel-group 2 mode on
end

SW1#sh run int Gi2/9
Building configuration...

Current configuration : 169 bytes
!
interface GigabitEthernet2/9
switchport
switchport access vlan 301
switchport mode access
speed 10
duplex full
flowcontrol send on
channel-group 2 mode on
end

SW1#sh run int port-channel 2
Building configuration...

Current configuration : 149 bytes
!
interface Port-channel2
switchport
switchport access vlan 301
switchport mode access
flowcontrol send on
spanning-tree bpdufilter enable
end

SW1#sh etherchannel 2 summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port

        w - waiting to be aggregated
Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(SU)          -        Gi2/7(P)       Gi2/8(P)       Gi2/9(P)

Last applied Hash Distribution Algorithm: Fixed

SW1#sh etherchannel load-balance
EtherChannel Load-Balancing Configuration:
        src-dst-mixed-ip-port
        mpls label-ip

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
  IPv4: Source XOR Destination IP address and TCP/UDP (layer-4) port number
  IPv6: Source XOR Destination IP address
  MPLS: Label or IP

SW1#sh etherchannel 2 port-channel
                Port-channels in the group:
                ----------------------

Port-channel: Po2
------------

Age of the Port-channel   = 0d:21h:06m:43s
Logical slot/port   = 14/2          Number of ports = 3
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =    -
Fast-switchover     = disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     49     Gi2/7    On    3
  2     92     Gi2/8    On    3
  1     24     Gi2/9    On    2

Time since last port bundled:    0d:20h:38m:03s    Gi2/9
Time since last port Un-bundled: 0d:20h:38m:03s    Gi2/9

Last applied Hash Distribution Algorithm: Fixed

SW2

SW2#sh run int Gi1/32
Building configuration...

Current configuration : 170 bytes
!
interface GigabitEthernet1/32
switchport
switchport access vlan 301
switchport mode access
speed 10
duplex full
flowcontrol send on
channel-group 2 mode on
end

SW2#sh run int Gi1/36
Building configuration...

Current configuration : 170 bytes
!
interface GigabitEthernet1/36
switchport
switchport access vlan 301
switchport mode access
speed 10
duplex full
flowcontrol send on
channel-group 2 mode on
end

SW2#sh run int Gi1/42
Building configuration...

Current configuration : 170 bytes
!
interface GigabitEthernet1/42
switchport
switchport access vlan 301
switchport mode access
speed 10
duplex full
flowcontrol send on
channel-group 2 mode on
end

SW2#sh run int port-channel 2
Building configuration...

Current configuration : 187 bytes
!
interface Port-channel2
switchport
switchport access vlan 301
switchport trunk encapsulation dot1q
switchport mode access
flowcontrol send on
spanning-tree bpdufilter enable
end

SW2#sh etherchannel 2 summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port

        w - waiting to be aggregated
Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(SU)          -        Gi1/32(P)      Gi1/36(P)      Gi1/42(P)

Last applied Hash Distribution Algorithm: Fixed

SW2#sh etherchannel load-balance
EtherChannel Load-Balancing Configuration:
        src-dst-mixed-ip-port
        mpls label-ip

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
  IPv4: Source XOR Destination IP address and TCP/UDP (layer-4) port number
  IPv6: Source XOR Destination IP address
  MPLS: Label or IP

SW2#sh etherchannel 2 port-channel
                Port-channels in the group:
                ----------------------

Port-channel: Po2
------------

Age of the Port-channel   = 2d:20h:59m:58s
Logical slot/port   = 14/2          Number of ports = 3
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =    -
Fast-switchover     = disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  1     49     Gi1/32   On    3
  0     92     Gi1/36   On    3
  2     24     Gi1/42   On    2

Time since last port bundled:    0d:11h:29m:48s    Gi1/32
Time since last port Un-bundled: 0d:11h:29m:50s    Gi1/32

Last applied Hash Distribution Algorithm: Fixed

1 Reply 1

Peter Paluch
Cisco Employee
Cisco Employee

Evgeny,

The load balacing on EtherChannels will never be totally perfect, and will be significantly uneven if the number of active ports in a bundle is not a power of 2 (i.e. 2, 4 or 8). For information on details how the load balancing on EtherChannel works, see the following document:

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml

In general, to achieve the maximum "spreading" of your trafic among the links in an EtherChannel bundle, you should consfigure the load balancing method to make its decisions on addressing fields that are varying the most in your traffic. This will require some analysis or at least making an educated guess as to decide what will give you the highest degree of randomness - MAC addresses, IP addresses, L4 ports...

Best regards,

Peter

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: