CME - SIP Trunk - Outgoing calls delay

Answered Question
Sep 22nd, 2010

Hello,

I have a Cisco 2801 directly accessing the Internet via a public IP address and it is working fine, I can make or receive calls with no problem. I then moved the 2801 inside of my local network and tried to use it the same way. The fact is I can receive calls with no problems but when I try to place and outgoing call the phone dials but wait for almost a minute with no tone or anything. Then around one minute later the call is made, I don't think this is an interdigit timeout problem given that the phone actualy dials the number.

My configuration is as follows :

Current configuration : 10012 bytes
!
! Last configuration change at 10:38:53 gw Wed Sep 22 2010 by cisco
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco2801
!
boot-start-marker
boot system flash:c2801-advipservicesk9-mz.151-2.T1.bin
boot-end-marker
!
!
logging buffered 51200 warnings
enable password !lie*cri.
!
no aaa new-model
!
clock timezone gw 1 0
network-clock-participate wic 0
dot11 syslog
ip source-route
!
!
no ip dhcp use vrf connected
!
ip dhcp pool voix
    network 192.168.0.0 255.255.255.0
    option 150 ip 192.168.0.251
    default-router 192.168.0.251
    dns-server 212.27.54.252
!
ip cef
ip domain name yourdomain.com
ip name-server 10.99.0.7
ip name-server 10.99.0.8
ip name-server 10.99.0.20
ip name-server 10.99.0.50
ip name-server 194.2.0.20
no ipv6 cef
!
multilink bundle-name authenticated
!
voice service voip
  ip address trusted list
   ipv4 0.0.0.0 0.0.0.0
  gcid
  no cti shutdown
  callmonitor
  allow-connections h323 to h323
  allow-connections h323 to sip
  allow-connections sip to h323
  allow-connections sip to sip
  no supplementary-service sip moved-temporarily
  no supplementary-service sip refer
  sip
   registrar server expires max 120 min 60
!
!
voice iec syslog
voice register global
  mode cme
  max-dn 144
  max-pool 24
!
voice register session-server  1
  keepalive 60
  register-id OCT_CME
!
voice register session-server  2
  keepalive 60
  register-id OCT_CME2
  cti-aware
!
voice register dn  5
  session-server 1
!
voice register dn  6
  session-server 1
!
voice translation-rule 1
  rule 1 /.*/ /975172273/
!
voice translation-rule 2
  rule 1 /^.*/ /404/
!
!
voice translation-profile inclid
  translate called 2
!
voice translation-profile outclid
  translate calling 1
!
interface Loopback0
  ip address 109.69.196.138 255.255.255.255
  h323-gateway voip interface
  h323-gateway voip bind srcaddr 109.69.196.138
!
interface FastEthernet0/0
  description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
  ip address 192.168.0.251 255.255.255.0
  ip nat inside
  ip virtual-reassembly in
  no ip route-cache cef
  no ip route-cache
  duplex auto
  speed auto
!
interface FastEthernet0/1
  ip dhcp relay information policy-action drop
  ip address 10.99.80.246 255.255.0.0
  ip nat outside
  ip virtual-reassembly in
  no ip route-cache cef
  no ip route-cache
  duplex auto
  speed auto
!
interface BRI0/0/0
  no ip address
!
interface BRI0/0/1
  no ip address
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:
ip nat inside source list 115 interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 109.69.196.137
ip route 0.0.0.0 0.0.0.0 10.99.0.207
!
logging esm config
access-list 115 permit ip 192.168.0.0 0.0.0.255 any
!
ixi transport http
  response size 64
  no shutdown
  request outstanding 1
  request timeout 60
!
ixi application cme
  response timeout 30
  no shutdown
!
voice-port 0/0/0
!
voice-port 0/0/1
!
dial-peer voice 1 voip
  translation-profile incoming inclid
  translation-profile outgoing outclid
  destination-pattern ..........
  session protocol sipv2
  session target dns:sip5.voip-centrex.net
  incoming called-number .
  codec g711ulaw
!
!
sip-ua
  credentials username mysiplogin  password 7 09051D5C414C0E081B1733 realm sip5.voip-centrex.net
  authentication username mysiplogin password 7 155B58595C63323E382802 realm sip5.voip-centrex.net
  retry register 10
  registrar dns:sip5.voip-centrex.net expires 3600
  registrar dns:sip5.voip-centrex.net expires 3600 secondary
!
!
!
telephony-service
  xml user infologic password infologic 15
  max-ephones 8
  max-dn 8
  ip source-address 192.168.0.251 port 2000
  auto assign 1 to 8
  load 7910 P00403020214
  load 7912 CP7912080003SCCP070409A
  load 7960-7940 P00305000301
  time-format 24
  date-format dd-mm-yy
  dialplan-pattern 1 4.. extension-length 3
  max-conferences 4 gain -6
  moh Terre.wav
  transfer-system full-consult
  log table retain-timer 30
  log table max-size 100
  create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
  session-server 1
  number 1001 no-reg primary
  name Apple Bee
  cti watch
!
ephone-dn  5  dual-line
  number 404
  cti watch
!
ephone-dn  6  dual-line
  number 405 no-reg primary
  cti watch
!
ephone  5
  device-security-mode none
  mac-address 0013.C353.09CD
  type 7912
  button  1:5
!
ephone  6
  device-security-mode none
  mac-address 0013.C353.0506
  type 7912
  button  1:6
!

end

My 2801 is now on the 10.99.0.0 local network and access the Internet through the 109.69.196.140 ip address.

I have this problem too.
0 votes
Correct Answer by Walter Solano about 6 years 2 months ago

Hello,

I would like to know if you already tried to use IP address if you ITSP under the sip-ua configuration instead of the FQN, just to disscard any issue with the DNS resolution taken so long.

Also I would like to see the output of the debug ccsip messsages and ccapi when doing the call.

HTH

Please rate this post if was helpful

Walter Solano

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Walter Solano Wed, 09/22/2010 - 05:31

Hello,

I would like to know if you already tried to use IP address if you ITSP under the sip-ua configuration instead of the FQN, just to disscard any issue with the DNS resolution taken so long.

Also I would like to see the output of the debug ccsip messsages and ccapi when doing the call.

HTH

Please rate this post if was helpful

Walter Solano

infologic Wed, 09/22/2010 - 07:36

Hello,

Thanks for your answer, it was indeed the dns resolution taking too long, I changed the dns-server adress and everything works fine. Once again thanks for the fast answer.

Walter Solano Wed, 09/22/2010 - 07:45

Hello,

Is good to hear that now everything is working

Best regards

Walter Solano.

Actions

This Discussion