Cisco 9971 Retry video call as audio not available on CCM 7.1.5

Unanswered Question
Sep 22nd, 2010
User Badges:

Hi


I am running CCM version 7.1.5. My problem is that when i have video capabilities enabled, i am unable to ring external mobile phones. When i disable this, mobile calls work fine. On previous versions of CCM, you were able to tick a box saying 'retry video call as audio'. This tick box seems not to be available in CCM version 7.1.5(even though it says its available in the help page. This is affecting my 9971 phones. has anyone come across this before?




Thanks,
Derek

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Lakshmi Adapala Fri, 09/24/2010 - 12:43
User Badges:
  • Cisco Employee,

Hi Derek,


I think the new CCMAdmin for a 99XX device will not expose the "Retry Video Call as Audio" option but it is set to true in the database.


You can verify that it is set to true in database by running the SQL query from the CLI (SSH session). The following example is using the MAC address of the 9971 phone


adin:run sql select pkid from device where name = 'SEP00230432C385'

retryvideocallasaudio
=====================
t


You can find the PKID of the device using MAC and can also verify this setting  as follows



admin:run sql select pkid from device where name = 'SEP00230432C385'
pkid
====================================
df354918-4a8d-4ed5-838e-b401e774bce5


admin:run sql select name,retryvideocallasaudio from device where pkid = 'df354918-4a8d-4ed5-838e-b401e774bce5'
name            retryvideocallasaudio
=============== =====================
SEP00230432C385 t
admin:

Derek McCormick Tue, 11/09/2010 - 08:37
User Badges:

looks to me like some kind of software bug. The phone defaults to retry as audio, but it doesn't work.

Lakshmi Adapala Wed, 11/10/2010 - 09:52
User Badges:
  • Cisco Employee,

Hi Derek,


If you run the sql query what are you seeing the value for retry as audio (true or false , t or f) ? If it is set to t and still not working then it will be another issue.


Thanks,

Lakshmi

Pavel K Tue, 12/14/2010 - 05:37
User Badges:

Found the solution.

In voice gateway configuration you need to add bearer-cap speech command in the section voice-port


looks like:


voice-port 1/1:23

bearer-cap speech

Actions

This Discussion