EASy install problem

Answered Question
Sep 22nd, 2010

I have Version 12.4(24)T3 on my 3845.

I am trying to install the easy-packet-capture.tar I downloaded from the EASy download site.

I get this error after I run the easy-installer script:

Router#easy-installer tftp://xx.xx.xx.xx/easy-packet-capture.tar flash:/easy
Loading easy-installer.tcl from xx.xx.xx.xx (via GigabitEthernet0/0): !
[OK - 39496 bytes]

ERROR: Failed to import the package configuration: 'couldn't read file
"flash:/easy/easytmpULh79s/pkgconfig": File not found'

Thanks in advance.


I have this problem too.
0 votes
Correct Answer by Joe Clarke about 6 years 2 weeks ago

Yeah, that is my internal server.  I have pointed out the problem with the link to someone that can get it fixed.  In the meantime, here is the installer.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Delfino Tiongco Wed, 09/22/2010 - 12:13

Below is the result when I run the easy-installer with debug:

ERROR: Failed to import the package configuration: 'couldn't read file
"flash:/easy/easytmpULh79s/pkgconfig": File not found'

Router#easy-installer --debug tftp://xx.xx.xx.xx/easy-packet-capture.tar flash:
Loading easy-installer.tcl from xx.xx.xx.xx (via GigabitEthernet0/0): !
[OK - 39496 bytes]

INFO: exec_cli: Running command 'show event manager environment __easy_PREFIX'

INFO: exec_cli: Output from command: 'No such environment variable defined.'

INFO: exec_cli: Running command 'show running | include ^file prompt quiet'

INFO: exec_cli: Output from command: ''

INFO: exec_cli: Running command 'mkdir flash:/easytmpth4DAt'

INFO: exec_cli: Output from command: 'Created dir flash:/easytmpth4DAt'

INFO: exec_cli: Running command 'archive tar /xtract
tftp://xx.xx.xx.xx/easy-packet-capture.tar flash://easytmpth4DAt'

INFO: exec_cli: Output from command: 'extracting ap_easy_epc_export.tcl (8437
%Error opening flash://easytmpth4DAt/ap_easy_epc_export.tcl (I/O Error on

ERROR: Failed to extract tftp://xx.xx.xx.xx/easy-packet-capture.tar to flash:/:
'Error extracting the package: 'I/O Error on read''

Joe Clarke Wed, 09/22/2010 - 21:08

Looks like there is a problem loading the package file from TFTP.  You're getting an I/O error.  Can you copy the tar file to the device's flash using a different copy method, then run easy-installer against the local copy of the tar file?  I tested the tar file you posted here, and it works fine for me locally.

Delfino Tiongco Thu, 09/23/2010 - 08:52


Thanks for the test. I will install them on another same model router and different Compact Flash. I will post the result. Also, is there a need to register this policy?

Kind regards,


Delfino Tiongco Mon, 09/27/2010 - 10:58

Hi Joe,

Here is what I have done so far.

I used a different compact flash and formatted and run fsck to make sure the CF is good. I installed the same IOS version. I was able to install the whole application until I am asked " Are you satisfied with these settings? (y/n) [y]: 

When I say yes, I get the following error:

"Configure EEM Environment Variables for 'easy-packet-capture-1.0'

ERROR: Step do_configure failed: 'list must have an even number of elements' "

Kind regards,


Delfino Tiongco Wed, 09/29/2010 - 10:33

Hi Joe,

I am successful in the installing and  running the new easy-packet-capture.tar you sent me.

My next inquiry is: After I saved the run-conf and reload my test router, I lost all the functionality of the package. When i run the "event manager run no_easy_epc_start/stop.tcl", there are no packets captured. I run the "sh monitor capture point cappnt" and I get this reply "Capture point cappnt does not exist".

When I reinstall the package, though I get an error telling me the package is already installed; I regain all the functionality of the package.

Sorry, I am not a programmer.

Kind regards,


Joe Clarke Thu, 09/30/2010 - 21:07

The packet capture point and buffer are not saved across reloads.  You will need to run the EASy Installer in order to reconfigure the package.  Run:

tclsh easy-installer-signed-1.5.tcl easy-packet-capture

That will let you reconfigure the capture point and buffer.

Delfino Tiongco Fri, 10/01/2010 - 13:40


I have the version 1.4; tried the command but did not work in my specific case.

Now that I am aware I have to re-install the package, it helps to know that I am doing the process correctly.  I made several tests in my lab and were able to capture packets successfully.

Thanks for the help.


Joe Clarke Fri, 10/01/2010 - 20:25

You don't need to reinstall.  Running EASy Installer again with just the name of the package will bring up the reconfigure menu.  This will let you reconfigure some of the options.  EASy Installer 1.5 is available at http://www.cisco.com/go/easy, but 1.4 should work as well.

Delfino Tiongco Thu, 10/07/2010 - 14:17


Thanks for the help.

I get it to work now. One happy ethernet engineer here (o:



This Discussion

Related Content