Error disable Switch port

Unanswered Question
Sep 22nd, 2010



I got issue on the switchport connecting to Wireless_outdoor_AP, all of a sudden the port becomes error_disable.

I shutdown the port and make the port default then it starts working again.

Cisco recommended to configure error-disable recovery and error-disable time but it doesnt help.

Can you expert can recommend solution to overcome this issue.

Switch : 2960 48 ports

Wireless_outdoor_AP : Wilan

Best Wishes


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
francisco_1 Wed, 09/22/2010 - 09:16

well you gonna need to find out what caused it.

post "show log" on your switch, hopefully that should give us some insight!


francisco_1 Wed, 09/22/2010 - 09:43

Try the commands "show interfaces status err-disable" and " show errdisable detect" to shows which local ports are involved in the errdisabled state. port the output.

also post show log - to see what logging is setup


anthony.dyne Wed, 09/22/2010 - 12:11


here is the output, appreciate your support.

show errdisable detect
ErrDisable Reason    Detection status
-----------------    ----------------
udld                 Enabled
bpduguard            Enabled
security-violatio    Enabled
channel-misconfig    Enabled
psecure-violation    Enabled
unicast-flood        Enabled
vmps                 Enabled
loopback             Enabled
unicast-flood        Enabled
pagp-flap            Enabled
dtp-flap             Enabled
link-flap            Enabled
sfp-config-mismat    Enabled
gbic-invalid         Enabled
dhcp-rate-limit      Enabled
storm-control        Enabled
arp-inspection       Enabled
community-limit      Enabled
invalid-policy       Enabled


sh interfaces status err-disabled

Port      Name               Status       Reason
Fa0/38                       err-disabled link-flap
Fa0/44                     err-disabled loopback

best wishes


francisco_1 Thu, 09/23/2010 - 05:21

which port the AP is connected to ?

According to your output, port Fa0/38 err-disabled due to link flap (interface state up/down). I believe the default on the switch is if an interface flaps more than 10 times in 5 seconds or the other way around, the port is err-disable. you need to investigate why the flap happened!! it could be a faulty cable or interface!!

Regarding port Fa0/44, can you post the config?


anthony.dyne Thu, 09/23/2010 - 07:21


AP is connected to Fa 0/44

int fa 0/44

switchport mode access

switchport access vlan 4

francisco_1 Thu, 09/23/2010 - 08:10

Thanks for the info.

Looks like the loopback error is a bug CSCea46385 due to a old version os IOS on your switch. By upgrading to new code should disable sending and receiving of keepalive on the AP interface. see below.

According to Cisco a loopback error occurs when the keepalive packet is looped back to the port that sent the keepalive.

The switch sends keepalives out all the interfaces by default. A device can loop the packets back to

the source interface, which usually occurs because there is a logical loop in the network that the

spanning tree has not blocked. The source interface receives the keepalive packet that it sent out, and

the switch disables the interface (errdisable). This message occurs because the keepalive packet is

looped back to the port that sent the keepalive:

Keepalives are sent on all interfaces by default in Cisco IOS Software Release 12.1EA−based

software. In Cisco IOS Software Release 12.2SE−based software and later, keepalives are not sent by

default on fiber and uplink interfaces. For more information, refer to Cisco bug ID CSCea46385

The suggested workaround is to disable keepalives and upgrade to Cisco IOS Software Release

12.2SE or later.

francisco_1 Thu, 09/23/2010 - 08:12

bug info

ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on gig0/2


An interface on a Catalyst switch is errordisabled after detecting a loopback.

Mar 7 03:20:40: %ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on

GigabitEthernet0/2. The port is forced to linkdown.

Mar 7 03:20:42: %LINK-5-CHANGED: Interface GigabitEthernet0/2, changed state

to administratively down

Mar 7 03:20:43: %LINEPROTO-5-UPDOWN: Line protocol on Interface

GigabitEthernet0/2, changed state to down


This might be seen on a Catalyst 2940, 2950, 2950-LRE, 2955, 2970, 3550, 3560 or

3750 switch running 12.1EA or 12.2SE based code.


Disable keepalives by using the no keepalive interface

command. This will

prevent the port from being errdisabled, but it does not resolve the root cause of

the problem. Please see section below for more information.

Additional Information:

The problem occurs because the keepalive packet is looped back to the port that


the keepalive. There is a loop in the network. Although disabling the keepalive

will prevent the interface from being errdisabled, it will not remove the loop.

The problem is aggravated if there are a large number of Topology Change


on the network. When a switch receives a BPDU with the Topology Change bit set,

the switch will fast age the MAC Address table. When this happens, the number of

flooded packets increases because the MAC Address table is empty.

Keepalives are sent on the Catalyst 2940, 2950, 2950-LRE, 2955, 2970, 3550, 3560

or 3750 switch to prevent loops in the network. The primary reason for the


is to prevent loops as a result of Type 2 cabling. For more information, see:

Keepalives are sent on ALL interfaces by default in 12.1EA based software.

Starting in 12.2SE based releases, keepalives are NO longer sent by default on fiber and

uplink interfaces.

rs      Status




3 - moderate


Cisco IOS software


1st Found-In



This Discussion