3750 X link lights

Unanswered Question
Sep 22nd, 2010

I have a client that has two stacks of 3750X switches as well as a mixed stack of 3750's and 3750X's.  On the stacks that are just 3750X's, none of the link lights work when the mode is set to status.  However, when you do a show int status, the switch shows ports connected.

On the mixed stack of 3750's and 3750X's, the link lights work fine.

I cannot find anything on Cisco's site or google search on this issue.  The switches are running 12.2(55)SE C3750E-UNIVERSALK9-M and are IPBase.

TIA for your help.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Reza Sharifi Thu, 09/23/2010 - 06:18

Hi Dan,

I have set of 3750x stacked and when I connect another device to any of the ports, the link light come up fine and no issues.

I think, this may be an IOS issue.   I am running 12.2-53

A change of IOS to this ver may fix the issue.

Switch#sh ver | i bin
System image file is "flash:/c3750e-universalk9-mz.122-53.SE2/c3750e-universalk9-mz.122-53.SE2.bin"



swittstr Tue, 10/19/2010 - 14:14


Did you find a solution?  I'm running the same code and have the same problem. It only shows up after you use the mode button.  Powering up and making port connections is works fine.  12.2(53) recommended elsewhere isn't an option for us as that's older code.  I did notice if you hold the mode button at least 5 seconds when at Status MOST of the LED's in the stack with light up.  E.g., this always worked on a 2 switch stack but this only worked on 4 or so in a 6 switch stack, i.e. the other 2 still showed no LED activity.


JEFFREY SESSLER Tue, 10/19/2010 - 15:24

I've seen the problem too on 53. Also, if you have any PoE enabled devices, we've seen a situation where PoE stops working on the 3750x i.e. it's working, unplug the device, plug it back in, no PoE. Happens on any PoE device on the switch. As long as it's running it's OK, but add or disconnect a device once the switch has been up for several weeks, and it no longer works. The 3750x switch must be power-cycled to fix.


hamish.bradshaw Mon, 11/01/2010 - 15:41

Hi Dan,

Did you find out what was causing this issue? I have just setup a stack of 4 x Cisco 3750X's and are seeing the same issue when selecting STAT on the front panel. Each time I select STAT the switch shows that different ports have a link and then next time shows no link light, although the CLI shows the port is UP. Very strange! After a reboot I noticed a port that has a router connected to it displayed 'notconnect' in the 'show int status' output. I had to move the router to another switch in the stack to make it active. I am in the process of raising a TAC request to get this resolved but would like to know if anyone else has seen this and has found resolution yet?

Software versions I have tried are:





hamish.bradshaw Thu, 11/04/2010 - 16:33

Thanks Steve, that has helped a lot. Turns out that there is another bug on the Cisco 3750X-24T-S that has caused at least one of my ports to not come up after a reboot. Bug ID: CSCti75491  Some ports fail POST fail to come up. The work around is to turn off POST for the ports! This is crazy that Cisco has released the 3750-X's without sorting out these types of bugs. Most unimpressed with the 3750-X's....



andtoth Tue, 11/23/2010 - 07:45


I can confirm, this is a software defect with ID CSCti09726. Will be fixed in 12.2(58)SE.

Out of control Ethernet port LED after pressing the Mode button to STAT


The ethernet port LED gets out of control after pressing the Mode button.


In fact, the port LED on onboard have a link up, however, it seems that

the port LED on onboard looks like link down status even if the interface

links up after pressing the "Mode button" on C3750X.

Bug Toolkit Page


Best regards,


whaughton Sat, 02/19/2011 - 14:51

BugTrac shows this as resolved now in 12.2(55)SE,  per 


We have RMA'd 2 of these,  as TAC is saying it's a hardware problem,  we have not tested (55) code  yet,  will update this in a week or two with results.

Anyone else out there determine if 55 code solves the problem with message:

POST: Failed PortPhyLoopback Packet Test asic_index 1 port_hardware_index 8

When we called TAC,  they didn't spot this,  most likely due to the original POST message not included in the bug description.

grodoni Tue, 11/23/2010 - 00:55

for your information:

I have 10 x stacks of 2x3750x-48 (all same)  in my lab .... all with the same IOs 12.2(53)SE2 and I encountered the same problem on 1 stack only !!!

It looks like the problem does not occur on all systems... may be it is related to hardware revisions ?

On the stack with the problem I upgraded to 12.2(55)SE, but the problem is still present ....

Let me know if you have news ...

richard-olson Wed, 05/18/2011 - 07:05

I have reviewed the release notes for 12.2(58)SE and 12.2(58)SE1 and see nothing related to CSCti09726.I am afraid to go to 12.2(58) since the first release was pulled back so quickly.

Does anyone have a clear definition of the problem with the link light functionality ?

richard-olson Wed, 05/18/2011 - 08:14

I checked the relase notes for this release and there is no mention of this bug fix. I have already downloaded the IOS so I will give it a shot.


This Discussion

Related Content