Error disable Switch port

Unanswered Question
Sep 22nd, 2010
User Badges:

Hi2All


I had posted this on WAN forum,



Switch-----------------------Wireless_outdoor_AP


I got issue on the switchport connecting to Wireless_outdoor_AP, all of a sudden the port becomes error_disable.

I shutdown the port and make the port default then it starts working again. Again after couple of days it goes off.

Cisco recommended to configure error-disable recovery and error-disable time but it doesnt help.

Can you expert can recommend solution to overcome this issue.


Switch : 2960 48 ports

Wireless_outdoor_AP : Wilan



show errdisable detect
ErrDisable Reason    Detection status
-----------------    ----------------
udld                 Enabled
bpduguard            Enabled
security-violatio    Enabled
channel-misconfig    Enabled
psecure-violation    Enabled
unicast-flood        Enabled
vmps                 Enabled
loopback             Enabled
unicast-flood        Enabled
pagp-flap            Enabled
dtp-flap             Enabled
link-flap            Enabled
sfp-config-mismat    Enabled
gbic-invalid         Enabled
dhcp-rate-limit      Enabled
storm-control        Enabled
arp-inspection       Enabled
community-limit      Enabled
invalid-policy       Enabled


OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO



sh interfaces status err-disabled




Port      Name               Status       Reason
Fa0/38                       err-disabled link-flap
Fa0/44                     err-disabled loopback




Best Wishes

Anthony

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Wed, 09/22/2010 - 15:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

The question is "WHY" is your port going into error disable.


If it's a link-flap then there is a chance that you have a faulty cable.  The good part of this all is that you have a 2960 with in-build TDR (crude but good enough).


Use the command "test cable tdr int ", wait for about 8 seconds before invoke the result using the command "sh cable tdr int ".


NOTE:  If you are running IOS earlier than 12.2(46) this command is DISRUPTIVE.  IF you have IOS version newer to this, then it's OK.


Good result is "OK" or "Normal".  Anything else is bad.  Also, because you have a 10/100BaseTx, don't be alarm if the result is for the first two pairs.  This is normal.  If you have gig ports then you will have a result of all four pairs.


Hope this helps.

Souvik Ghosh Wed, 09/22/2010 - 17:36
User Badges:
  • Cisco Employee,

Hi,

It would be better to check the speed/duplex settin as well.

Rgds,
Souvik

anthony.dyne Thu, 09/23/2010 - 00:04
User Badges:

Hi2All


I got this as output



Interface Speed Local pair Pair length        Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Fa0/45    100M  Pair A     10   +/- 15 meters Pair A      Normal             
                Pair B     10   +/- 15 meters Pair B      Normal             
                Pair C     N/A                Pair C      Not Supported      
                Pair D     N/A                Pair D      Not Supported



How do I overcome this issue.



Best Wishes

NickNac79 Thu, 09/23/2010 - 00:13
User Badges:
  • Bronze, 100 points or more

Hi Antony,


This is connecting to an outside Wireless AP, is there any chance that the cable that is feeding the AP is loose outside and is flapping when the wind blows?  There may be a microbreak in the cable that only presents when the cable is in certain positions (i.e. when the wind is blowing hard and the cable is flapping)

Check to ensure it's properly secured.


Also, have you tried the AP connected to a different port on the switch?


Nick

anthony.dyne Thu, 09/23/2010 - 01:10
User Badges:

Hi2All


Nick what you mentioned is very much possible. Can we bypass this for outdoor Wireless links.

I have checked on 5 different ports but its the same, even changed the switch with new IOS ; still the same


Best Wishes

Actions

This Discussion