WAP4410N v2.0.0.5 firmware - release soon

Unanswered Question
Aug 31st, 2009

Sorry for the inconvenience folks.  The link provided is delivering the wrong f/w file.  Our IT staff is working to resolve this issue and should be fixed shortly.  Again, sorry for any inconvenience this may have caused.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
grey-cisco Mon, 08/31/2009 - 20:34

Wow... many had probably given up on any new firmware (certainly I practically had) and then what arrives is a new major release! Looking forward to hearing how people go with it.

Any more info on the Cisco changes? just diff UI? Any IOS?

What happened to


amcmis Tue, 09/01/2009 - 05:57

Hmmm, I've been away for awhile, but I see that others have kept up with my "Where's the firmware?" rant. My first day back, and 2.x is out! Yay! Then I can't download for reasons noted above. Hmmm, who are the geniuses that can't provide a download link? Anyhoo...

Did anybody read the release notes? I am afraid. If they had said it was a total rewrite of the code I might have een excited, but it looks like they spent all the time on a fresh new GUI instead. The 'Fixed' and 'Known Problems' don't even mention the issues talked about here. (DLink provided a firmware upgrade once for the  DWL-3300, and it still had all of the pre-existing problems. Nicer GUI though...)

So I will watch and wait, try the firmware on a test unit, and cross my fingers.

BTW, I also send syslog data to a Splunk server, and never see error messages even when it's down. But why is it that if I set up email alerts, save config, and reboot, that setting goes away?

Oh, and to comment on the 'Hey what happened to through, if you get the Powerpoint presentation on how to modify the backup restore to actually work, (???) it shows a config file with Maybe I should hold out for 3.x.

amcmis Wed, 09/02/2009 - 07:28

Bump! Where's the firmware? Link is still wrong, probably should be edited out... Download library still shows old version as well.

matthew.hewson Wed, 09/02/2009 - 07:33

Having just installed a pair of 4410N's today, I thought I'd pop by and download/apply the latest firmware update. Absolutely gutted to find that I have actually rolled back an entire full revision from, which is what the APs came pre-configured with. Is there any headway being made on getting the latest firmware online for download?

matthew.hewson Wed, 09/02/2009 - 09:26

If you have a read of the rest of this topic, you'll see that the firmware release included with the APs was only actually made available for download just recently, and it seems that someone has made a cockup and listed the wrong .zip on the download server. It seems the issue was being looked into as recently as two days ago, and admittedly it's a little annoying having downgraded the firmware (especially as the release notes were correct, and there was no warning to say this was a downgrade!) but hardly worthy of returning all your purchases. Give it a few more days at least!

brnickli Wed, 09/02/2009 - 09:41

Folks, there is an issue with the firmware link to the Free and Anonymous download that does not require a login to Cisco.com to get this file.

If you go to the Software Center on Cisco.com you can download the WAP4410N v2.0.0.5 firmware right now, however if you do not already have an account on Cisco.com this requires user registration.  Please login and download the latest firmware:


Once in the Software Center, select Wireless then Access Points.  Click Cisco Small Business Wireless Access Points, then select the WAP4410N.


The link to Free and Anonymous download is being fixed but there may be some lag time before it's active.

It's strongly recommended to restore factory defaults on the WAP4410N after performing the f/w upgrade.  There are instructions for migrating the configuration file here if you'd like transfer the configuration between the two versions before performing the upgrade.


Or you can rebuild the configuration manually by re-entering the wireless parameters (SSID, security, etc.)

shepner2000 Wed, 09/02/2009 - 11:54

Just upgraded my AP to v2.0.5 which seemed to go ok.  My settings seem to have carried over find and my laptop connected without complaint.


1)  The login page doesnt render correctly under FireFox 3.5.2.  Im all for nicer interfaces and all but whats wrong with using standard HTML??

2)  The logging settings still revert back to default  after a reboot.  I guess that the new GUI was more important then fixing bugs.

Time will tell if they fixed the real problem but Im not holding my breath.  Assuming  it continues  to stop working at random intervals, Im gonna eBay this piece of crap if it doesnt go into the trash first.  In the meantime, anyone have suggestions for a good/reliable access point which is functionally the equiv of the WAP4410N (ie PoE, B/G/N, etc) that is both affordable and  NOT made by Cisco?


shepner2000 Wed, 09/02/2009 - 19:06

Latest update since my upgrade:

1) first of all, at some point the web management interface suddenly started working correctly under firefox.  I didnt restart anything.  Couple hours later I was suddenly able to use firefox.  Who knows, hadnt seen anything else behave that way in an extremely long time

2)  The AP still hangs same as before.  Good strong signal, link on the ethernet port, does not respond to ping on ethernet.  Havnt had it occur this quickly after a power cycle before.

3)  New problem this time.  Now its doing momentary drops of my connection.  It comes back right away but its long enough to drop RDP sessions, IPSEC VPN tunnels, etc.  I did a site survey and the only AP within range is on channel 6 while my AP is configured for channel 1

4) GUI is much nicer then the old version.  woo

If this keeps up I think Im gonna go back down to 1.0.12 as that was only extremely annoying as opposed to the bearly usable state its in with 2.0.5.  Anyone else upgrade yet?


grey-cisco Thu, 09/03/2009 - 05:03

Interesting shepner...I look forward to hearing more from yourself and others who've tried it. Pity it *seems* that this new major release might just be a new web UI. Don't suppose it lets one assign names to each MAC in the filter? Fancy a MAC filter where you can't retrospectively see the owner of any of the stored MAC's!!

We've also experienced the sudden traffic flow problem, but *seem* to have it resolved for now, having made these changes:

  1. disable the MAC filter,
  2. moving the AP to a different power source and network connection. Previously the AP was run off a large generator (now on steady mains supply) as was the gbit switch it was hooked into.
  3. Switching wireless channels.

Our AP hasn't missed a beat since, though I must admit it did seem to fail a bit more after these changes were made, but within a day they'd stopped completely (around 1 week ago now).

Keep the info coming. :)


matthew.hewson Thu, 09/03/2009 - 05:41

Interesting, what hardware revision of the WAP4410 are you running? Mine are WAP4410N G5s hardware rev. 12, and I have none of the problems you mention - has been completely stable so far, and the logging settings are retained even after reboot. The log itself is cleared, but that's to be expected.

shepner2000 Fri, 09/04/2009 - 08:35

I just upgraded to 2.0.5 a couple days ago when it was released.  Not sure about the hardware revision and will have to check later on.  Tho tis interesting that new units were being shipped with this  firmware before it was released to the rest of us.

Cisco is aware of the issue with the log settings.  They confirmed it in their lab, provided me with a workaround which I used, documented and then posted.  I assume you just happened configure your AP in a different order then I had which would be how I had that problem and you didnt.

For those who are keeping tabs, I only had 1 momentary loss of connection last night.  So it seems to have calmed down a bit since its behavior on Wed.  Will be interesting to see what happens this weekend with 2 laptops going at the same time.


ahorwitz9523 Fri, 09/04/2009 - 14:23

Please keep us updated. What concerns me most is the power cycle requirement. That is a show stopper for me. Perhaps you could post a daily update? I need to place an order ASAP.

How does 802.11n compare to whatever you were previously using; "g" I assume?

shepner2000 Fri, 09/04/2009 - 16:30

Im only using 802.11g.  Dont currently have anything which supports N at this time and so havnt tried that.

btw, it just hung again this evening.  This time I verified that I could ping the AP's IP addr via 802.11 even if that wasnt possible via ethernet.

as far as recommendations to buy a WAP4410N or not, the best Ill go is "mebbe".  Apparently some (most??) people dont have problems.  Im unfortunately not one of them.  Sofar the only thing that is keeping me from ebaying the thing and avoiding anything made by the Linksys side of Cisco is the support that Im currently receiving.  Tho I think that  ditching the $3 no-name AP I had gotten from CompUSA some years ago in favor of this new AP might have been a mistake.  It might have been a piece of junk but at least it was reliable junk

btw, someone earlier listed the hardware revision of the one they have.  Where is that shown?  I dont see it anywhere.


ahorwitz9523 Fri, 09/04/2009 - 16:51

I'm dissapointed to hear that. I'm an IT professional and spend money on stuff that works for my home. I gave up on the consumer crap years ago as it never had enough features to support my needs. I currently have a Cisco AP-1131AG ($$$). I do a significant amount of large transfers between my wireless systems and servers so would like to get the additional bandwidth that 802.11n supposedly delivers. The 1131 is mounted in the kitchen pantry and has never needed a reboot and is running the software release it came with 2 years ago....

I don't really want to spend the money for an Aironet 1250 but maybe that's what I need to do. I was optomistic the WAP4410 would be the solution and it'll even use the power injector I have for the 1131. I don't understand what's so difficult about this. Granted the consumer stuff is crap, and the AP1131/1250 is pro stuff. The stuff in the middle should be good considering the prices charged. Yet many people buy the consumer crap and it works fine for them because they have one or two PCs with light use. There are two heavy Mac and two heavy Windows users in my household, plus other clients when there are kids here with their iPods, etc.

Cisco couldn't wait to slap their name on the boxes. Linksys By Cisco everywhere. Good, grief. Where's the beef for the customers? I bought a SLM2024 switch. Lots of features, seems to work, just don't go into the GUI. Had to open it up and fix the power recepticle the first day. Dog slow interface, device either boots every day or can't tell time. Honestly I'm not sure which. Maybe the accountants could spend $5 extra dollars per device and get a faster CPU?!

shepner2000 Fri, 09/04/2009 - 17:46

I also generally try to avoid the consumer grade equipment for the same reasons but wasnt willing to pay the $$$$ for what I wanted.  So I compromised.  Went with Linksys because my co-workers were happy with the ones they bought years ago.   Went with the 4410 because of all the horrible reviews the 4400 had.

btw, my linksys SGE 2000P switch has been pretty good sofar and the web interface hasnt annoyed me *too* much.  It was also a compromise because I wasnt willing to pay that much for a proper Cisco switch with PoE...


shepner2000 Fri, 09/04/2009 - 19:28

Locked up again.  The last time I set it so I could admin the AP via 802.11.  This time I was able to tell it to reboot  via wireless rather then running downstairs to unplug the cable


matthew.hewson Sat, 09/05/2009 - 00:35

For me at least, the hardware version is shown on the status page within the admin panel. Glad to report that things here are still fine, both APs have been rock solid thus far. If you're really at your wits end then it seems your options are limited if you want a reasonably priced 11n AP with POE built in - it's got to be between the D-Link DAP2553, or the Netgear WNAP210, the latter which I wouldn't trust as far as I could throw it based on my experiences with Netgear WG102 APs.

To be fair, I think the support we're seeing here on Cisco Community is probably better than you're likely to find anywhere else for a product at this price point - at least there's a Cisco employee here keeping an eye on proceedings, even if there are some issues that still haven't been resolved.

Shepner, when the AP hangs, what exactly do you have access to? You can ping the AP, but can you access the admin pages on the APs webserver? I'm just a little curious because I had a problem that might be similar, which was the major influence in purchasing my WAP4410s. I had a pair of Ericsson APs, and besides the inherent instability and console only administration (no web admin!), I could never get roaming working properly with them. If I roamed from one AP to the other, the network would not realise that I had moved, and it would either take 15 minutes or a power cycle to be able to get back on the network. I could still ping the AP itself the whole time. I think this may well have been something to do with the address tables on the switch not updating, but I never managed to sort it, as I gave up on those APs in frustration due to the other aforementioned problems before I ever really got to resolving the roaming. With exactly the same switch (and same config on the switch), roaming worked straight out of the box with the WAP4410, so I can only assume that every time a client associates, the access point is sending out a graceful ARP request to the switch.

shepner2000 Sat, 09/05/2009 - 07:23

ah, there it is.  Yep, hardware revision 12 as well.

I find your comments about D-Link and Netgear amusing.  I have similar opinions except that Ive completely given up on D-Link and Im none too thrilled with Netgear either.  I dont think its too much to ask for a product to work as advertised.

For the problem itself:  After a while for reasons unknown, traffic no-longer passes through the AP.  The laptop still has good strong signel.  Ive found that it is still possible to ping the AP's management address via 802.11.  However, it is not possible to ping the address via ethernet.  There are still link lights on the ethernet ports.  All the other lights on the AP look normal as well.  The switch its attached to is not reporting anything unusual either.   Most recently, Ive enabled web management of the AP via 802.11 which has allowed me to grab logs and reboot.


shepner2000 Sat, 09/05/2009 - 09:29

Did it again.  This time telling it to reboot didnt help and so I had to power cycle it.


grey-cisco Sat, 09/05/2009 - 16:26

Hey Shepner... don't suppose you could humour me and try switching off your MAC filter (it won't lose the addresses) and perhaps change your wifi channel to #9.


shepner2000 Sat, 09/05/2009 - 18:36

Im not doing any MAC filtering and whats so special about channel 9?

btw, it locked up again


grey-cisco Sun, 09/06/2009 - 15:37

Nothing other than that is one of the few changes I made to stop mine losing network connectivity...

mrazmik Sun, 09/06/2009 - 23:06


Assuming the switch address is configured to be in the same subnet, when the issue happens:

   a. can you ping the switch IP address from your both PCs wireless and LAN PC ?

   b. from the switch can you ping all devices, (AP, LAN and WLAN PCs) ?

   c. 1. could you please check your PC's arp (c:\arp -a) table, do you see APs MAC address ?

       2. can you clear arp table (c:\arp -d) and ping it again ?

       3. this time please do not reboot the AP, but your LAN PC then ping the AP.

Thank you.

kjjump105 Mon, 09/14/2009 - 05:28

Is there any new information on this issue.  I am still having this problems, but all discussions about it have stopped.  I have posted my setup information in the following thread: https://www.myciscocommunity.com/thread/4935

I have tried all recommended resolutions from this thread without any success.

shepner2000 Mon, 09/14/2009 - 06:13

sorry for lack of updates.  The problem is still going but work was crazy last week and  the times at which it occured I couldnt spend the time troubleshooting it. Hopefully this week will be more conducive to troubleshooting


I shall learn to have some more patience it seems :-)  But it does appear the complaining resulted in being posted, I am grabbing it now and taking the WAP4410N's out of the box that I was going to ship them back in.

Suggestion for Cisco on product page, above or next to the download link, list the version number of the file.


This Discussion