WAP4410N release notes question

Unanswered Question

Let's hope this works.  From the release notes, it appears I will have

to set the speed setting to 100M mode.  Once I did this, my managed

Gigabit switch indicated the port is now at 100TX mode.

However, the switch also indicated the connection is now Half duplex

instead of Full duplex.  I believe this drops the throughput

even more when the traffic is high through the WAP.  It seems the

WAP autonegotiated to Half duplex mode.  Is this correct and

is it necessary?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ismarkusem Mon, 01/04/2010 - 16:50

Forcing the LAN Port Speed to 100Mb is a bad workaround. The LAN port on a WAP4410N should not stop responding in any conditions. Attached are some details related to Speed and Duplex settings.

David Hornstein Tue, 01/05/2010 - 00:56

Hi Guys,

I think from discussions we are now looking at a autonegotiation issue. A lot of folks forget what auto negotiation does, because they don't have to worry about this on a daily basis.

I appreciate that everyone who reads this post knows what autonegotiation is, so I say the following with sincere humility.

Auto-negotiation is a protocol that a switch port is in, usually by default.  If the device attached to a switch port it is not in autonegotiation  mode, but MANUALLY altered to 100meg full duplex, that attached  device is obviously  not in auto-negotiation mode.

If a device attached to a switch port is manually altered to 100mFull duplex, then the switch port also  should be manually altered to 100Mfull duplex.

Why, because,  there is no possibility of the auto negotiation process to complete between the two ethernet hosts.

If the  the device attached to a switch port is manually attached at  100mFull duplex, but the switch port is still in autonegotiation mode, that switch port may try to unsuccessfully negotiate a speed and may settle for 100mHalf duplex, because it is not getting a response to it's autonegotiation 'challenge.'

So the behaviour you mention,  indicates to me that a switch port may still be in auto negotiation mode.

The moral of the story is;

1.If one host speed and duplex is manually altered, the attached host must also be manually altered to the same speed and duplex. Auto negotiation setting WILL NOT work, even advertising100M  Full duplex, because the other host will not respond to autonegotiation.

2. Simply put, since the wireless side is running  a bit like a old fashion hub, almost a  shared collision prone ethernet environment,  your WAP4410N is still providing  much faster bandwidth for AP users, when compared to a 54Meg  wireless G AP environment..But sounds like new firmware is available to resolve this issue.

Good luck and Regards

Dave

Cisco Small Business, Channel Systems Engineer

ismarkusem Tue, 01/05/2010 - 03:23

This is exactly the theory explained within one of the previous attachments (Speed and Duplex Matrix.pdf).


Now the question from the WAP4410 perspective is;

1) How do we see and know whether the WAP4410 is set via GUI to “Force LAN Port Speed to 100M” works on 100Mb/FD or in 100Mb/HD (half duplex)?
2) What is the reason for increasing RX errors on the switch end and increasing “Drop Received Packets” on the WAP4410 end while the switch is forced to 100/FD and the WAP4410 is set via GUI to “Force LAN Port Speed to 100M”? Within my opinion this indicates a duplex mismatch!
3) What is the interpretation of below CLI output while the WAP4410 is set via GUI to “Force LAN Port Speed to 100M”?

Observations:

  • GUI is set to “Force LAN Port Speed to 100M” while CLI indicates “Ethernet Data Rate: Auto”. Does that mean that the GUI settings have no real effect?
  • Within the scenario whereby I set the WAP4410 via CLI command to “set ethdatarate 1000” and force he switch as well to 1000Mb/FD there are no errors increasing on both end.
  • There are also no errors when I force both devices to 100Mb/FD (WAP4410 is configured using cli command “set ethdatarate 100”)
  • Changing the GUI value “Force LAN Port Speed to 100M” does not override settings if another value is set via CLI. CLI settings have persistency above the settings configured within the GUI.

Conclusion:

  • It is too early to judge whether the AP stops responding as discussed within this post. Will need more time to observe this.
  • Within my opinion the new firmware introduced a new problem or a different interoperation related to speed and duplex settings.

*************

[VAP0 @ Cisco-WAP4410N-POE]# set ethdatarate
ethdatarate auto                    -- Auto detect
ethdatarate 1000                    -- 1000Mbps
ethdatarate 100                     -- 100Mbps
ethdatarate 10                      -- 10Mbps

[VAP0 @ Cisco-WAP4410N-POE]# set ethdatarate 100
Warning: Force LAN Port Speed to 100M is enabled, disable it first to set ethernet data rate here.

[VAP0 @ Cisco-WAP4410N-POE]# get ethdatarate
Ethernet Data Rate: Auto



[VAP0 @ Cisco-WAP4410N-POE]# set ethdatarate 100
Ethernet Data Rate: 100Mbps

[VAP0 @ Cisco-WAP4410N-POE]# get ethdatarate
Ethernet Data Rate: 100Mbps

*************

David Hornstein Tue, 01/05/2010 - 04:06

Hi Ismarkusem,

Data you posted above with the release notes i just looked at, which  states "Enable this feature to force the link speed of the LAN port of the

access point to be at 100 Mbps" brings up another question.

Is it only advertising 100m  via autonegotiation or is it fixing 100mFull duplex. I would prefer to see the port status via the gui, but without that data and only the data you posted, it sure looks like, it is just in autonegotiating, but now not advertising 1000MBit/sec .

I would hazard a guess that if you set the switch port to autonegotiate, the switch port would settle to 100mFull duplex, when the WAP4410N is set to force the link speed to 100Bbps.  If that is the case, it would seem that the new software is autonegotiating, but not advertising 1000mHalf or Full.

Agreed, yes RX errors on the switch would indicate  maybe a duplex mismatch  :(.

If you can set both switch port and the  WAP4410N to 100mFull, and avoid autonegotiation, why not just leave it at that setting?

I will have a word to the WAP4410N Product manager (when he's back from vacation) to get a better explaination of what is meant by "force the link speed of the LAN port of the access point to be at 100 Mbps"

I will update this post

regards Dave

streaves Wed, 01/06/2010 - 15:23

I passed your question to Engineering and was informed that, when the access point is configured to negotiate 100M speed with "Force LAN Port Speed to 100M" enabled in firmware v2.0.0.12, some gigabit switches will have half duplex speed due to various switch specifications. The next firmware release will provide an improved solution for auto-negotiating speed between the AP and the switch.

Stay tuned.

Thanks

Actions

This Discussion