wlan controller, can't bring up the gui, please advise

Unanswered Question
Sep 22nd, 2010


I as configuring WLAN controller, I did following configuration but I still couldn't bring up the GUI and I wasn't able to ping WLAN controller interface ip addresses from other devices and visa versa.

Service Interface IP Address Configuration [none][DHCP]: none
Service Interface IP Address:
Service Interface Netmask: Enable Link Aggregation (LAG) [yes][NO]: yes Management Interface IP Address:
Management Interface Netmask: Management Interface Default Router:
Management Interface VLAN Identifier (0 = untagged): Management Interface DHCP Server IP Address:
AP Manager Interface IP Address:
AP-Manager is on Management subnet, using same values AP Manager Interface DHCP Server ( Virtual Gateway IP Address:

Mobility/RF Group Name: NapNac

Network Name (SSID): test
Allow Static IP Addresses [YES][no]: yes Configure a RADIUS Server now? [YES][no]: no Warning! The default WLAN security policy requires a RADIUS server. Please see documentation for more details. Enter Country Code list (enter 'help' for a list of countries) [US]: US Enable 802.11b Network [YES][no]: yes Enable 802.11a Network [YES][no]: yes Enable 802.11g Network [YES][no]: yes Enable Auto-RF [YES][no]: yes Configure a NTP server now? [YES][no]: yes Enter the NTP server's IP address:
Enter a polling interval between 3600 and 604800 secs: 4000 Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

>config network webmode enable

>config network secureweb enable

I did above config. but I still couldn't bring up the GUI.

Please advise how do I resolved this.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
irfanrayma7 Wed, 09/22/2010 - 19:05
It following is the other additional command output:

(Cisco Controller) show>interface summary
Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Gu est -------------------------------- ---- -------- --------------- ------- ------ -- --- ap-manager                       LAG  untagged  Static  Yes    No management                       LAG  untagged  Static  No     No service-port                     N/A  N/A Static  No     No virtual                          N/A  N/A static  No     No

field in "Gu" are "No" does that mean Gui isn't enabled yet even though i configured "conf network webmode enable"? please advise.

George Stefanick Wed, 09/22/2010 - 21:48

Hey Bud,

On the switch ... Is your vlan for 192.168.32.x (NATIVE) ? You selected 0=untagged ... if your truck this and left it as .1q you wouldnt reach the controller. you need to either tag on the controller side OR native on the switch side.

Make sense?

davy.timmermans Thu, 09/23/2010 - 02:08


You can give your pc ip address 192.168.132.X and connect directly with the management interface (no lag configured)

Possible problems

->Management interface doesn't tag frames while switch does

Management Interface VLAN Identifier: xxx or put 0 and configure it as native vlan on the switch

--> LAG wrong configured on the switch --> ports down

Check if your etherchannel (LAG) on the switch is up

Still not ok

-> Default-gateway is wrong

irfanrayma7 Thu, 09/23/2010 - 05:01


I haven't configured Etherchannel(LAG) on the switch. do I need to configure one? which port should be a part of etherchannel?

Please advise.

davy.timmermans Thu, 09/23/2010 - 05:11

Can you check if your port is up on the switch?

On the wlc you enabled LAG (=etherchannel)

The corresponding ports on the switch need to be configured as a forced portchannel = channel-group x mode on. Be sure that all cables part of the lag are connected to the same switch (unless 3750 stack)

interface range gx/x, giga/b


switchport mode trunk

channel-group y mode on

portchannel y


switchport mode trunk

Also make sure that you use gigabit ports
irfanrayma7 Thu, 09/23/2010 - 05:19

yes, port is up on the switch. there is only one port on the switch that connects to one gig port of WLC.

will I still need to configure portchannel, etherchannel?

please advise.

George Stefanick Thu, 09/23/2010 - 07:38


Cool deal ... Here is why you had your issue..

1. Since you configured tagg = 0. Packets leaving the controller interface dropping on the LAN are not tagged with .1q (they are native)

2. Your truck was set to .1q for this vlan. So your switch doesnt understand the packet and drops it...

Make sense?

If you find the post helpful please rate ! Thanks buddy!

irfanrayma7 Thu, 09/23/2010 - 08:31

i've converted AP to lightweight using command  "archive download-sw /overwrite /reload". after ugrading to Lightweight and reload, AP doesn't show up in WLAN controller. AP and WLC are in the same vlan.

pls advise.

George Stefanick Thu, 09/23/2010 - 09:05


Its pretty easy. Cisco as an upgrade tool that handles the join process for you ...

1. Go to Cisco DOwnload section client on wireless->access points->select the model you want to uprade


2. Dlownload the following:

     1. The autnomous lwapp image

     2. The autnomous to lwapp tool

     3. The notes

3. After you have these. Simply read the notes, load the tool and you are ready to go.

In short, the cisco tool handles the image push through tftp and within the tool you add the controller you want it to join. A few items to note, you will need to enable TFTP on the AP and controller.

Good luck .. Let me know if you have any problems!

irfanrayma7 Thu, 09/23/2010 - 09:08

Thanks george,

but I just did this:

i've converted AP to lightweight using command  "archive  download-sw /overwrite /reload". after ugrading to Lightweight and  reload, AP doesn't show up in WLAN controller. AP and WLC are in the  same vlan.

pls advise how do i associate AP to WLC.

George Stefanick Thu, 09/23/2010 - 09:18

OK, i never converted an AP this way before to be honest.

1. Console into the AP and look for the join process

2. attach what it says

irfanrayma7 Thu, 09/23/2010 - 17:44

Thanks george. after converting  autonomous AP to lightweight AP using command "archive ...." i used:

lwapp ap controller ip add

it worked.

can we have multiple vlans under associated with same SSID?

irfanrayma7 Thu, 09/23/2010 - 20:05

Thanks george.

As per your video, we can create AP group that will map to specific vlan and then we assign that AP group to Access Point. so APs will have same SSID but different vlans based on AP group they are assigned to. correct?

please correct me if i'm wrong..

i my case, I want to have Access point assigned to multiple AP groups. i.e. SSID should be maked to multiple vlans on the same Access point. would it be possible..


This Discussion