WRP400 Looses DHCP lease time

Unanswered Question
Sep 23rd, 2010

Sirs

We are receiving an increasing number of complaints from our customers that their ADSL lines are disconnecting randomly.

We have together with the country largest telco operator faulttraced the lines now for 2 week and the conclusion is

the the WRP400 is the culpit.

When connected the router sends DHCP renewal request within the lease time of 2 hours for 3-4 days and the goes to sleep

(WRP400_v1.01.00_004_021809_1446_ETSI_feb29_09 & 1.01.00 Jul 29 2009) and only to come alive again when hard rebooted.

The ver of 29/5-2008 doozes off any hour within a 24 hours cycle.

We have tried to get assistance from the importer but unforthunately without succes.

We have tried these awailable releases: WRP400_2.00.20_000_081610_ETSI    but they are not retreiving any IP addresses i.e not asking for registration.
WRP400_2.00.05_010_022009_1600_ETSI

Can you estimate a timeframe for repair ? and/or provide an solution asap.

Thanking you in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
laharper Thu, 09/23/2010 - 14:41

Hello,

Can you provide the traces so that we can look at and help troubleshoot?  Also, any WRP400 debug logs that you can provide would be appreciated too.

Thank you,

-Lance Harper

Cisco Systems, Inc.

mxcross42 Thu, 09/30/2010 - 16:40

Hi,

I am having the exact same probelem...I spent 2hrs on the phone my service provider last night.  I though initially it was a dead router, so bought a new one another WRP400, and the same issue is existing on this one also.

The router just will NOT obtain a DHCP address from the Cable Modem. Yet when i connect the service providers modem directly into my laptop it gets an IP straight away and works fine.

Could you please advise ASAP.

Cable modem is a Motorola Surfboard Cable modem, connecting to my WRP400 router.

Please help, as i am at a complete loss, and now have two WRP400 routers, neither working.....one router is running the new firmware, one is running the old....the FW is making no difference.

mxcross42 Thu, 09/30/2010 - 17:53

Hung, im based in Australia, and use Optus as my ISP...just wondering if you are the same???

j-deschenes Tue, 11/09/2010 - 10:28

Hi,

I am in Canada and we are dealing with Cable Internet + VoIP with WRP400.

We are a Cable & DSL reseller and this issue we have it too but only on Cable with Static IP.

The problem is we get a DHCP lease every 24hours. If a person is on the phone while the lease is due the phone call will be cut and needed to be redialed.

A level 2 technician uses a Routerboard 750 and here's what he done on his own home setup:

"At home I'm  with Videotron and I have a Routerboard 750. It's a router that  needs to be configured manually before anything works.

I had the same issue we  are now having with the WRP about a loss of connection every day for a month and  a half before I fixed it.


In my configuration for my DHCP client, I had an  option "Add Default  Route" which if checked, will create an Internet  route linked to my current IP address. It seemed like the logical thing to do.

What I didn't know is that that default route sends it's own DHCP request when  it needs to renew itself and Videotron answers it with a NAK(Negative  Acknowledgement) because I'm already registered.

That NAK was effectively  killing my connection for 2 seconds every day.

I had to remove that option and  create a manual route, linking my route to any IP (0.0.0.0) but to the WAN port  my Videotron modem was connected to. Just doing that solved my issue completely.


There's a good chance it's the same issue we have with our WRP as they have  exactly the same symptoms and we had one client (and only one) with a DHCP lease  of one hour that will lose the phone line if she's on the phone when it happens.

We can't be fully sure until either Videotron can confirm the NAK or until the  routes are changed on the WRP400.

The reason why I think only Cisco can help is  that the WRP400 is a lot less configurable then the Routerboard 750 and won't  let me save a static route with no IPs on the WAN port.

There might be a way to  do it actually on our firmwares but I doubt it. Cisco should know, and if it's  not possible they should be able to modify the firmware for it. It's not hard to  do and most of their routers do it."

If anyone can find this information and send it to Cisco we might be able to fix our DHCP lease issue.

joriswillemse Thu, 12/02/2010 - 02:24

I have exactly the same issue with the WRP400, indeed with all the firmware versions (ETSI) that have been released so far.

It would be great if this could be solved.

Actions

This Discussion

Related Content