ASA Windows7 and Start-Before-logon (SBL) Issues

Answered Question
Sep 23rd, 2010
User Badges:

We are attempting unsuccessfully to get Windows7 SBL working with the following configuration (SBL works for XP);


ASA5520

ASA 8.0(4)

ASDM 6.1(5)

AnyConnect 2.4.1012

License VPN Plus (SSL VPN Peers 100)


When configuring Group Policy for Optional Clent Module to download we only have option for vpngina and cannot see Start Before Logon (SBL) module as referenced in AnyConnect Client 2.4 documentation.


Is this a license type issue or do we need an upgrade to ASA/ASDM software ?


Thanks in advance for your help.

Correct Answer by Robert Salazar about 6 years 6 months ago

The following doc can be referenced regarding the rest of the SBL setup:


http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00809f0d75.shtml

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Robert Salazar Thu, 09/23/2010 - 06:57
User Badges:
  • Cisco Employee,

You can use vpngina for the same purpose.

I believe the command has changed in later versions from vpngina to Start Before Login to be more intuitive.

Let me know if you have any further questions regarding this.

Jim Bell Thu, 09/23/2010 - 07:11
User Badges:

Thanks Rosalaza,


We have our Group policy set for vpngina and SBL set to True in the profile and did see an AnyConnect SBL module downloaded.


However on rebooting the Windows7 laptops - after Switch User selected - we do not see the Network Connect button (in lower-right corner of window) to launch AnyConnect Client.

Robert Salazar Thu, 09/23/2010 - 07:22
User Badges:
  • Cisco Employee,

You may want to check if the profile has been pushed to that pc:

   C:\ProgramData\Cisco\Cisco AnyConnect VPN Client\Profile


If the profile is loaded in that directory, what icons do you see at the bottom right hand corner?


-Rob

Jim Bell Thu, 09/23/2010 - 07:34
User Badges:

Thanks Rob,


Looks like the issue, I can't see the profile in that location.


Will work through the document in link you gave me to see if it resolves my issue, and post results back here.

Jim Bell Thu, 09/23/2010 - 14:22
User Badges:

Thanks Rob,


Now have SBL working for Windows7 - just some dns issues to resolve now.

Actions

This Discussion