Cisco Mobile 8 only rings once on iPhone

Answered Question

Hello Everyone,

I have recently setup access through Cisco mobile 8 though a couple iphoes on our network.I have desktop integration working fine, I am able to dial out just fine, the only problem is when someone calls in. On the 3G models of iPhone the call only gets 1/2 to 1 ring before it disappears. The call continues to ring on the actual desk phone, but the iPhone notes it as a missed call. On the 3GS models the call rings on the iPhone for the full duration, and you are able to answer it without any problems. Unfortunately I do not have a iPhone 4 to test with right now. Does anyone have any ideas? I have went through the logs for my 3G to see if anything stuck out but it hardly makes mention of the call incoming and makes no mention of the call missing.

Someone had mentioned a similar problem to what I am having currently, but since it was tied to a second issue that was answered I wanted to seperate them out.

Thanks for reading and any help,


Trevor

I have this problem too.
0 votes
Correct Answer by auppal about 6 years 1 month ago

Just for documentation the deskphone was not associated to the user. After which sip dual mode timer kicks in. That timer tells the CUCM to  call the iphone for that many sec before it uses the gsm

Thnx

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
auppal Fri, 10/08/2010 - 06:49

Hi Trevor,

       Raise the sip dual mode timer to 3000 in service parameter

Thnx

auppal Fri, 10/08/2010 - 07:37

Hmm Wierd I would expect it to work .So you are telling me that some one calls the iphone mobile 8.0 it rings just 1 time ? Can you attach the SDI traces for one call. Mention the calling and the called number. Make sure you have the traces set to detail.

THanks

A little more in depth info for you, when someone calls an extension that I have on the iPhone 3g is rings only once, but they other phones assigned to that extension (standard cisco ip phones) continue to ring their full duration. I tried the same thing with an iPhone 3gs and it worked fine.

I would love to attach the trace for you, but as embarassing as it is to admit I have not done a trace since CCM4.3, and I am having trouble finding a guide for setting up the correct trace in CUCM 7.

auppal Fri, 10/08/2010 - 07:57

This is the timer

SIP Dual Mode Alert Timer Required Field in Service parameter which needs to be increased. Also the user id associated to the phone should also be associated to the TCT device as well as make sure all the lines on the TCT device as well as the physical desk phone is assoicated to the user

That was the field I modified in my service parameters. I can not look at the link since it's a 10. address, but the name field matched exactly. I attached a copy of the "Live Log Viewer" that I recorded for my call. The phone number I was calling from was 2640, and the phone number I was calling to was 2642.

Also, I looked to double check that the user was associated with all the devices, which he is. And I made sure that the end user was the CTI control user, which he is.

Attachment: 
auppal Fri, 10/08/2010 - 09:43

Hi I think you selected CTI in the trace menu please select Call Manager. Make sure you make a call and then collect for the last 5min

Correct Answer
auppal Fri, 10/08/2010 - 10:12

Just for documentation the deskphone was not associated to the user. After which sip dual mode timer kicks in. That timer tells the CUCM to  call the iphone for that many sec before it uses the gsm

Thnx

Actions

This Discussion