ip default-gateway is wrong and I cannot change it

Unanswered Question
Sep 23rd, 2010
User Badges:

I have several 2960/2640 switches with "ip default-gateway" configured.  However, the IP of the default gateway recently changed, and the old gateway IP is no longer active.  But these 2960's still try to send *some* outbound traffic using the old gateway IP, even though I have changed the default gateway to the new IP.  I have tried deleted and re-adding, and also just deleting it, thinking that proxy arp can figure it out, but nothing works. A reboot does fix it, just wondering if there is some way to do it without rebooting the switches. Any ideas from anyone?


I said *some* outbound traffic, because it can reach other hosts, even on the same destination subnet as the failed destination host.  But when I try to reach that particular host, the switch tried to use the old gateway IP.  I can tell this because I used debug arp to see what it was doing. Very strange.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Thu, 09/23/2010 - 19:28
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Have you tried to clear the  arp-cash and clear mac-address-table?

Paul B Thu, 09/23/2010 - 19:30
User Badges:

I tried the arp cache, but not the mac table.  I'll give it a try.

Actions

This Discussion

Related Content