ASR 1002 error message :%IOSXE-4-PLATFORM: R0/0: kernel: mcp: hrtimer_get_softirq_time() not serviced

Unanswered Question
Sep 23rd, 2010

Hi ,

I got an error message in ASR 1002.

The ASR information:

(1)#show version

Cisco IOS Software, IOS-XE Software (PPC_LINUX_IOSD-ADVENTERPRISEK9-M), Version 12.2(33)XNF1, RELEASE SOFTWARE (fc1)


System image file is "bootflash:packages.conf"
Last reload reason: PowerOn


(2)#show redundancy states
       my state = 13 -ACTIVE
     peer state = 8  -STANDBY HOT
           Mode = Duplex
           Unit = Primary
        Unit ID = 48

Redundancy Mode (Operational) = sso
Redundancy Mode (Configured)  = sso
Redundancy State              = sso
     Maintenance Mode = Disabled
    Manual Swact = enabled
Communications = Up

   client count = 75
client_notification_TMR = 30000 milliseconds
           RF debug mask = 0x0

(3)#show platform
Chassis type: ASR1002         

Slot      Type                State                 Insert time (ago)
--------- ------------------- --------------------- -----------------
0         ASR1002-SIP10       ok                    12w2d        
0/0      4XGE-BUILT-IN       ok                    12w2d        
R0        ASR1002-RP1         ok                    12w2d        
R0/0                         ok, active            12w2d        
R0/1                         ok, standby           12w2d        
F0        ASR1000-ESP10       ok, active            12w2d        
P0        ASR1002-PWR-AC      ok                    12w2d        
P1        ASR1002-PWR-AC      ok                    12w2d     

Slot      CPLD Version        Firmware Version                       
--------- ------------------- ---------------------------------------
0         07120202            12.2(33r)XNC                       
R0        08011017            12.2(33r)XNC

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Giuseppe Larosa Fri, 09/24/2010 - 12:47

Hello Rick,

have you received this error only once or multiple times?

the error comes from kernel of OS running on active route processor ( R0/0) and states that a routine hasn't been serviced.

The affected routine is named hrtimer_get_softirq_time() and the name leads to a control process that should get the timestamp of execution of software based interrupts.

Have you experienced any noticeable issue?

Hope to help


ccnarick Sun, 09/26/2010 - 23:08

Hi Giuseppe,

I have two ASR1002 routers.And I got the message twice every device.

I haven't experienced any noticeable issue or other errors.

Do you recommand ?



Giuseppe Larosa Mon, 09/27/2010 - 07:55

Hello Rick,

if it happened only twice on two boxes I would think of a possible SW bug

For the moment I would investigate on bug toolkit and/or I would open a TAC service request.

However, if no real issues the bug may be cosmetic

Hope to help


ccnarick Mon, 09/27/2010 - 19:44


Thank you very much !!

I wii open a TAC case.

If any news,I will update to here.



This Discussion

Related Content