ASA5505 Clientless SSL and Ajax issue

Unanswered Question
Sep 24th, 2010

Hi Guys.

I haev noticed there are some issues with the Clientless SSL on the ASA and websites that support AJAX posted in these forums but nothing as yet has seems to work for individuals.

my setup is an ASA5505 running 8.3.2ED. and a Synology CS407 running DSM v2.3.

when i use this setup i can connect fine to the CS407's control panel which is web based using AJAX through the clientless SSL connection of the ASA5505.  Synology however have brought out a new DSM v3.0 which works fine ove the lan, but as soon as I try using a clientless SSL connection I see a blank page - s I said before it works fine with an older version of the DSM operating system.

now we can blame synology for bringing out a new version, but surely the Clientless SSL feature of the ASA is blocking the new designed front end and shouldn't be.

is there anything I can do with the SSL connection settings to make this work or will i need to raise this issue with Cisco?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
simonslater Fri, 09/24/2010 - 05:10

I have noticed this however:

CSCtd07817 Bug Details

ASA: eCRF content not displayed via WebVPN in AJAX/Oracle application
Content on an AJAX- and Oracle-based web application may not be displayed via Clientless SSL VPN.

This has first been observed on an ASA running software version 8.0(4), but all other ASA releases, that do not have the fix for this bug yet are suspected to be affected as well.

Use Smart Tunnel or AnyConnect

though if i revert to an older DSM version on my NAS and still use the same ASA version the issue is resolved. both DSM versions use AJAX however.


This Discussion