Update User Locale in CP-7945G will not work ...

Unanswered Question
Sep 24th, 2010

Hello,
I have a problem with CP-7945G; I need to change User Locale setting from English, United States to Italy, Repubblica Italiana as following:
24-09-2010 16-28-30.png
but when I restart my CP-7945G, my User Locale setting will not load, infact User Locale setting remains in English, United States status:
24-09-2010 16-29-39.png
In Status Messages page, I found these messages:
24-09-2010 16-20-38.png
Have you got any idea?
Thank you,

P.S.:

CP-7945G firmware versions:

24-09-2010 16-26-18.png

Cisco Unified CM System version: 6.0.1.2000-3

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Harmit Singh Fri, 09/24/2010 - 08:16

Hi Paolo,

Could you send the following please to begin with:

++  "show version active" from all servers in the cluster -- This is to ensure that the Italian Locale is installed on all servers and the version is compatible.

++  Open a command prompt and run "TFTP get SEP081FF3634EC6.CNF.XML" -- This is to make sure the config file is correctly updated with the Italian Locale info.

Also:

++  Has this ever worked before for any other phone model?

++  Were there any changes made in the recent past to the config / versions?

Thanks,

Harmit.

Paolo Bratti Mon, 09/27/2010 - 05:28

Hi Harmit,

in attachment you can find our config file (SEP081FF3634EC6.CNF.XML); it seems OK, do you agree with me?

At following, you can find show version active output command:


from PUBLISHER:
admin:show version active
Active Master Version: 6.0.1.2000-3
Active Version Installed Software Options:
localeinstaller
cm-locale-it_IT-6.0.0.1-1.cop
cmterm-3911_3951-cm60.8-1-1b.cop
cmterm-3911_3951-sip.8-1-2.cop
cmterm-7921-sccp.1-2-1.cop
cmterm-devicepack6.0.1.3121-1.cop

from SUBSCRIBER:
admin:show version active
Active Master Version: 6.0.1.2000-3

Active Version Installed Software Options:
localeinstaller
cm-locale-it_IT-6.0.0.1-1.cop
cmterm-3911_3951-sip.8-1-2.cop
cmterm-7921-sccp.1-2-1.cop
cmterm-devicepack6.0.1.3121-1.cop


CP-7945G phone is new installation.


Let me know,

Thank you!

Alexey Platov Thu, 04/14/2011 - 07:16

Any new info on that?

Have the same problem.

Localeinstaller and locale packages are installed but even i set in phones another locale phone still uses default English locale.

phooghen Thu, 04/14/2011 - 12:31

Try a factory reset of the phone + restart of the TFTP service on both Pub + Sub.

Pierre.

Alexey Platov Thu, 04/14/2011 - 23:40

Thanks for answering.

Already done that - phone resetted to a factory default and TFTP server restarted. And I have only one server - no subscribers.

System version: 6.0.1.3000-7.

On CUCM I have RU locale installed and active and also localeinstaller installed and active.

When I change User Locale in configuration from English to Russian then Voice announcement heard on this phone are changed to another language but display still uses English locale.

richb1971 Wed, 05/04/2011 - 08:45

Hi,

I've got this too now. We're on 6.1.1 and the system status locale still reads English (United States) despite installing English UK on all servers and rebooting them and the phones.

Any fix out there?

Rich

Alexey Platov Sat, 05/07/2011 - 09:43

I loaded po-locale-ru_RU-9.1.2.1000-1.cop.sgn package on CUCM.

You must have those files in tftp server. Check with traces which files phone is looking for - in my case it was "be-sccp.jar".

For every model of phone you need locale files to be available on tftp server.

You can find it on cisco site in Unified Communications Manager Endpoints Locale Installer ssection - special files for every version of CUCM.

Actions

This Discussion

Related Content