Error when running utils dbreplication status on Pub

Answered Question
Sep 24th, 2010

While trying to troubleshoot a "database communication error" when logging into the Pub (no I didn't change the hostname or IP) I get the following error:

via SSH

admin:utils dbreplication status


-------------------- utils dbreplication status --------------------

Traceback (most recent call last):

  File "/usr/local/cm/bin/DbReplStatus.py", line 98, in ?

    fout = open(tmpOutputFile, 'w');

IOError: [Errno 30] Read-only file system: '/tmp/ReplicationStatus.2010_09_24_12_01_26.out'

I'm logging in with the admin account. What do I need to do?
Thanks,
-mike
I have this problem too.
0 votes
Correct Answer by srsivara about 6 years 2 months ago

A Cisco DB stopping could be a result of informix cores, sometimes. Run the latest 7.1.x recovery disk on the system and check if the automatic file check fixes issues. Depending on the model of the server, you can run a HPSmartStart or IBM DSA to determine the hardware health of the server.

- Sriram

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Michael Murray Fri, 09/24/2010 - 09:23

Hmmmm. Looks like the DB wasn't running and I couldn't restart it. Sounds buggy. I'll have to check around for 7.1.3.

admin:utils service list

Requesting service status, please wait...

System SSH [STARTED]

Cluster Manager [STARTED]

Service Manager is running

Getting list of all services

>> Return code = 0

A Cisco DB[STOPPED]  Component is not running

A Cisco DB Replicator[STARTED]

Cisco AMC Service[STARTED]

Cisco AXL Web Service[STARTED]

Cisco Audit Event Service[STARTED]

Cisco Bulk Provisioning Service[STARTED]

Cisco CAR Scheduler[STARTED]

Cisco CAR Web Service[STARTED]

Cisco CDP[STARTED]

Cisco CDP Agent[STARTED]

Cisco CDR Agent[STARTED]

Cisco CDR Repository Manager[STARTED]

Cisco CTIManager[STARTED]

Cisco CallManager[STARTED]

Cisco CallManager Admin[STARTED]

Cisco CallManager Cisco IP Phone Services[STARTED]

Cisco CallManager Personal Directory[STARTED]

Cisco CallManager SNMP Service[STARTED]

Cisco CallManager Serviceability[STARTED]

Cisco CallManager Serviceability RTMT[STARTED]

Cisco Certificate Expiry Monitor[STARTED]

Cisco DRF Local[STARTED]

Cisco DRF Master[STARTED]

Cisco Database Layer Monitor[STARTED]

Cisco Dialed Number Analyzer[STARTED]

Cisco Extension Mobility[STARTED]

Cisco Extension Mobility Application[STARTED]

Cisco IP Voice Media Streaming App[STARTED]

Cisco License Manager[STARTED]

Cisco Log Partition Monitoring Tool[STARTED]

Cisco RIS Data Collector[STARTED]

Cisco RTMT Reporter Servlet[STARTED]

Cisco Serviceability Reporter[STARTED]

Cisco Syslog Agent[STARTED]

Cisco TAPS Service[STOPPED]  Commanded Out of Service

Cisco Tftp[STARTED]

Cisco Tomcat[STARTED]

Cisco Tomcat Stats Servlet[STARTED]

Cisco Trace Collection Service[STARTED]

Cisco Trace Collection Servlet[STARTED]

Cisco Unified Mobile Voice Access Service[STARTED]

Cisco WebDialer Web Service[STARTED]

Host Resources Agent[STARTED]

MIB2 Agent[STARTED]

Native Agent Adapter[STARTED]

SNMP Master Agent[STARTED]

SOAP -Log Collection APIs[STARTED]

SOAP -Performance Monitoring APIs[STARTED]

SOAP -Real-Time Service APIs[STARTED]

System Application Agent[STARTED]

Cisco CTL Provider[STOPPED]  Service Not Activated

Cisco CallManager Attendant Console Server[STOPPED]  Service Not Activated

Cisco Certificate Authority Proxy Function[STOPPED]  Service Not Activated

Cisco DHCP Monitor Service[STOPPED]  Service Not Activated

Cisco DirSync[STOPPED]  Service Not Activated

Cisco Extended Functions[STOPPED]  Service Not Activated

Cisco IP Manager Assistant[STOPPED]  Service Not Activated

Cisco Messaging Interface[STOPPED]  Service Not Activated

Cisco SOAP - CDRonDemand Service[STOPPED]  Service Not Activated

Cisco UXL Web Service[STOPPED]  Service Not Activated

Primary Node =true

admin:utils service start A Cisco DB

Service Manager is running

Component is not running

A Cisco DB[NOTRUNNING]

Joseph Martini Fri, 09/24/2010 - 11:50

What model server are you running?  Can do issue "utils remote_account enable" and "utils remote_account create user 1"?  If the file system is really in read-only mode there are a few bugs for different server models that this can happen with.  Also what's the full version of 7.1.3 you're running?

Michael Murray Fri, 09/24/2010 - 12:04

System version: 7.1.3.10000-11

I issued a utils system restart and the server never came back online. This was after trying to restart the server from the OS Administration GUI with no luck. I would click restart, the server would respond with a successful response but the server would never reboot. I'm remote so I'll have to try a system restore disc when I'm on site next week. For now everyone's running off the sub.

Correct Answer
srsivara Fri, 09/24/2010 - 13:37

A Cisco DB stopping could be a result of informix cores, sometimes. Run the latest 7.1.x recovery disk on the system and check if the automatic file check fixes issues. Depending on the model of the server, you can run a HPSmartStart or IBM DSA to determine the hardware health of the server.

- Sriram

Michael Murray Mon, 10/04/2010 - 05:52

I ran a fsck from the system recovery disk and it caught and repaired a few errors on the first pass. You'll want to continue to check the disk until there are no errors which may take multiple passes. I ran it once more and it came back clean. After that the server came up no problems.

srsivara Mon, 10/04/2010 - 06:15

Hi Michael,

You might want to keep in mind the following defect :

CSCth53322    Document the need for system rebuild after file system repair

Symptom:
Symptom is in a running state but part of the file system is corrupt causing certain features to fail.

Conditions:
This can occur if a server goes down and needs to be recovered using the recovery disc.

Workaround:
Rebuild the server if the file system becomes corrupt.

---

It is recommended by Cisco to rebuild the server after file system corruption, to ensure full functionality of the server.

- Sriram

Actions

This Discussion

Related Content