Trunking HELP

Unanswered Question
Sep 24th, 2010

I have a Cisco 2600 router that I would like to use for trunking, but have no idea how.  Below is my current home network setup, could you please provide soe guidence on how to configure trucking please.

Home_Network.jpg

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Fri, 09/24/2010 - 11:53

Jonathan

Difficult to tell from your diagram what you are looking to trunk etc. but as an example you should be able to adapt -

1 L2 switch = sw1

1 router = r1

sw1 (fa0/1) -> L2 trunk -> (fa0) r1

2 vlans

vlan 10 = 192.168.5.0/24

vlan 11 = 192.168.6.0/24

sw1 config

========

int fa0/1

switchport mode trunk

switchport trunk encapsulation dot1q

you also need to have created the L2 vlans 10 & 11 on sw1  eg.

sw1(config)# vlan 10

sw1(config-vlan)# name v10

sw1(config)# vlan 11

sw1(config-vlan)# name v11

r1 config

======

int fa0.10

encapsulation dot1q 10  <--- the 10 here needs to match the vlan ie. vlan from above

ip address 192.168.5.1 255.255.255.0

int fa0.11

encapsulation dot1q 11

ip address 192.168.6.1 255.255.255.0

then you allocate ports on sw1 into either vlan 10 or vlan 11 eg.

int fa0/2

switchport mode access

switchport access vlan 10

a PC connected into fa0/2 would be allocated an IP from the 192.168.5.x subnet and have it's default-gateway set to 192.168.5.1

Jon

woodjl1650 Fri, 09/24/2010 - 12:03

Well I am not exactly sure what trunking does, but I have the extra 2600 router and someone said that I could use it as a trunk, so not sure on what I want to trunk.  Will it help with anything on my current network?

Jon Marshall Fri, 09/24/2010 - 12:29

woodjl1650 wrote:

Well I am not exactly sure what trunking does, but I have the extra 2600 router and someone said that I could use it as a trunk, so not sure on what I want to trunk.  Will it help with anything on my current network?

Hmmm, so i typed all that out for nothing

Trunking allows one physical link to carry traffic for multiple L2 vlans. So usually switch links between other switches are trunk links so you can have the same vlans across multiple vlans. However these are only at L2 ie. you still need routed interfaces for the vlans so you can go from one vlan to another. Normally this is done on a L3 switch with Switched Virtual Interfaces (SVI) but sometimes you may have a L2 switch(es) but no L3 switch and you still want to route between vlans.

So you can also run a trunk link from a switch to a router and on the router have multiple subinterfaces and the router can then route between the vlans. Which is what i the config i provided would do.

Why would would you need it ? Well you have to be able to route your vlans if you want the vlans to be able to talk to each other. With a router you only have so many interfaces but you may need more vlans than interfaces. So you can have multiple subinterfaces on a router as in the example.

As i say you would normally do this on a L3 switch but if you don't have you can use the above. It's called "routing on a stick".

Jon

Actions

This Discussion

Related Content