AIR-CAP3501I access point not joining the Cisco 2100 Wireless Lan controller.

Answered Question
Sep 25th, 2010

Hello All,


I am installing a new LAP (AIR-CAP3501I ) through the wireless lan controller (AIR-WLC2112-K9) with software version 7.0. I have an external ADSL modem which will act as the DHCP server for the wireless clients and the LAP.


Please find my network setup as below:


The ISP ADSL modem , WLC and LAP are connected to a unmanaged POE switch. The LAP gets its power through the POE switch. When i connect the LAP and the WLC to the switch along with the ADSL modem, the LAPs are getting the ip address from the ADSL modem, however they are not joining the WLC for further process.


ADSL Modem ip address: 192.168.1.254


Management ip address on the LAP: 192.168.1.1 ( Assigned to port 1, untagged Vlan).


Ap Manager ip address: 192.168.1.1 ( Assigned to the same port i.e port1, Untagged Vlan).


The LAP is getting an IP address from the ADSL modem in the range of the DHCP scope.


I will paste the logs very soon.


Please let me know if i am doing anything wrong oe what will be the issue.



Thanks in advance,


Mohammed Ameen


I have this problem too.
0 votes
Correct Answer by bbxie about 6 years 2 months ago

No worries, mate! Glad to be able to help, have a good day!

Correct Answer by George Stefanick about 6 years 2 months ago

MO,

Throw BB some points and mark the post as resolved. It helps others as well when the look for a resolve ...

Correct Answer by bbxie about 6 years 2 months ago

From the message log, it clearly says that Invalid regulatory domain 802.11bg:-A     802.11a:-A for AP e8:04:62:0a:d1:20 and Invalid country code. So you need to correct your WLC's country code settings to be the same as AP(wireless-->country)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
mohammed ameen Sat, 09/25/2010 - 05:36

Hello All,


One small correction:


The AP Manager ip address is 192.168.1.2


Thanks,


Mohammed Ameen

mohammed ameen Sat, 09/25/2010 - 12:48

Hello All,


Please find the logs from the LAP below:


Translating "CISCO-CAPWAP-CONTROLLER"...domain server (192.168.1.254)
*Sep 25 00:15:52.996: %CAPWAP-3-ERRORLOG: Did not get log server settings from DHCP.
*Sep 25 00:15:53.996: %SYS-6-LOGGINGHOST_STARTSTOP: Logging to host 255.255.255.255 started - CLI initiated
*Sep  25 00:16:11.002: %CAPWAP-3-ERRORLOG: Could Not resolve CISCO-CAPWAP-CONTROLLER
*Sep 25 22:11:22.965: %CAPWAP-5-CHANGED: CAPWAP changed state to DISCOVERY
*Sep 25 22:11:22.965: %CAPWAP-5-CHANGED: CAPWAP changed state to DISCOVERY
*Sep 25 22:11:29.027:  status of voice_diag_test from WLC is false
*Sep 25 22:17:22.000: %CAPWAP-5-CHANGED: CAPWAP changed state to
*Sep 25 22:17:22.767: %CAPWAP-5-DTLSREQSUCC: DTLS connection created sucessfully peer_ip: 192.168.1.2 peer_port: 5246
*Sep 25 22:17:22.767: %CAPWAP-5-SENDJOIN: sending Join Request to 192.168.1.2
*Sep 25 22:17:22.767: %CAPWAP-5-CHANGED: CAPWAP changed state to JOIN
*Sep 25 22:17:22.921: %CAPWAP-5-CHANGED: CAPWAP changed state to CFG
*Sep 25 22:17:22.921: %DTLS-5-ALERT: Received WARNING : Close notify alert from  192.168.1.2
*Sep 25 22:17:22.924: %DTLS-5-PEER_DISCONNECT: Peer 192.168.1.2 has closed connection.
*Sep 25 22:17:22.924: %DTLS-5-SEND_ALERT: Send FATAL : Close notify Alert to 192.168.1.2:5246
*Sep 25 22:17:22.972: %CAPWAP-5-CHANGED: CAPWAP changed state to DISCOVERY
*Sep 25 22:17:22.972: %CAPWAP-5-CHANGED: CAPWAP changed state to DISCOVERY

Note: I am able to ping the AP manager ip (192.168.1.2) from the LAP.


Please let me know if i am doing anything wrong or i need to check something else.


I would appreciate if anyone can help me out.


Thanks,


Ameen


bbxie Mon, 09/27/2010 - 22:29

Have you checked WLC's message log? What's there? You can also use debug capwap event and debug mac addr ap-mac in WLC to find out what happened.

Usually it is because of mismatched regulatory domain, so check the country setting in WLC and the AP

Leo Laohoo Mon, 09/27/2010 - 22:44

*Sep  25 00:16:11.002: %CAPWAP-3-ERRORLOG: Could Not resolve CISCO-CAPWAP-CONTROLLER

Can you please create a DNS entry for "CISCO-CAPWAP-CONTROLLER" and point it to the Management IP address of the WLC?
mohammed ameen Tue, 09/28/2010 - 01:40

Hello All,

Please find the logs for  "debug capwap event" from the WLC below:

*spamReceiveTask: Sep 26 19:44:59.196: e8:04:62:0a:3f:10 Join Version: = 117465600

*spamReceiveTask: Sep 26 19:44:59.197: e8:04:62:0a:3f:10 Join resp: CAPWAP Maximum Msg element len = 92

*spamReceiveTask: Sep 26 19:44:59.197: e8:04:62:0a:3f:10 Join Response sent to 192.168.1.156:45510

*spamReceiveTask: Sep 26 19:44:59.197: e8:04:62:0a:3f:10 CAPWAP State: Join

*spamReceiveTask: Sep 26 19:44:59.197: e8:04:62:0a:3f:10 capwap_ac_platform.c:1216 - Operation State 0 ===> 4
*apfReceiveTask: Sep 26 19:44:59.198: e8:04:62:0a:3f:10 Register LWAPP event for AP e8:04:62:0a:3f:10 slot 0
*spamReceiveTask: Sep 26 19:44:59.341: e8:04:62:0a:d1:20 DTLS connection not found, creating new connection for 192:168:1:158 (45644) 192:168:1:2 (5246)

*spamReceiveTask: Sep 26 19:45:00.119: e8:04:62:0a:d1:20 DTLS Session established server (192.168.1.2:5246), client (192.168.1.158:45644)
*spamReceiveTask: Sep 26 19:45:00.119: e8:04:62:0a:d1:20 Starting wait join timer for AP: 192.168.1.158:45644

*spamReceiveTask: Sep 26 19:45:00.121: e8:04:62:0a:d1:20 Join Request from 192.168.1.158:45644

*spamReceiveTask: Sep 26 19:45:00.123: e8:04:62:0a:d1:20 Join Version: = 117465600

*spamReceiveTask: Sep 26 19:45:00.123: e8:04:62:0a:d1:20 Join resp: CAPWAP Maximum Msg element len = 92

*spamReceiveTask: Sep 26 19:45:00.124: e8:04:62:0a:d1:20 Join Response sent to 192.168.1.158:45644

*spamReceiveTask: Sep 26 19:45:00.124: e8:04:62:0a:d1:20 CAPWAP State: Join

*spamReceiveTask: Sep 26 19:45:00.124: e8:04:62:0a:d1:20 capwap_ac_platform.c:1216 - Operation State 0 ===> 4
*apfReceiveTask: Sep 26 19:45:00.125: e8:04:62:0a:d1:20 Register LWAPP event for AP e8:04:62:0a:d1:20 slot 0
*spamReceiveTask: Sep 26 19:45:00.273: e8:04:62:0a:d1:20 Configuration Status from 192.168.1.158:45644

*spamReceiveTask: Sep 26 19:45:00.273: e8:04:62:0a:d1:20 CAPWAP State: Configure

*spamReceiveTask: Sep 26 19:45:00.273: Invalid channel 1 spacified for the AP APf866.f2ab.24b6, slotId = 0

*spamReceiveTask: Sep 26 19:45:00.274: e8:04:62:0a:d1:20 Updating IP info for AP e8:04:62:0a:d1:20 -- static 0, 192.168.1.158/255.255.255.0, gtw 192.168.1.254
*spamReceiveTask: Sep 26 19:45:00.274: e8:04:62:0a:d1:20 Updating IP 192.168.1.158 ===> 192.168.1.158 for AP e8:04:62:0a:d1:20
*spamReceiveTask: Sep 26 19:45:00.274: e8:04:62:0a:d1:20 Setting MTU to 1485
*spamReceiveTask: Sep 26 19:45:00.274: e8:04:62:0a:d1:20 Finding DTLS connection to delete for AP (192:168:1:158/45644)
*spamReceiveTask: Sep 26 19:45:00.274: e8:04:62:0a:d1:20 Disconnecting DTLS Capwap-Ctrl session 0xa06d6a4 for AP (192:168:1:158/45644)

*spamReceiveTask: Sep 26 19:45:00.274: e8:04:62:0a:d1:20 CAPWAP State: Dtls tear down

*spamReceiveTask: Sep 26 19:45:00.277: spamProcessGlobalPathMtuUpdate: Changing Global LRAD MTU to 576

*spamReceiveTask: Sep 26 19:45:00.277: e8:04:62:0a:d1:20 DTLS connection closed event receivedserver (192:168:1:2/5246) client 192:168:1:158/45644).

The Acess point joins the Controller for 2-3 seconds and then unjoins again. I am not sure what i am doing wrong here. The access points are getting the IPs from the ADSL modem through the switch, then it talks to the WLC, however it does not join the controller for further process.

Note:

The Managemnet interface and the AP manager interface are assigned to the same port 1 with unassigned Vlan as mention above.

mohammed ameen Tue, 09/28/2010 - 02:06

Hello All,

I have few more details as below, hope this might help fix the issue:

The below output is a part of the command " sh tech" from the controller:


1#

interface address ap-manager 192.168.1.2 255.255.255.0 192.168.1.254
interface address management 192.168.1.1 255.255.255.0 192.168.1.254
interface address virtual 1.1.1.1
interface dhcp ap-manager primary 192.168.1.254  
interface dhcp management primary 192.168.1.254  
interface port ap-manager 1
interface port management 1

2#

*spamReceiveTask: Sep 26 21:14:37.013: %CAPWAP-3-POST_DECODE_ERR: capwap_ac_sm.c:4452 Post decode processing failed for Config status from AP e8:04:62:0a:d1:20
*spamReceiveTask: Sep 26 21:14:37.011: %LWAPP-3-RD_ERR4: capwap_ac_sm.c:2431 Invalid regulatory domain 802.11bg:-A     802.11a:-A for AP e8:04:62:0a:d1:20
*spamReceiveTask: Sep 26 21:14:37.011: %LOG-3-Q_IND: spam_lrad.c:9223 Invalid country code () for AP e8:04:62:0a:d1:20
*spamReceiveTask: Sep 26 21:14:37.010: %LWAPP-3-RD_ERR7: spam_lrad.c:9223 Invalid country code () for AP e8:04:62:0a:d1:20
*apfReceiveTask: Sep 26 21:14:36.861: %RRM-3-RRM_LOGMSG: rrmChanUtils.c:290 RRM LOG: Airewave Director: Could not find valid channel lists for 802.11bg
*spamReceiveTask: Sep 26 21:14:26.047: %CAPWAP-3-POST_DECODE_ERR: capwap_ac_sm.c:4452 Post decode processing failed for Config status from AP e8:04:62:0a:d1:20
*spamReceiveTask: Sep 26 21:14:26.044: %LWAPP-3-RD_ERR4: capwap_ac_sm.c:2431 Invalid regulatory domain 802.11bg:-A     802.11a:-A for AP e8:04:62:0a:d1:20
*spamReceiveTask: Sep 26 21:14:26.044: %LOG-3-Q_IND: spam_lrad.c:9223 Invalid country code () for AP e8:04:62:0a:d1:20
*spamReceiveTask: Sep 26 21:14:26.044: %LWAPP-3-RD_ERR7: spam_lrad.c:9223 Invalid country code () for AP e8:04:62:0a:d1:20
*apfReceiveTask: Sep 26 21:14:25.896: %RRM-3-RRM_LOGMSG: rrmChanUtils.c:290 RRM LOG: Airewave Director: Could not find valid channel lists for 802.11bg
*spamReceiveTask: Sep 26 21:14:15.078: %CAPWAP-3-POST_DECODE_ERR: capwap_ac_sm.c:4452 Post decode processing failed for Config status from AP e8:04:62:0a:d1:20

Thanks and Regards,

Mohammed Ameen R

Correct Answer
bbxie Tue, 09/28/2010 - 03:09

From the message log, it clearly says that Invalid regulatory domain 802.11bg:-A     802.11a:-A for AP e8:04:62:0a:d1:20 and Invalid country code. So you need to correct your WLC's country code settings to be the same as AP(wireless-->country)

mohammed ameen Wed, 09/29/2010 - 10:59

Hello bbxie,

Thanks a ton for your kind help !!!! It worked after changing the regulatory domain in the WLC to match with the LAP.

After that the LAP just joined the WLC without any issue and everything worked fine.

Thanks again.

God bless you

Mohammed Ameen

Correct Answer
George Stefanick Wed, 09/29/2010 - 13:53

MO,

Throw BB some points and mark the post as resolved. It helps others as well when the look for a resolve ...

Correct Answer
bbxie Wed, 09/29/2010 - 16:27

No worries, mate! Glad to be able to help, have a good day!

Vinay Sharma Mon, 09/19/2011 - 08:50

Great info BOXIE. 5+

Thanks,

Vinay Sharma

Community Manager

Sent from Cisco Technical Support iPhone App

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode