Cisco 6500 Vrf Multicast Problem

Unanswered Question
Sep 25th, 2010


I have configured a VRF lite on my 6500. Enabled multicast routing as well as VRF multicast routing.

What happens is Local multicast is streaming on L2 network (of course IGMP snooping is disabled). But on the default gateway there is no evidence of any multicast !! Show ip mroute vrf MCAST shows nothing related to the sever stream address. The server is directly connected to the switch and streaming to (which is working fine on the lan)....

any clue ?

with regards

Prasad. K

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Giuseppe Larosa Sun, 09/26/2010 - 06:48

Hello Prasad,

post the configuration of the vrf and show ip pim rp mapping vrf vrf-name

for PIM sparse mode but also for PIM sparse-dense mode an RP has to be configured

Hope to help


prasad.gsmc Tue, 09/28/2010 - 04:44


My problem is not even with mVRF.... it is not showing the first hop local mroute table (from there it has to escape to MDT tunnel 0) i am using ssm in backbone hence no RP

interface config is as follows

ip multicast-routing
ip multicast-routing vrf VPN_MCAST

ip vrf VPN_MCAST
rd 100:5
route-target export 100:1
route-target import 100:1
mdt default
mdt data threshold 1

interface vlan  500
ip vrf forward VPN_MCAST

ip address
ip pim dense-mode

interface gi1/3/1
description ##### connected to Soruce  #####
switchport mode access
switch port access vlan 500
no shutdown

interface gi1/3/2
description ##### connected to local client  #####
switchport mode access
switch port access vlan 500
no shutdown

show ip mroute vrf VPN_MCAST will not show the address while an active source is connected to interface g1/3/1 and a client on the local switch is able to view the stream .....


This Discussion

Related Content