NAT Question

Unanswered Question
Sep 27th, 2010

I am using NAT for my mail server, but when I check my IP address from my mail server using my address shows up as my routers WAN IP. Need to correct this because my routers WAN IP sometimes ends up on RBL lists. ip nat inside source static 71.162.x.x route-map SDM_RMAP_1 Any help is greatly appreciated!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
salterinc Mon, 09/27/2010 - 07:24

I am totally aware of that Paolo. I guess I did not make my question clear enough. I need the return address to be the NAT'ed address INSTEAD of my routers IP. For example.... router ip Mail server nat inside source static route-map SDM_RMAP_1 Is clearer?

salterinc Mon, 09/27/2010 - 07:31


Are you using NAT? If so, go to a server using NAT.

From your browser, go to What IP is displayed?


salterinc Mon, 09/27/2010 - 08:52

I found problem.

I needed to remove "route-map SDM_RMAP_1" because it was forcing it to use the IP address on my WAN interface instead of

ip nat inside source static route-map SDM_RMAP_1

route-map SDM_RMAP_1 permit 1

match ip address 104

match interface FastEthernet0

Thanks anyways.

salterinc Mon, 09/27/2010 - 09:15

At one point I did need it because I was having routing issues between VPN subnets. But a while back we upgraded to ver 12.4.15-T3 from a very early version and I think that may have impacted this.

I have router with multiple WAN interfaces, VPN connection to multiple sites and special settings. Not a simple configuration by all means.


Paolo Bevilacqua Mon, 09/27/2010 - 07:18

That is normal, and there is NO alternative.

You CAN NOT use private addresses on the Internet.


This Discussion