7941 Firmware upgrade problem

Unanswered Question
Sep 27th, 2010
User Badges:

I am trying to upgrade the SCCP firmware of a 7941 model, but the display locks on a upgrading message.


The new firmeware´s version is 8.X and the old one is previous from 7.X .


I found some Cisco documents that warned about the impossibility of a direct upgrade, if the 7941 old version was previous 7.X. In this case, I had to make a 7.X upgrade and, after this, a second upgrade to a 8.X version. But I´ve seen the document only after the problem.


I´ve reseted to the default factory conf and, after this, tried the upgrade through CallManager Express and a TFTP server (I´ve configured the .xml config file and uploaded all the files necessary to the  firmware upgrade), but it didn´t work. I didn´t try to change the firmware to SIP and back to SCCP.


Does somebody had already this problem?



Best Regards.

Carlos Fujimura.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Muthurani Lavan... Wed, 09/29/2010 - 03:26
User Badges:
  • Gold, 750 points or more

Hi Carlos


Yeah, during the Firmware upgrade for 7941G IPPhone, if you are currently running in the firmware earlier than 6.0(2) on

Cisco 7941G phone and want to upgrade to 8.x(x), you must do the following

1. First do 7.0(x) firmware upgrade, specifically 7.0(3) to prevent upgrade failures

2. Then do the required firmware upgrade 8.x(x) say 8.3.3


This is actually a two step process and I upgraded as per this and my phone works. 


Attached the link for reference.. If you have any doubts, pl revert.




http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cuipph/7961g_7961g-ge_7941g_7941g-ge/firmware/8_3_3_sr2/english/release/notes/61833sr2.html#wp68082



Thanks.

cfujimura Wed, 09/29/2010 - 09:47
User Badges:

Hi.


I´ve already tried to downgrade the 7941 firmware. The 7.X firmware version  is not supported by CUCM 5.X and above, so I tried to downgrade the 7941 firmware through CUCM Express, but it didn´t work.


I will have to install a 4.X CUCM (on a VM, for example) version to be able to install 7.X version of the 7941 firmware.


Best Regards.

Carlos Fujimura.

Muthurani Lavan... Fri, 10/01/2010 - 01:46
User Badges:
  • Gold, 750 points or more

Hi Carlos


Yes SCCP v.7.x firmware is not supported by CUCM 5.x and Instead of downgrading the CUCM, i have a better option you may try, just try to upgrade the latest release phone firmware.


Try upgrading your 7941 phone to latest release of sccp 9.0(3) and this is a 2 step procedure

First upgrade to sccp 8.3.3 and then upgrade to 9.0(3)


For all sccp firware upgrades from firware release versions earler than 8.3(3) to version 9.0(3) or greater, you must first upgrade your firmware to version 8.3(3). once upgraded to version 8.3(3), you can upgrade your ip phones to version 9.0(3) or later.


Thanks.


Attach the link for your reference.

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cuipph/firmware/9_0_3/english/release/notes/7900_903.html

cfujimura Tue, 10/05/2010 - 04:54
User Badges:

I´ve tried to upgrade to the last SCCP firmware version (I´ve installed the 7941 9.0.3 firmware on the CUCM), but it didn´t work. The display of the fone remain in the "updating" process and nothing happens.


I will try to change to a SIP firmware and back to a SCCP firmware. If it didn´t work, I will have to install a 4.X CUCM version on a VM.


Best Regards.

Carlos Fujimura.

Muthurani Lavan... Tue, 10/05/2010 - 05:01
User Badges:
  • Gold, 750 points or more

Hi Carlos


Just try it out, its other way of getting it done.  Let me know the results.


Thanks.

cfujimura Wed, 12/08/2010 - 11:14
User Badges:

I try to switch to sip firmware, but it didn´t work. The phone remains on the upgrading message in the display.


Best Regards.

Fujimura.

Actions

This Discussion