CDP table become Empty after few hours

Unanswered Question
Sep 28th, 2010

Hi,

I had a stack of 3750 witht the latest IOS version.

When I reboot the switch, I have all CDP from neighbor.

After few hours, the table is empty and no way to retreive it.

clear cdp, no cdp, cdp,...

Nothing works.

The only suitable way is to reboot completely the stack.

If I do a debug cdp event.

I receive the message below but I didn't find any comment on CCO.

Sep 28 08:36:03 UTC: CDP-EV: No space for insertion of civic location
Sep 28 08:36:03 UTC: CDP-EV: No space (1080) for insertion of location information information.
Sep 28 08:36:04 UTC: CDP-EV: No space for insertion of civic location
Sep 28 08:36:04 UTC: CDP-EV: No space (1079) for insertion of location information information.
Sep 28 08:36:04 UTC: CDP-EV: No space for insertion of civic location

Any Idea.

And I have a subsediary question. I have the same trouble with the VTP.

If I create a new VLAN on the switch attached to it, The new vlan didn't appear on this specific stack.

We have other stack with the same IOS and all is working fine for the other.

sh vtp status
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : EU-Backbone
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 0023.058c.2980
Configuration last modified by 192.168.44.254 at 9-23-10 18:30:02
Local updater ID is 192.168.250.199 on interface Vl502 (lowest numbered VLAN interface found)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 46
Configuration Revision            : 94
MD5 digest                        : 0xE1 0xC7 0xCA 0xD6 0xCD 0x39 0xCE 0x70
                                    0x1C 0x90 0xAE 0xF3 0xD9 0xDA 0xDE 0x07

Thanks in advance for your help.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
milan.kulik Tue, 09/28/2010 - 09:12

Hi,

looks like an IOS bug.

I remember something similar several years ago with 2940s - the CDP was not releasing the memory allocated and consuming the whole memory after some time.

Try to use Bug Toolkit on CCO or open a ticket with TAC.

BR,

Milan

s.balon Wed, 09/29/2010 - 00:25

Hi,

We allready try with 3 different IOS version, all has the same behavior.

We have some other stack in other location which run the same IOS with no CDP and VTP problem.

the bug toolkit didn't come with a similar problem.

Thanks for your help.

Steve

Ashley Georgeson Wed, 09/29/2010 - 00:27

Hi Steve,

Are all switches definitely running the same IOS?

Silly question as I am sure they probably are, but worth an ask!

Regards, Ash,

s.balon Wed, 09/29/2010 - 00:48

Hi,

The very latest software was only push on this specific stack.

But the 2 old version we test was deploy on the same time on all place.

Now, all the rest run the version 12.2(53)SE

and this one is running 12.2(55)SE.

But the problem exist since the beginning when every switch have the same version.

Just notice that we also have different switch connected to this stack like a 2950 and a 3560.

When debugging, we see that the connected switch send CDP update but the stack doesn't seems to receive it.

xx#sh cdp traffic
CDP counters :
        Total packets output: 31141, Input: 98
        Hdr syntax: 0, Chksum error: 0, Encaps failed: 0
        No memory: 0, Invalid packet: 0,
        CDP version 1 advertisements output: 23, Input: 14
        CDP version 2 advertisements output: 31118, Input: 84
xx#

The input counter was incrementing on the reload, once the cdp table is empty, the input counter will not increment anymore...

Steve

Ashley Georgeson Wed, 09/29/2010 - 00:55

I would advise on keeping a consistent configuration across your organisation - this would include IOS software versions as well as IOS control plane services - e.g. VTP.

Is this new switch still in test or is it now in production?

As an aside, I prefer not to use VTP server/client across switching environments, better to use them in transparent mode with a configuration revision of 0 to protect against a big VTP problem!

Regards, Ash.

glen.grant Wed, 09/29/2010 - 07:21

  I have seen cdp dissapear when the trunks are not setup correctly on each end .  Verify trun

k configs are the same and both sides are using the same  native vlan .

s.balon Thu, 09/30/2010 - 02:48

The switch is in production and we have big difficulties to reboot it :-(...

I will review the VTP config of all adjacant switch.

Thanks.

Actions

This Discussion