UCCX 8.0 Historical Reports

Unanswered Question
Sep 28th, 2010

I am in the process of upgrading to UCCX 8.0(2) from 7.x. I have a lab set up to test Applications, Scripts, CAD, CSD, and Historical Reports functionality. It doesn't appear that anything (not much anyway) has changed as far as the way UCCX 8 functions compared to UCCX 7. This is a good thing, however, since going from Windows to Linux is big enough of a change to deal with on it's own.

The one problem I am unable to get around is when I install Historical Reports as an administrator, normal users are not able to launch it. The below error is seen in the log file when a normal user tries to open it. This was not an issue with Historical Reports version 7. Also, when you install it as an admin, the shortcuts are not displayed on normal users' start/programs menu. I found a work around for this, but would prefer not to have to do it.

1: 9/24/2010 11:28:09 AM %CHC-LOG_SUBFAC-3-UNK:Error in setting the value of Informix Protocol (PROTOCOL) value in registry.
2: 9/24/2010 11:28:09 AM %CHC-LOG_SUBFAC-3-UNK:Failed to login user to the apps server since we failed to initialize database connections

NOTE: This happens on both Windows Vista and Windows 7

Your help is greatly appreciated,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
MARK BAKER Tue, 09/28/2010 - 12:14

I was able to work around this issue by editing the registry. I gave the USERS group full control permission of the INFORMIX folder under LOCAL MACHINE. I would prefer a solution that doesn't involve registry edits or admin privileges for end users.


Aaron Harrison Wed, 09/29/2010 - 01:05

Hi Mark

I'm guessing here that it's the first connection, and that it's trying to apply settings obtained from the server to the client informix drivers.

It may be that if you run it first as an admin and log in the the changes are applied and then stick (since they're in HKLM).

If it does it every time it's a bug - if right perms are required to those keys the installer should set it. You could argue that it's a bug anyway (i.e. if you automatically deployed it you wouldn't have chance to run it as admin).

I would probably build a standard, non-corporate build of the OS from the standard microsoft media, and install nothign on it but historical reports - don't even add it to your domain. If it works the same way, report it as a bug.

If on this standard build it works OK, you may have some domain policies that are increasing security and causing the issue...


Please rate helpful posts..

MARK BAKER Wed, 09/29/2010 - 06:04


Thanks for the reply. I see what you are saying. I have not tried this on a non-domain PC. I did first run Historical Reports as a local admin to verify that it worked prior to logging in as a standard user.

I first tried to deploy using WIndows SCCM. At first I thought that it wasn't installing at all since I didn't see the start menu shortcuts as a standard user. This was the second issue I had mentioned in the initial post. It took me awhile to realize that it was actually installing. I attempted to run the app after I realized that it had actually installed but with no shortcuts and it never started. From there I uninstalled it and installed it manually. When it still didn't work for a standard user, I dug deaper and found the log file that pointed to the registry issue.

I'll see if I can round up a standard build non-domain PC.

Thanks again,


keysors10 Mon, 09/12/2011 - 13:09

We are experiencing the exact same thing.  Did you ever find a fix besides the workaround of giving users full permissions to the INFORMIX folder?



MARK BAKER Mon, 09/12/2011 - 13:14

I never did find a fix for this other than the permission workaround. I plan on waiting for UCCX 9.x to come out and won't be putting any more time on this issue.


wenqianyu Tue, 09/13/2011 - 16:55

We had the same problem running UCCX 802 Historical Report on Windows 7 64 Bit Desktop. Here are our workaround:

1. In Registry Informix Folder, assign full access to local User

2. Run it once when logged in as Administrator

3. Assign local user full access to Historical Report Folder C:\Program Files(X86)\Cisco UCCX Historical Report\

Before we only change registry permission and it seems fixed the problem. But a few days later users reported again having problem to run report. After we changed permission on Historical Report Folder, this problem never come back again.

Hope this help.


ian.ryder Fri, 10/21/2011 - 07:09

Hi - I am now experiencing the same issue.  Did anyone get anymore information from Cisco on a Permanent fix?



This Discussion

Related Content