SPA504g daylight savings rule not working

Unanswered Question
Sep 29th, 2010

Daylight savings has just come into effect in New Zealand. The official start date is the last Sunday in September at 02:00 and the time moves forward one hour. The official end date is the first Sunday in April when the time moves back one hour from 03:00 to 0:200. On my Cisco SPA504g phones I had the following "Daylight Savings Time Rule" configured and the "Daylight Savings Time Enable" set to yes:


However the time on the phone did not adjust forward by one hour. I also tried the following rule:


This rule also made no adjustment to the time. I can't seem to make the time change at all with this function. I am using firmware version 7.4.6.

Has anybody had a similar experience with this function?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
nseto Wed, 09/29/2010 - 11:31

These rules look fine.

You are basing it off of the ntp server setting, right?   So primary NTP server and Time Zone parameters are populated correctly?

xtechdata Mon, 11/08/2010 - 15:36

I'm having the same issue on 7.4.6.

GMT -4

Ignore DHCP Time Offset = yes

Daylight Saving Time Rule =start=3/8/7;end=11/1/7;save=1

Daylight Saving Time Enable= yes

nseto Mon, 11/08/2010 - 16:37

Your setting is fine.  Please enclosed the unit config, easiest is to use IE and login as admin/advanced and just save as htm.  Thanks.

nseto Tue, 11/09/2010 - 09:52

That looks fine, the settings for your time is like what my phone looks like.

Using NTP, timezone, daylight rule.

It should have taken effect on the hour.

You can try erasing the daylight rule and letting it run till the top of the next hour.

Then put back in the daylight rule and wait till the next top of the hour to see if it takes effect.

The rule is supposed to check and take effect at the top of the hour (just a few mins afterward, you are supposed to see the 1 hour change)

It does work for me.


This Discussion

Related Content