Configuring WLC (4400) with multicasting enabled network

Unanswered Question
Sep 29th, 2010

Hi netpros!

I'm setting up the multicast configuration on a 4400 wlc for communication with the multicast enabled network.I used the Multicast with Wireless LAN Controllers (WLCs) and Lightweight Access Points (LAPs) Configuration Example from cisco as a reference.

I must mention that while in the wired lan, the multicast is acting as expected.

But, i havent managed to get it work on the wlan.

Among other questions/doubts i have i believe that the following is the most critical:

After setting up the Multicast group (which is the actual udp url we need to receive from the source) should i have been able to see that specific group under Monitor->Multicast-L3 MGID Mapping ? Because i cant and i'm not sure if thats a problem to start investigating from or not.

Can anyone give me some feedback?

Thanking you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.2 (4 ratings)
Loading.
Serge Yasmine Tue, 10/05/2010 - 08:35

Hello,

1- so how is multicast configured on the WLC? Is mcast delivery configured for mcast output?

Do you have this when you do a "show network summary" from CLI on your WLC?

Ethernet Multicast Mode..................... Enable   Mode: Mcast 

2- make sure that multicast routing is enabled on your network and also on the VLANs between the Management Interface of the WLC and the Access Points VLANs.

Here is from my LAB

(Cisco Controller) >config network multicast global enable

(Cisco Controller) >config network multicast mode multicast


(Cisco Controller) >show network multicast mgid summary

Layer2 MGID Mapping:
-------------------
InterfaceName                    vlanId   MGID
-------------------------------- ------   ----
                       306      10
                       307      11
                       305      8
                       2        0

One important thing as well for Multicast over wireless --> Multicast traffic over the air is not acknowledged, so it is sent from the Access Point over the Highest common Mandatory data rate without caring whether the client received it or not.

Unlink unicast, Mcast doesn't have ACKs.

So make sure not to be too agressive on your Mandatory data rates over the air and that you client is within good range so it can decode correctly the Mcast traffic.

Hope this helps.

Serge

panayiotiscy Tue, 10/05/2010 - 23:49

Hi Serge,

Thank you fora answering!

So here is my outpout:

Ethernet Multicast Forwarding............... Enable
Ethernet Broadcast Forwarding............... Disable
AP Multicast/Broadcast Mode................. Multicast   Address : 238.1.1.100

Layer2 MGID Mapping:
-------------------
InterfaceName                    vlanId   MGID
-------------------------------- ------   ----
                           120      11      
                           136      13      
                           122      16      
                           121      14      
guest                               125      8       
management                       0        0       
                           130      10      


Layer3 MGID Mapping:
-------------------
Number of Layer3 MGIDs........................... 8

Group address    Vlan  MGID
---------------  ----  ----
224.0.0.251      120   559
224.0.0.251      122   558

224.0.0.251      136   550
224.0.0.252      121   554
239.255.255.250  120   556
239.255.255.250  121   552
239.255.255.250  122   557
239.255.255.250  136   551

Also, the management interface of the WLC is in vlan 10 and the interface vlan 10 is configured for multicasting. Plus, i have also added the interface associated with ssid 1 for multicasting. The ssid 1 is the wlan we use for connecting and requesting the multicast.

Do you see any misconfiguration here?

Thank you

Serge Yasmine Wed, 10/06/2010 - 03:47

The only thing that could be mis-configured is the address being used for mcast.

You are currently using 238.1.1.100.

The Cisco Unified Wireless Network solution uses some IP address           ranges for specific purposes. Keep these ranges in mind when you configure a           multicast group:

Although not recommended, any multicast address can be assigned to           the LWAPP multicast group; this includes the reserved link local multicast           addresses used by OSPF, EIGRP, PIM, HSRP, and other multicast protocols.

Cisco recommends that multicast addresses be assigned from the           administratively scoped block 239/8. IANA has reserved the range of           239.0.0.0-239.255.255.255 as administratively scoped addresses for use in           private multicast domains. See the note for additional restrictions. These           addresses are similar in nature to the reserved private IP unicast ranges, such           as 10.0.0.0/8, defined in RFC 1918. Network administrators are free to use the           multicast addresses in this range inside of their domain without fear of           conflict with others elsewhere in the Internet. This administrative or private           address space must be used within the enterprise and its leave or entry blocked           from the autonomous domain (AS).

Note: Do not use the 239.0.0.X address range or the 239.128.0.X address             range. Addresses in these ranges overlap with the link local MAC addresses and             flood out all switch ports, even with IGMP snooping turned on.

Except for that the config is ok, also enable IGMP snooping  on the WLC and test mcast to see if it works.

If still not working, maybe open a TAC case for further troubleshooting?

panayiotiscy Thu, 10/07/2010 - 05:41

Hi Serge,

I will change the multicast LWAPP group ip  and let you know if the problem is resolved.

Thanking you

panayiotiscy Thu, 03/17/2011 - 04:09

So, i have managed to make the multicast work for my wireless clients.

Though,i'm still testing this in a lab enviroment and the results i receive (in terms of video quality) are really bad.

My wlc (4404) runs the latest version 7, and i have disabled the lowest data rated for 2.4 and 5 GHz.Also, i'm testing this using AP1142.

Still, i'm not getting any good video quality.

What else is to be tuned for good multicasting though the wlc?

Thank you

Stephen Rodriguez Thu, 03/17/2011 - 05:43

Double check what your "mandatory" rates are.  The WLC will send multicast at the highest configured mandatory rate.  You should also take a look at the QoS configurations.  If you have a busy network, including a busy RF environment not just the LAN, you may want to enable the WLAN that's receiving the stream to be "gold" for QoS, so that the packets get the appropriate mark across the LAN as well as at the radio in the AP.

Cheers,
Steve

--

If  this helps you and/or answers  your question please mark the question as "answered" and/or rate it, so  other users can easily find it.

panayiotiscy Mon, 03/21/2011 - 04:43

Hi Steve,

I had disabled the lowest data rates while testing it.

But, if i'm going to set the highest data rates as "Mandatory", will this have an impact(negative) on the wireless coverage distance?

Thank you

Stephen Rodriguez Mon, 03/21/2011 - 08:13

Ok, you don't want to set the highest data rate to mandatory.

The WLC will use the highest rate that is configured for mandatory.  For Example ONLY!

If you set 9M, 11M, and 12M as mandatory rates, the WLC will send multicast packets at 12M, and 12M only.

If you set 9M to mandatory and the higher rates to supported, the WLC will send multicast packets at 9M.

As for what rate to set mandatory, you need to know your environment.  Normally I'd say to set 9M to be the mandatory rate, and disable everythign below it.  This will keep the cell size a bit smaller, send multicast at a rate that should be attainable in the entire cell, and because this is a OFDM rate, it will keep the legacy B only clients off of the network.

Cheers,
Steve

--

If  this helps you and/or answers your question please mark the question as "answered" and/or rate it, so other users can easily find it.

Actions

This Discussion