Anyconnect works on my PC, why not my Mac?

Unanswered Question
Sep 29th, 2010

Using Anyconnect, I can connect to my office network via my home PC, but not my home Mac. What gives?

This is the message I get when I try connecting thru my mac:

The AnyConnect package on the secure gateway could not be located. You may be experiencing network connectivity issues. Please try connecting again.

If it helps, my computer at work is a Mac, but our IT guys are not very familiar with Apple computers. And, I know about as much about our servers as they do Macs.

Thanks for any help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jennifer Halim Wed, 09/29/2010 - 07:05

You would need to install the mac version of AnyConnect package on the ASA, that's why you are having the error message:

The AnyConnect package on the secure gateway could not be located.

Please kindly install the MAC version of the AnyConnect package to your ASA.

johnsosh1 Wed, 09/29/2010 - 07:12

Is that something I can do, or does my server admin have to do this?

Second, does this require opening a port? I know they said they did not want to open any ports. However, not sure why they would have to do this on a mac if they dont on pc's.

Thanks again so much.

Jennifer Halim Wed, 09/29/2010 - 07:16

It is something that the admin needs to do. Admin would need to add the MAC version of the AnyConnect package onto the headend device (possibly an ASA firewall).

No need to open any other ports for MAC. If PC can connect and access the network, MAC would also be the same.

The only thing required is for admin to add the MAC AnyConnect package to the headend device.

Hope that helps.

deon.steyn1 Tue, 05/10/2016 - 00:30

Hi,

I am having the same issue, upgraded Mac OSX to new Capitan version and same error.

The only funny is that on the Cisco ACS the authentication is successful. User connected but on the Mac it says The AnyConnect package on the secure gateway could not be located. 

I'm not using AD just ACS database to authenticate.

Cisco AnyConnect is version 4.2

Cisco ACS version 5.3.0.40

grahamhand1 Wed, 08/17/2016 - 04:31

Why is this still a thing?  I am trying to connect to an ASA from a Mac in 2016 and Cisco have still not seen fit to just add the Mac AnyConnect client as a matter of course.  Are you waiting to see whether this OSX thing is gonna take off?

Actions

This Discussion