COBRAS Unity to Unity Connection

Unanswered Question
Sep 29th, 2010
User Badges:

I am trying to use COBRAS to export information from a Unity 4.0.5 to a Unity Connection 7.1.5.  I am able to get an export fine using the COBRAS Export for Unity, but when I try to import this to UCX using the Cobras Unity Connection import tool I get an error that says the backup cannot be opened.  Am I using the correct versions of the tools for what I am trying to do?  The Unity Tools website doesn't seem to address the crossplatform process at all.  Additionally, the individual tools are not well described.


Any help would be much appreciated.


Thanks,


Justin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lindborg Wed, 09/29/2010 - 10:43
User Badges:
  • Cisco Employee,

hmmm.... so you reviewed the help file and training videos offered on the home page and the assesment is the process is not well covered?  Ouch.  I spent weeks on that - can you be more specific about where you're getting confused so I can make it better?  Just saying it's not good and leaving it at that doesn't give me much to work with.


The COBRAS Import for Connection is, indeed, the correct tool - the help file goes into some detail about what you need to configure on the Connection server for this, troubleshooting techniques should you have problems with HTTP, IMAP/SMTP connectivity etc... You install this on a Windows server that can connect to your Connection server you want to import to and you should be good to go.


If the error is indicating you can't open the file (the full text of this error message as well as versions you are using would be helpful here) the most likely reason I can think of is perhaps where you're opening the MDB file from does not have full write/execute permissions and/or the file is marked read only or the like.


You should be able to open the MDB file using the DAta Viewer utility (also available off the home page) which may be an interesting test... make sure you have the MDB file created by the backup on your local Windows box to rule out permissions issues in a shared folder (a common bugbear in Windows) or the like - if it also can't open the file and you've determined it's not forced to read only (i.e. from a DVD burn perhaps?) then it's likely the backup was somehow corrupted - this this seems unlikely.

jmachiggins Wed, 09/29/2010 - 10:56
User Badges:

The exact error is-


"Could not open MDB file to check for version information.  Make sure to select the MDB file that starts with 'UnityDBData_Backup_' and that the selected file was created by an appropriate version of the Unity Connection Backup tool and try again."


I have full access to the files no issues there.


The movies are great, but to us they look to only cover the apples to apples process and not the apples to oranges of Unity to Unity Connection.   On the download page it would be great if you could include a bit more in the description fields.  Something like Use this version to import Unity data into Unity connection would be a big help.  When an error is encountered one finds them selves asking questions like-


I pulled the data from a Unity..Should I be using the Unity restore utility instead?  After all it's Unity data I pulled and the description of the tool says Unity data can be restored to Untiy Connection.  Where as the Unity Connection Import only lists Unity version compatability and says nothing at all about Unity at all one way or the other.


I hope that helps explain my position from the original post a bit.

lindborg Wed, 09/29/2010 - 11:23
User Badges:
  • Cisco Employee,

still looking for version information though - what version of Unity Export did you use to create the backup?  That error indicates a table is not found in the backup that should be there - it was added many versions ago - perhaps you did a backup with an older version that didn't have it?


I tried to convey that info with the tool name - COBRAS Import for Connection is to be run against Connection - COBRAS Import for Unity is for Unity - the backup MDB file can be created against any product (Connection 1.2, Unity, Conneciton 7.x+) - that has no bearing on the import application itself.  THis is what I was talking about in the videos when I mention "product neutral MDB file format".


I can add a note on the download page for each link to try and clarify this if there is confusion on that point.

jmachiggins Wed, 09/29/2010 - 11:30
User Badges:

All utility versions used are the ones curently available for download on the Unity Tools website.  7.0.100 for export and 1.1.176 for import. The Unity is 4.0.5 and the Unity Connection is 7.1.5.


Also we get no errors when we run the export tool.

lindborg Wed, 09/29/2010 - 11:47
User Badges:
  • Cisco Employee,

Well, doing restores from my library of backups (I have a backup for every version of Unity/Conneciton released) shows now problems - let me fire up my 4.0(5) server and do a download from scratch and take an export to review just to make sure something obvious isn't missing in the setup or the like.


if I can't find anything screamingly obvious there I may need to take a look at your MDB file itself for clues - that routine that is failing is extremely straight forward - it opens the MDB version table and pulls information about the backup that gets populated there - hasn't changed in the better part of a year.  I'd be suprised if something is haywire there and I don't know what the MDB file would be corrupted right off hand but looking at it raw may provide some clues.

lindborg Wed, 09/29/2010 - 12:01
User Badges:
  • Cisco Employee,

Well, downloaded the Unity Export from the web site directly to my Unity 4.0(5) rig (no previous versions installed), ran an export and then imported that to the 7.1(3) box I have installed for testing and it worked flawlessly from end to end.


We can at least rule out something obvious in the export packaging at any rate.


Did you try and open the MDB file with the Data Viewer utility yet?  If that fails to open the MDB file as well you almost certainly have a corrupted MDB file - it'll try and open anything, it doesn't care if it's old or new.


Also, anything unusual about the Unity server you installed the export on - was there an older version of COBRAS already on there?  Did you install over it or to a new folder or uninstall it first?  Any AV/security packages at play that may have truncated the file comits on the back end or the like?  Anything I'm perhaps not doing in my test that you are - just looking for obvious areas to try here.


Beyond that the best I can offer is to have you send me the MDB file via FTP and I'll take a look - not sure how big the backup is - but if it included messages I don't need those files (they're stored in seperate MDB files from the directory backup).  You can ping me directly (lindborg at cisco dot com) and I can send you the FTP instructions.

lindborg Wed, 09/29/2010 - 12:43
User Badges:
  • Cisco Employee,

as a side note... you ARE opening the file named UnityDBData_Backup_xxx, right?  The error dialog notes that so I assumed so but just wanted to check... sounds like maybe you're trying to open one of the message backup MDB files or the like.


Even if you're restoring only messages you still need to open the directory MDB file - the mailbox references are all pulled from there, they have to be.  Further there can be multiple message MDB files (it has to roll them about every 7000 messages or so given file size limits).  So you don't pick message files like that, you choose users and then messages are pulled.


You can choose to restore messages for selected users and/or only restore messages for users you restore on the last page (there's a checkbox that lets you indicate existing users don't get touched other than messages).


Just a guess - let me know what you're doing.

jmachiggins Wed, 09/29/2010 - 13:31
User Badges:

We got it.  There was some virus software running that was not readily apparent.  As soon as we killed that we got a good backup.  You mentioned security software.  And the previous backup files, even though they wee over a meg in size, came up as empty when I tried to open them in the viewer utility as well.  That made me sure we had something blocking the export even though there were no errors listed.


Thanks for the help.


Justin

lindborg Wed, 09/29/2010 - 14:02
User Badges:
  • Cisco Employee,

good deal - that's a little unusual that the file would be empty - but MDB files create a temporary locking file (to deal with multiple clients) and then does simple transaction updates (i.e. you write to memory and it comits it to the file structure in a "lazy cache" mechanism) - I'd think if the virus scanner was blocking access to the file updates it would be throwing errors but maybe not.  Either way the client writes to memory and moves on with life.


Unfortunately there's no easy way to detect/report on AV (or CSA or the like) security apps from the application side - the CSA stuff has come up in the field before since it can restrict access to updating files by unknown EXEs (i.e. COBRAS_Export.EXE) or the like.  The joys of security.


either way, glad you got it going.

Actions

This Discussion