IP Multicasting Troubleshooting

Unanswered Question
Sep 29th, 2010

Hello All.

Multicast video streaming is not working for only one VLAN (172.28.7.0/24)

How to find The router is detecting IGMP hosts to join group ?

Pls guide me to make this works.

Please find below few outputs from Router:

ip multicast-routing

interface GigabitEthernet1/0.3

  ip address 172.28.7.254 255.255.255.0

ip pim sparse-dense-mode

  ip igmp query-interval 125

end

sh ip igmp interface

GigabitEthernet1/0.3 is up, line protocol is up

  Internet address is 172.28.7.254/24

  IGMP is enabled on interface

  Current IGMP host version is 2

  Current IGMP router version is 2

  IGMP query interval is 125 seconds

  IGMP querier timeout is 250 seconds

  IGMP max query response time is 10 seconds

  Last member query count is 2

  Last member query response interval is 1000 ms

  Inbound IGMP access group is not set

  IGMP activity: 113 joins, 109 leaves

  Multicast routing is enabled on interface

  Multicast TTL threshold is 0

  Multicast designated router (DR) is 172.28.7.254 (this system)

  IGMP querying router is 172.28.7.254 (this system)

  No multicast groups joined by this system

sh ip igmp groups

IGMP Connected Group Membership

Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted

230.0.0.2        GigabitEthernet1/0.3     00:22:50  00:06:13  172.28.7.114

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Wed, 09/29/2010 - 14:07

Hi,

If it is only for one vlan and multicast does not need to be routed you don't need ip pim sparse-dense-mode

Can you add

ip igmp snooping querier

and test again

HTH

Reza

Lei Tian Wed, 09/29/2010 - 15:05

Hi,

From the IGMP group output, you have 172.28.7.114 as a host. Is that the host not receiving mcast stream? What switch is connecting to the router? Is it doing IGMP snooping?

Regards,

Lei Tian

Actions

This Discussion