NVRAM: Unable to read configuration. Try again later.

Unanswered Question

Hi,


I have built a 3750 switch stack (8 switches) and every now and then (random) when i do a "show run" or "write mem", i get the following error message

NVRAM: Unable to read configuration. Try again

It doesn't happen all the time, its a random thing. I'm currently using c3750-ipservicesk9-mz.122-53.SE2.bin.

I have checked the memory and there's a lot of free memory. I am the only person consoled onto the stack. I did reboot the stack but its an intermittent problem.


Anyone encountered this issue before?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Leo Laohoo Wed, 09/29/2010 - 18:00

When you get this error message it usually is an IOS bug.  I've used that version IOS and I've never seen this happen to me.  Another factor is the size of your switch stack too.

tstewart Tue, 10/05/2010 - 09:13

The error message indicates the nvram is "locked" by another process.  You typically see this message when multiple users are trying access the nvram at the same time, when the nvram is taking a long time to save, etc.  When you experience this issue how long does it last?  Meaning, are you able to execute a wr t, or wr right after you see the message?  If you see the message continously for a period of time, you can use the command "show configruation lock" to see which process is locking the nvram.  You can also use the debug "debug configuration lock" to see when a lock is enabled or disabled.

You should probably check to make sure that nvram is not being accessed by something else at the same time you are trying to access it (another user, snmp, http-server, etc.)

Tim

Hi Timothy,

I am the only person consoled onto the stack. The stack is not in production yet, so no one else is connected to it except myself.

How long does it last? I'd say a couple of seconds. I might do a show run or write mem and have the error come up, but if I try again after getting the message, it's fine...i can execute the command without getting the error. It's happening randomly.

I will most definately use that command. Hopefully it will tell me something.

As leo mentioned earlier, I think it may have something to do with the size of the stack (8 switches).

Snmp, http server, etc have already been disabled.

Thanks.
DK

tstewart Tue, 10/05/2010 - 14:59

I apologize, I apparently must have missed the fact that you had 8 switches in a stack.  When in a stack configuration, the system will periodically update all of the stack members with the current configuration.   It takes a small amount of time for this update to occur, but as the configuration grows in size as does the amount of time taken during the stack updates.  In addition to the periodic updates, modifing the configuration will also result in a stack update.  When the stack is being updated, the configuration will be unavailable (i.e. it is locked).  I suspect you are seeing the message during one of the periodic updates which explains why it seems to be random.  If you can catch it with the show config lock command then we can verify if the process which has the lock is indeed also responsible for update the stack members.

Thanks

Tim

tonykazee Tue, 05/24/2011 - 22:26

I have noticed the same problem when working on larger 3750 and 3750X stacks on several different code levels.  I applied the "DEBUG CONFIGURATION LOCK" command and was able to duplicate the problem.  I shut down and unused interface and tried to write the configuration and got the messages below:

May 25 00:09:55: Parser: - Config. Lock requested by process <342> client
May 25 00:09:55: Parser: - Config. Lock acquired successfully !
May 25 00:09:55: Parser: -  Config. SHARED UnLock requested
May 25 00:09:55: Parser: - Config UNLOCKED !

May 25 00:10:08: Parser: - Config. Lock requested by process <342> client
May 25 00:10:08: Parser: - Config. Lock acquired successfully !
May 25 00:10:08: Parser: -  Config. SHARED UnLock requested
May 25 00:10:08: Parser: - Config UNLOCKED !wr
May 25 00:10:15: Parser: - Config. Lock requested by process <342> client
May 25 00:10:15: Parser: - Config. Lock acquired successfully !
May 25 00:10:15: Parser: -  Config. SHARED UnLock requested
May 25 00:10:15: Parser: - Config UNLOCKED !end
Stack-1#wr
May 25 00:10:17: %SYS-5-CONFIG_I: Configured from console by tkazee on vty0 (10.65.128.62)

May 25 00:10:20:  Exec command locking feature is not enabled.
NVRAM: Unable to read configuration. Try again later.
Stack-1#

The problem appears to be related to the "SSH Process".  You are not alone.

sobsupport Tue, 02/05/2013 - 21:18

Hi Daniel,

Did you ever manage to resolve this issue? I have a 4500R-E with a similar issue. The first SSH user to login is unable to write or read the running config yet any other user taking up the second session works fine?

I should mention that it started happening after i started kron tftp transfers from the unit to a tftp server for backups of the config on regular basis. the switch seems to be working fine its just that the first logged in user is hamstrung.

I had a look at the 'debug conf lock' and it returned no locks, There seems to be heaps of memory free and closing the user sessions doesnt seem to make any differences?

Any thoughts??

Actions

This Discussion