CISCO 1841 not responding properly every after 4 hours of operation

Unanswered Question
Sep 29th, 2010

hi. we're having problems with our network. once the operation starts, approximately after 4 hours, ping replies from cisco 1841 are two time<1ms followed by requet timed out and goes all over again. i'm no cisco expert and i dont know what is really the problem. i've done some configurations, half of it i don't understand completely. when this happens, calls are getting bad (btw, im working in a very small call center). callers can hear the other end clearly but they cannot hear our agents. from my point of view, we are not sending anything outside our network. im not sure but it seems that our packets are not getting out of the cisco router. then we will do a reset, and everything will be back to normal for the next 4 or 5 hours again. the cpu is below 10% when this is happening. no drop packets on the interfaces. can you please help me identify why after resetting the router, we're back in business again? is there something like memory, cache that's getting full that needed clearing in order for us to operate again? i know i have of things to learn. thanks in advance. by the way, this is my first post in this forum. sorry for my english.

Current configuration : 3037 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname test
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$/WsF$kQL1pXS8lweqVKmSio4ug.
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 8
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no ip subnet-zero
no ip source-route
ip cef
!
!
ip dhcp excluded-address 192.168.1.1
!
!
no ip bootp server
ip domain name test.com
ip name-server xxx.xx.xx.xxx
ip name-server xxx.xx.xx.xxx
ip name-server xxx.xx.xx.xxx
!
username test privilege 15 secret 5 $1$kpoG$pKrat5PHTm86q4Ll3qxrB.
!
!
class-map match-any VOIP
match access-group name RTP
match access-group name SIP
!
!
policy-map VOIP
class VOIP
  bandwidth 3000
class class-default
  shape average 1000000
!
buffers small permanent 200
buffers small max-free 250
buffers small min-free 50
buffers middle permanent 100
buffers middle max-free 150
buffers middle min-free 30
buffers big permanent 150
buffers big max-free 200
buffers big min-free 40
!
!
interface FastEthernet0/0
description LAN
ip address xxx.xx.xx.xxx 255.255.255.224
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip route-cache flow
speed auto
full-duplex
fair-queue 4096 256 0
no mop enabled
hold-queue 150 in
!
interface FastEthernet0/1
description WAN
bandwidth 4000
ip address xxx.xx.xx.xxx 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
speed auto
full-duplex
no mop enabled
service-policy output VOIP
hold-queue 150 in
!
interface Serial0/0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
shutdown
clock rate 2000000
!
interface Serial0/0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
shutdown
clock rate 2000000
!
ip classless
ip route 0.0.0.0 0.0.0.0 xxx.xx.xx.xxx
ip route 192.168.2.0 255.255.255.0 xxx.xx.xx.xxx
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip access-list extended RTP
permit udp any any range 10000 20000
ip access-list extended SIP
permit tcp any any eq 5060
permit udp any any eq 5060
permit udp any eq 5060 any
permit tcp any eq 5060 any
!
logging trap debugging
logging 192.168.2.184
no cdp run
!
control-plane
!
!
line con 0
password 7 01202F286D2E342200621F5B4A51
login
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
password 7 00373A2A327E392B2E0F1D1C5A4D
login
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
password 7 072D13796D2C2B242E43595F50
login
transport input telnet
!
scheduler allocate 4000 1000
end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Federico Coto F... Wed, 09/29/2010 - 18:14

Hi,

Could very well be something wrong with the router but could be a network problem as well.

When this happens, can you still get out to the Internet?

From the router, can you PING the internet?

I would say that next time before resetting the router, check if you can PING across and from the router.

Are you running a weird IOS image in 12.4 train?

Federico.

tokugamo8 Thu, 09/30/2010 - 05:51

i can still ping the router, but it was to successful ping replies and 1 timed out and then 2 successful again. it's like the router is not responding every after 2 secs. i've never tried pinging from the router because it's responding very slow when i am logged in using telnet. im sorry but i dont know what you mean by "running a weird IOS image in 12.4 train". sorry, im not really good at this. but thanks for the reply.

jimmysands73_2 Wed, 09/29/2010 - 22:30

I know 4 hours is the default timeout for Cisco routers arp cache or 60*60*4 = 14400 or..... 4 hours

I saw this on a article here about 6 months ago, unfortunatly I lack the technical knowledge to understand if it is impacting your issue.  But if the router is losing the arp, right around the time your pings fail, this it might be place to look.  I know one of the top 5'rs on here was the ones who's post I read, but I can not find it now....hopefully one of them will weigh in (again!).

tokugamo8 Thu, 09/30/2010 - 06:27

but, isn't it than when you ARP, the router will just automatically refresh it? also, can you guys tell me what these results mean?

SHOW IP TRAFFIC

  Rcvd:  32614623 total, 7198 local destination
         0 format errors, 0 checksum errors, 371 bad hop count

  Drop:  3952 encapsulation failed, 0 unresolved, 0 no adjacency
         202 no route, 0 unicast RPF, 0 forced drop

Rcvd: 42 total, 0 checksum errors, 42 no port

SHOW CEF DROP

Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj  ChkSum_Err
RP          3953           0           0         202           0           0

Actions

This Discussion