Creating an Etherchannel between HP Procurve and Cisco 3750 stack.

Unanswered Question
Sep 30th, 2010

Hi,

I've got a 2x Cisco 3750 switches in a stack and 2x HP Procurve 2910al-48G.

The HP switches have a 10Gbs backpane link between them.

I need to create a 4 link Etherchannel between the Cisco stack and the 2x HP switches.

I cross wired all the 4 switches.

Drawing1.jpg

I created the Etherchannel on Cisco stack

And also created a trunk trk2 on both the switches.

Now I'm not too sure how to setup the Etherchannel (trunk) on HP switches to talk to Cisco switches

I’m using 801.q trunk and VLAN 300 as native VLAN on the Cisco.

I would appreciate if someone could please send me the config on the HP side.

Here is the Cisco stack config.

!

!

port-channel load-balance src-dst-ip

!

spanning-tree mode pvst

spanning-tree logging

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

spanning-tree vlan 1,100-104,200,300 priority 40960

!

vlan internal allocation policy ascending

!

!

!

interface Port-channel1

switchport access vlan 100

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,100,300

switchport mode access

!

interface GigabitEthernet1/0/1

description Etherchannel 1

switchport access vlan 100

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,100,300

switchport mode access

shutdown

channel-group 1 mode on

spanning-tree portfast trunk

!

interface GigabitEthernet1/0/2

switchport access vlan 100

switchport mode access

spanning-tree portfast trunk

!

interface GigabitEthernet1/0/3

switchport mode access

!

interface GigabitEthernet1/0/4

description Wireless-TER

switchport access vlan 120

switchport mode access

spanning-tree portfast trunk

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

switchport access vlan 111

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

macro description cisco-switch

spanning-tree link-type point-to-point

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

description Barracuda

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/0/12

description Trunk to Core 3750

switchport trunk encapsulation dot1q

switchport trunk native vlan 300

switchport trunk allowed vlan 1,100-104,110,112,120,200,300

switchport mode trunk

!

interface GigabitEthernet2/0/1

description Etherchannel 1

switchport access vlan 100

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,100,300

switchport mode access

channel-group 1 mode on

spanning-tree portfast trunk

!

interface GigabitEthernet2/0/2

switchport access vlan 100

switchport mode access

spanning-tree portfast trunk

!

interface GigabitEthernet2/0/3

!

interface GigabitEthernet2/0/4

!

interface GigabitEthernet2/0/5

!

interface GigabitEthernet2/0/6

!

interface GigabitEthernet2/0/7

!

interface GigabitEthernet2/0/8

!

interface GigabitEthernet2/0/9

!

interface GigabitEthernet2/0/10

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

macro description cisco-switch

spanning-tree link-type point-to-point

!

interface GigabitEthernet2/0/11

switchport access vlan 100

switchport voice vlan 200

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

!

interface GigabitEthernet2/0/12

switchport trunk encapsulation dot1q

switchport trunk native vlan 300

switchport trunk allowed vlan 1,100-104,200,300,1002-1005

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

macro description cisco-switch

!

interface Vlan1

ip address 10.234.13.252 255.255.255.0

!

interface Vlan100

ip address 10.234.3.252 255.255.252.0

!

interface Vlan101

ip address 10.234.31.252 255.255.252.0

!

interface Vlan104

ip address 10.234.10.252 255.255.255.0

!

interface Vlan200

ip address 10.234.7.252 255.255.252.0

!

interface Vlan300

ip address 10.20.30.252 255.255.255.0

!

ip default-gateway 10.234.13.254

ip classless

ip route 0.0.0.0 0.0.0.0 10.234.3.254

ip route 0.0.0.0 0.0.0.0 10.234.13.254

ip http server

ip http authentication local

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Peter Paluch Thu, 09/30/2010 - 03:19

Hello Harinder,

Your 3750 should use the LACP to negotiate the creation of an EtherChannel between your Catalyst and ProCurve. Avoid configuring static EtherChannels without using a signalling protocol.

The ProCurve configuration is quite simple in your case:

trunk 47-48 Trk1 LACP

vlan 1

tagged Trk1

vlan 2

tagged Trk1

! ...

vlan 300

untagged Trk1

vlan 301

tagged Trk1

! ...

This configuration simply bundles the ports 47 and 48 into an EtherChannel called Trk1, and assigns this port into explicitly stated VLANs as either tagged or untagged. Obviously, the untagged VLAN 300 becomes the native VLAN. Before modifying the VLAN configuration, have a look at the current running-config first as the Trk1 will be probably already added to all VLANs so you need to just modify its tagged or untagged status.

Best regards,

Peter

G4stechno Thu, 09/30/2010 - 04:08

Thanks for the quick reply,

just to clarify another point

As I'm cross-wiring the switches the cisco stack acts like one big switch and the HP stack is different and each switch is managed differently

so im not using stacking option on HP switches.

so the point im trying to get to is how to tackle the backpane link connecting both the HP switches this is a 10Gbs link (A1)???

do I tag all the VLANs into trk1 and then tag A1 into trk1 or use a seperate trk for that??

Peter Paluch Thu, 09/30/2010 - 04:17

Hello Harinder,

Unfortunately, I don't know the definitive answer to your second question. From my viewpoint, the 3750 behaves as a single switch (if it is stacked) but according to what you wrote, the HP are not stacked and they still behave as two distinct and different switches. If this is true (you have to verify that!) then you have to create two independent EtherChannels on your 3750 stack, each containing ports connected to the same ProCurve. On ProCurve, you create only one Trk interface because the ProCurve considers the 3750 to be a single switch.

Regarding the 10Gbps link interconnecting the ProCurve switches, I would have to look it up in documentation as I have not worked with that.

I am sorry I cannot give you a more definitive answer by now.

Best regards,

Peter

Peter Paluch Thu, 09/30/2010 - 04:33

Harinder,

I have skimmed briefly over the available 2900al ProCurve documentation. If I am not mistaken, there is no such thing as true stacking in these ProCurve switches, as opposed to stacked 3750 Catalysts. What HP calls stacking here is something we know under the name switch cluster on Catalysts that allows for simpler management of a set of physically distinct switches. This is not about sharing backplane, MAC address tables or creating a single switch out of two. This is simply a management feature that can make the management of several switches easier but they are still as independent as they always were.

In such case, the interconnection between two your switches is simply another port. Do not create any Trk interface for it. Simply configure it as tagged in all VLANs (and to be consistent, make the VLAN 300 to be untagged on this interconnection). On each ProCurve, there will be only a single Trk interface for those ports which are connected to the 3750. On the 3750, you need two Port-channel interfaces, each comprising the ports connected to a particular ProCurve switch. The 10Gbps interconnection between your ProCurve switches will not be bundled into any Trk interface, just simply configured for tagging operation on all VLANs.

I am sorry for this convoluted explanation...

Best regards,

Peter

G4stechno Fri, 10/01/2010 - 02:50

I Tried the things mentioned by yourself and trunk seems to be up but the throughput is about 128Bb/sec on a supposedly 2Gbs link.

The link speed goes up once i disconnect of the links in the etherchannel.

also when i do

show Lacp neighbor

nothing shows up.

so I take it hasnt worked

Peter Paluch Fri, 10/01/2010 - 03:22

Harinder,

One configuration error is strongly visible: On both your HP ProCurve switches, you are not using the LACP. Currently, they are both configured as

trunk 47-48 Trk2 Trunk 

This configuration is a static EtherChannel without any supporting protocol. You must convert this to use the LACP as follows:

trunk 47-48 Trk2 LACP

Note that I have already indicated this in my original post - you have to read my answers more carefully so I do not have to keep repeating myself.

Regarding the configuration of your 3750 - it looks basically good but there are still issues to improve:

  1. Configure all your ports Gi1/01, Gi1/0/2, Gi2/0/1, Gi2/0/2 as active ports. Currently, some of them are passive.
  2. Some of these ports are shutdown. Reactivate them.
  3. Remove the command spanning-tree portfast trunk from the configuration of all these ports. This command must not be used on ports connected to other switches. If you want to achieve rapid convergence between switches, you must use RSTP or MSTP.
  4. Remove the command switchport access vlan 100 from the configuration of all these ports. As these ports are statically set as trunks, there is no reason to define an access VLAN.
  5. Make sure that the configuration of the Port-channel interfaces is identical to the configuration of the member ports (except, of course, the channel-group command itself that cannot be used on a Port-channel interface).

Best regards,

Peter

utawakevou Sun, 03/18/2012 - 18:34

Hi Peter,

This is quite and interesting post for me as I have just posted some questions on static and using LACP protocol. Would really appreciate if you can explain more on this "Avoid configuring static EtherChannels without using a signalling protocol." Just to help me understand it more before I schedule to change this. WIll the change from static to LACP have an effect on the link between the 2 switch (Cisco and HP) ??? i.e shutdown of this uplink ports ?

Am not sure whether this (static port channel/trunk without  using a protocol) could be the reason why I notice on my monitoring applciation that it normally send me an alert during backup times about traffic reaching 90% of the bandwidth of only a single interface that is bundled with other ports between my Cisco and HP switch. Alerts normally comes from both switches of the corresponding ports. Got four ports bundled between the two switch

Thank you

Tom Marcoen Mon, 07/16/2012 - 07:11

Hi Peter,

I too would like to know why you recommend to use LACP over statically configuring your EtherChannels. I _always_ statically configure my EtherChannels and _never_ use LACP or PAgP. I know that "

Using an EtherChannel protocol avoids configuration errors." But other than that, there is -- in my opinion -- no benefit to using LACP or PAgP. Though I must admit to this reason being a very good one.

Tom

Peter Paluch Mon, 07/16/2012 - 07:34

Hello Tom,

Probably the greatest danger with misconfigured EtherChannels is the formation of switching loops even if STP is running in the network. Such a switching loop may bring down your networks in seconds, and it is extremely easy to create with static EtherChannels. LACP and PAgP are designed to allow the creation of an EtherChannel bundle only if the opposite device also agrees to the put the ports into an EtherChannel bundle. Along with this negotiation, LACP/PAgP should also make sure that the entire cable bundle leads to a single neighboring device and do some additional sanity checks. In switched networks, there is probably nothing worse than a switching loop, hence we are trying to avoid it at all costs, and using LACP/PAgP helps tremendously.

We have had a lengthy discussion with a couple of friends here on CSC on how the switching loop with misconfigured EtherChannels gets created. You may be interested in reading that discussion. The link I am posting here will jump to the response that contains the explanation but reading the entire thread may be worthwile (even if quite long):

https://supportforums.cisco.com/message/3241966#3241966

Best regards,

Peter

Tom Marcoen Mon, 07/16/2012 - 07:55

Hi Peter,

Thanks for the link. I'm reading the entire conversation right now!

Kind regards,

Tom

Actions

This Discussion