One multipoint GRE tunnel interface onto two physical interfaces ?

Answered Question
Sep 30th, 2010
User Badges:

Hi all


I'm using DMVPN dual hub single cloud VPN network.


Our spokes (C831 ISR) are connected to dynamic DHCP ISP and dynamic PPPoE ISP.  I want to setup a temporary kit that fits everywhere.  Here's my tunnel's configuration for my PPPoE ISP :


interface Tunnel0
bandwidth 1000
ip address 172.23.2.254 255.255.252.0
no ip redirects
ip mtu 1436
ip nhrp authentication xxxxxx
ip nhrp map 172.16.0.1 230.2.2.1

ip nhrp map multicast 230.2.2.1
ip nhrp map 172.16.0.2 230.2.2.2
ip nhrp map multicast 230.2.2.1
ip nhrp network-id 900001
ip nhrp holdtime 300
ip nhrp nhs 172.16.0.1
ip nhrp nhs 172.16.0.2
delay 1000
tunnel source Dialer1
tunnel mode gre multipoint
tunnel key xxxxxx
tunnel protection ipsec profile MyIPSecProf


For my DHCP ISP I only change the tunnel source to Ethernet1.


Is there a way to setup 2 tunnel interfaces linked onto 2 different physical interfaces (like : 1 on Ethernet1 and 1 on Dialer1).  The challange is I cannot change the Hubs configuration at all.  So I cannot put the tunnel's ip address into 2 different subnet.  There's only 1 tunnel interface on the hub


Anyone have an idea ?


Thank you very much

Correct Answer by Lei Tian about 6 years 7 months ago

Yea, I see it now. ip unnumbered will bring the interface to ptp, and the tunnel interface you have is point-to-multipoints. I am afraid there is no good solution for your requirement.


Regards,

Lei Tian

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Lei Tian Thu, 09/30/2010 - 06:41
User Badges:
  • Cisco Employee,

Hi,


Are you looking for 2 tunnel interfaces with same configure?



interface Tunnel0

ip address 172.23.2.254 255.255.252.0

tunnel source fa0/0
tunnel mode gre multipoint
tunnel key xxxxxx
tunnel protection ipsec profile MyIPSecProf



interface Tunnel10

ip address 172.23.2.254 255.255.252.0

tunnel source Dialer1
tunnel mode gre multipoint
tunnel key xxxxxx
tunnel protection ipsec profile MyIPSecProf


The router will complain have overlapping subnet on different interface. Maybe you can try to create a loopback interface and configure ip unnumber on both tunnels.



int lo1

ip add 172.23.2.254 255.255.252.0


interface Tunnel10

bandwidth 1000

ip unnumbered lo1


interface Tunnel0

bandwidth 1000

ip unnumbered lo1

HTH,
Lei Tian
Administrateurs... Thu, 09/30/2010 - 06:53
User Badges:

I'll try thanks.


Sorry I made a typo mistake.  My tunnel IP address shoud have been : 172.16.2.254 instead of 172.23.2.254

Administrateurs... Thu, 09/30/2010 - 07:23
User Badges:

It's worth only for Point-to-point's tunnel interfaces


Error : Point-to-point (non-multi-access) interfaces only


Other idea ?


Thank you very much

Correct Answer
Lei Tian Thu, 09/30/2010 - 10:08
User Badges:
  • Cisco Employee,

Yea, I see it now. ip unnumbered will bring the interface to ptp, and the tunnel interface you have is point-to-multipoints. I am afraid there is no good solution for your requirement.


Regards,

Lei Tian

jan.nielsen Thu, 09/30/2010 - 15:56
User Badges:
  • Gold, 750 points or more

Not sure i understand completely, you have 2 internet connections at the same time on your spoke routers ? How are you going to make the router decide what connection to use?


Jan

Actions

This Discussion

Related Content