7937 registers to SRST instead of CCM

Answered Question
Sep 30th, 2010

I have a 7937 that will not register to CCM.  The phone boots up properly pulls DHCP with option 150 which provides the correct TFTP source.  When you IP to the phone it displays the correct available CCMs.  The phone seems to choose SRST over CCM.  I have factory reset the phone, moved it to a new switch, and moved it to a new voice vlan all with no changes.  If I remove ccm-fallback from the router the phone will finally register to CCM.  As soon as I put ccm-fallback back on the router the phone will register to the router.  There is NO ephone config that would maybe pull the phone.

Any help would be greatly appreciated!

I have this problem too.
0 votes
Correct Answer by Felipe Garrido about 6 years 2 months ago

Can you get a packet capture that covers the registration process? Best thing to do would be to start the capture and then plug the phone back into the network. We can then see what happens when the phone sends it's registration requests.

Please include the IP addresses of the CUCM, phone and SRST gateway.

-Felipe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Ashley Georgeson Thu, 09/30/2010 - 07:12

Hi Chris,

I would first check the compatibility between your SRST router IOS/SRST version, CUCM version and 7937 firmware load.

I imagine they should be okay given it does register to both CUCM and SRST under certain configurations, but I've been caught out by IOS bugs once too often not to consider it!

Regards, Ash.

Correct Answer
Felipe Garrido Thu, 09/30/2010 - 07:26

Can you get a packet capture that covers the registration process? Best thing to do would be to start the capture and then plug the phone back into the network. We can then see what happens when the phone sends it's registration requests.

Please include the IP addresses of the CUCM, phone and SRST gateway.

-Felipe

Chris Austin Thu, 09/30/2010 - 07:34

I'm checking on the IOS/CUCM/Firm Load.  I don't think that is the case but we have all been burned too many times by IOS bugs to not consider it.

Pulling a packet capture is going to be difficult.  I'm in Louisiana and the phone and cluster are in Georgia.  We recently seperated the two sites networks via firewalls so it will take some finagling to get a capture but I'll try to get it.

Chris Austin Thu, 09/30/2010 - 14:19

I got the packet capture.  Turns out there were two problems.  The DHCP scope for the voice vlan was pointing to the wrong domain.  Also in the CCM config I set the "System-Server- Hostname/IP" to a host name.  The phone was trying to register to hostname.wrong domain.  Corrected the domain and changed the server information to an IP since we dont put CCM in DNS.  I then reset the phone and all is good.  It seems that the 7937 looks at the conf file and DHCP differently from 7962s or 7936s.  Those phones all registered fine but this one did not.

Thank you for your help.

Felipe Garrido Fri, 10/01/2010 - 06:00

Chris,

Thank you for the update. That is strange behavior. Can you provide me with the firmware version running on the 7937 and the packet capture? I want to see if this impacts the latest version of the firmware and needs to be addressed.

-Felipe

Actions

This Discussion