LACP between 6509 to 4948

Unanswered Question
Sep 30th, 2010

Hi,

I am trying to setup LACP for trunking between a 6509 and a 4948. I think I have the right config for the 6509 but need help with the 4948 settings. Has anyone done this before? Any issues where a vlan or network went unavailable for a short period when bringing this link up?

6509:

g1/1/1:

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

shutdown

wrr-queue cos-map 2 2 4

priority-queue cos-map 1 3 5

channel-group 3 mode active

g1/2/1:

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

shutdown

wrr-queue cos-map 2 2 4

priority-queue cos-map 1 3 5

channel-group 3 mode active

Port-Chan 3:

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jasmasker Thu, 09/30/2010 - 12:56

Your 6509 config looks correct, except did you notice that you have the interfaces shutdown?  When you bring up the trunk, I would enter the configuration as follows:

Do a show int on each interface you are bundling to ensure that the configurations are identical. Then enter the following:

interface range Gi1/1/1 , Gi1/2/1

  channel-group 3 mode active

This will place both interfaces into the port channel and bring it online. The relevant configuration from the underlying interfaces should be copied into the port channel interface automatically for the most part, but you can check it afterward by doing a 'show run int Po3' and adding any configuration lines that are missing. (In the past I have seen that some things like portfast do not get copied automatically.) Your 4948 configuration should be similar. As far as I know, the channel-group command is universal in IOS, but I am unfamiliar with the 4948 specifically.

You will have a spanning tree event when you first bring the port channel online but by using LACP and if you are using RPVST+ the impact should be minimal. All the same, I would do it during off hours or low usage, if possible, and plan for some minimal disruption.

glen.grant Thu, 09/30/2010 - 17:26

   The etherchannel configs for the 4948 should be exactly the same  as the 6509  except maybe the COS settings.

sudip.acharya1 Thu, 09/30/2010 - 20:36

The config worked great. Same commands on the 4948.

Thanks.

Actions

Login or Register to take actions

This Discussion

Posted September 30, 2010 at 12:15 PM
Stats:
Replies:3 Overall Rating:
Views:1420 Votes:0
Shares:0
Tags: No tags.
 

Discussions Leaderboard

Rank Username Points
1
Jon Marshall
16,516
2
Reza Sharifi
9,299
3
Giuseppe Larosa
8,202
4
Peter Paluch
7,598
5
Leo Laohoo
7,591
Rank Username Points
Jon Marshall
511
Joseph W. Doherty
110
Reza Sharifi
108
Peter Paluch
75
Bilal Nawaz
54