Caller ID - fighting with the Telco

Unanswered Question
Sep 30th, 2010

Here is the scenerio. We just replaced a Nortel System, running on a Bell Canada PRI to a CMBE running on an Alstream PRI.

All is well, except the outbound calls have no name associated with them. Everything I have read indicates that the name comes form the carrier and not the call manager. I have looked high and low and have been unable to find anything that I can configure on the Call Manager to send the company name on outbound calls. Can this be done or is it controlled by the Carrier - i.e. CNAM field based on the Calling Number Mask???

Could I set this on the Gateway Router PRI port?

Can anyone point me to documetation that either proves my point (so I can send it to the carrier) or documentation that proves me wrong so I can fix it....

CMBE version 7.1.5

ISR g2 2921 Router

Thanks,

Heath

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (9 ratings)
Loading.
Steven Holl Thu, 09/30/2010 - 12:27

What ISDN switch type (protocol variant) is being used by the provider?  CNAME delivery type varies depending on switch-type.

I assume that CNAME works inbound?

Also, what VoIP protocol are you using between CUCM and the PRI?

Steven Holl Thu, 09/30/2010 - 12:59

Do you have these enabled on CM?

* Send Calling Name In Facility IE

* Display IE Delivery

Did you reset the gateway from CM after enabling them?

You can run a 'debug isdn q931' and see if CM is sending CNAME out.  It will either be in the display IE in the original setup, or in a 'name to follow' facility for thid switch type.

The short answer is providers can usually overwrite ANI/CNAME to whatever is tied to your account, but you should also be able to send them your own CNAME (at leat on an NI switchtype) if they can't do the former or if you want more specific ANI/CNAMEs.

HEATH FREEL Thu, 09/30/2010 - 13:05

Yes both are on and the Gateway was reset.

If I am able to set the Name  where do I do that.... Where do I set the name? Can I set it globally? or is it set per caller?

Steven Holl Thu, 09/30/2010 - 13:11

CM is sending the CNAME as per that output, but is sending it as 'Name not available'.  So it's a CM issue (although if your provider can overwrite to a generic CNAME for all outbound calls, that could fix it.

I believe CNAME is set under the DN config with 'Display (Internal Caller ID)'.

Then, make sure that under the route pattern which is hit, that calling and connected name presentation are set to 'Allowed.'

HEATH FREEL Thu, 09/30/2010 - 13:07

Here is the Q931 output.

Sep 30 20:07:43.511: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8  callref = 0x0004
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9838E
                Exclusive, Channel 14
        Facility i = 0x9F8B0100A10F02010106072A8648CE1500040A0100
                Protocol Profile =  Networking Extensions
                0xA10F02010106072A8648CE1500040A0100
                Component = Invoke component
                        Invoke Id = 1
                        Operation = InformationFollowing (calling_name)
                                Name information in subsequent FACILITY message
        Calling Party Number i = 0x0081, 'somenumber'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0xA1, 'called number'
                Plan:ISDN, Type:National
Sep 30 20:07:43.623: ISDN Se0/0/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x8004
        Channel ID i = 0xA9838E
                Exclusive, Channel 14
Sep 30 20:07:45.519: ISDN Se0/0/0:23 Q931: TX -> FACILITY pd = 8  callref = 0x0004
        Facility i = 0x9F8B0100A1080201010201008400
                Protocol Profile =  Networking Extensions
                0xA1080201010201008400
                Component = Invoke component
                        Invoke Id = 1
                        Operation = CallingName
                                Name not available
Sep 30 20:07:47.523: ISDN Se0/0/0:23 Q931: RX <- ALERTING pd = 8  callref = 0x8004

cristobal.priego Thu, 09/30/2010 - 13:16

issue the following command

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

-interface Serial0/0/0:23

-isdn supp-service name calling

-exit

Steven Holl Thu, 09/30/2010 - 13:18

cristobal.priego wrote:

issue the following command

-interface Serial0/0/0:23

-isdn supp-service name calling

-exit

This is MGCP, so configuration under the D channel is irrelevant, since the q.931 is being crafted by CM.

HEATH FREEL Thu, 09/30/2010 - 13:19

Getting better - I am able to set it per DN - can I set it globally.... without affecting the per DN setting - if so where can I set it globally.

Steven Holl Thu, 09/30/2010 - 13:24

I don't know of a way to do that.  We can do it for ANI with 'Caller ID DN.'  But I don't see anything under the Gateway, RP, or RL/RG to overwrite CNAME.

Configure all your DN CNAMEs via BAT, perhaps? :-P

HEATH FREEL Thu, 09/30/2010 - 13:27

The other thing I noticed is that I am now sending a caller ID via the Q931 - but only the phone number is showing up on the called parties phone... Is this becuase the carrier may not send this field accross the network?

Steven Holl Thu, 09/30/2010 - 13:30

Yeah that could be true.  Call the provider and ask them what format they want to see CNAME in.  (Here's a trick, ask them how they want to see it before you tell them how you are sending it--it forces them to look up the right answer.)

We're sending it in a subsequent facility IE, with 'calling name to  follow' in the setup IE.  That's the standard way to do it with NI  switch type.

While you're on the phone with them, have them look up what ISDN variant they have you configured for.  You want to make sure it actually is NI, though if you see CNAME in a later facility on an inbound call, that would be enough proof to know.

HEATH FREEL Thu, 09/30/2010 - 13:39

I will call them and I really appreciate your help on this...

A couple of things I have tried in the meantime.

I set the Caller ID DN in the gateway to a DN that uses the Internal Caller ID of the name I wanted to send - I thought that may work globally... it did not. When nothing is set in the Internal Caller ID  field then the Facility says Name Not Avialaible.

No matter what I set it to though it does not show up on the called end.

I'll keep on the telco and report back... Thanks again.

Heath

HEATH FREEL Fri, 10/01/2010 - 05:47

The plot thickens and becomes almost comical.....

I have discovered the the telco is configured for NI1 - please help me as I am still sending the same Caller ID info but it never shows up.

So I have configured the following:

In the Gateway Router: ISDN Switch Type Nantional-ni

In the Call Manager Gateway Devices - Global ISDN Switch Type - 5E8

in the Call Manager Endpoint PRI - PRI Protocol Type - PRI 5E8

I have tried variation after variation and in all cases it sends out the Caller ID... but never shows up on the other end.

Thanks,

Heath

Steven Holl Fri, 10/01/2010 - 06:00

The switch type config on the gateway is irrelevant for MGCP, since CM sends the q931 messages.  The switch type config on CM needs to match what the provider is doing.  If they said you are using NI, you need to configure the CM switch type for NI.  Then, test for any issues from there.

HEATH FREEL Fri, 10/01/2010 - 06:03

There is no NI1 on the call Manager - however I read that 5E8 is the same as NI1... is this correct.

PRI 5E8-AT&T family 5ESS ISDN switch that runs in NI-1 or custom mode.

Steven Holl Fri, 10/01/2010 - 06:08

A 5E switch hardware can run a NI/national protocol, but the 5e protocol is different fron NI.

Use PRI NI2 on CM.  NI2 is backwards compatible with the NI1 spec.

HEATH FREEL Fri, 10/01/2010 - 08:34

OK - more conflicting information from the wornderful carrier.... Now I am told it is a DMS 100 - and that the protocol should be set for DMS 100.

Guess what - it still doesn't show the Calling Name on the called phone. I've got a case open - but like all Telco's they will call me back when it suits them.

Steven Holl Fri, 10/01/2010 - 08:52

If it is DMS100 I'd expect that the provider would send and want to receive CNAME in a Display IE in the setup.

Debug an inbound call from the provider and see how it comes in.  If you see name in a subsequent facility from the provider, they've got to be NI.  If the provider is sending the name in with a display IE, I'd give DMS100 a shot.

In my experience, it sometimes takes several people from the provider side to be able to tell you what ISDN protocol variant is running.  Some provider's L1 people only know how to run BERT tests and can't look at the provisioning configuration at the q.931 layer, and thyey need to escalate to the 'trunk group' or whatever to get that expertise.

HEATH FREEL Fri, 10/01/2010 - 08:55

Here is an inbound debug - looks like DMS 100 from what you explained.

Oct  1 15:53:06.214: ISDN Se0/0/0:23 Q931: RX <- SETUP pd = 8  callref = 0x0B9D
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98381
                Exclusive, Channel 1
        Display i = 0xB1, 'Users Name'
        Calling Party Number i = 0x2183, 'xxxxxxxx2292'
                Plan:ISDN, Type:National
        Called Party Number i = 0xA1, 'xxxxxx615'
                Plan:ISDN, Type:National
Oct  1 15:53:06.222: ISDN Se0/0/0:23 Q931: TX -> CALL_PROC pd = 8  callref = 0x8B9D

Steven Holl Fri, 10/01/2010 - 09:06

You're right.  I'm apparently blind. :-P

Looks like DMS100 to me.  Make that change in CM and reset the gateway.  If calling name still doesn't work, sing and dance to your provider.  ;-)

HEATH FREEL Fri, 10/01/2010 - 09:08

Thats funny - I thought I was losing my mind for a second.....

I have changed it, with no luck - so I'll sit and wait for the provider to call me back.

HEATH FREEL Thu, 10/14/2010 - 06:09

Heres a little update for anyone interested.... Although it still is not solved... and I would still like some help if anyone has any ideas.

It is DMS100 - both for the Switch type and PRI Protocol and we have a display name now being passed, however there are a couple of issues.

The carrier only supports 15 Character - this created a bit of an issue when the company name included the the word "associates" with characters 13, 14 and 15 being 'Ass'.

That all being said - here is the updated question... How do we have outbound calls show the company name, while internal calls show the user name and extension.....

Please keep in mind that this is a Canadian PRI and the Telco/carrier does not set the Name.....

Thanks,

Steven Holl Thu, 10/14/2010 - 06:51

Heath,

The 15 character length is for compliance with standard GR-1367.  With H.323 you can control it with a hidden command 'isdn supp-service name calling length ' under the D-channel.  For MGCP, there doesn't appear to be a way in CM to change this, so you'd have to switch to H323 if you did want this control.  I'm not sure if the q931 stack in H323 supports CNAME >15 characters, though, so that's something to test (I know SIP does, I've tested this scenario before with SIP).  Even if you were able to change it to 16+ characters, would the provider and all of the devices in the ISDN cloud accept CNAME of that length on their end?

I don't know of any way to get internal calls to show a different CNAME than external outbound calls.  It would have to be done in CM since you can't transform/translate the CNAME on the gateway at all.  The closest I can think of is using privacy settings to get it to show as restricted when it hits the gateway.

The provider really has no capability of overwriting CNAME on their side?  That's the easy solution to that, and potentially the only solution.

rob.huffman Thu, 10/14/2010 - 07:00

Hi Heath,

First off, thanks for the update and nice chuckle with the 15 character reference (+5)

I agree with Steven (+5 "S") that the Telco should be able to label all outgoing calls with

a Billing/Corporate name right on the PRI. I have not worked with Allstream here in Canada

but both Bell and Telus can do this and both use DMS100/200/1000 in the CO. Throw those

two names and your requirements at Allstream and see what happens. I'm pretty sure they will

find a way to accomplish what you are looking for.

Cheers!

Rob

HEATH FREEL Thu, 10/14/2010 - 07:06

Rob and Steven,

I had initially said that this was Allstream and was mistaken - it is Bell and from what you have said they should be able to set it for me. I have been told by bell that it is a DMS100  - so it is really a matter of getting hold of the right Bell tech and getting er done.

Thanks again guys.

Heath

HEATH FREEL Fri, 10/15/2010 - 05:14

And the plot thickens...

After discussions with two Bell engineers we are told that due to CRTC regulations/tariffs they are unable to put the name on a PRI in Ontario..... Seems to me that this is technically possible but due to red tape or bureaucracy we are our of luck!!

Question - Am I the only person that has installed a Call Manager in Ontario on a Bell PRI with this requirement? I would have trouble believing that I am!

I also find it odd that on a UC500 I can set the Caller ID Name for outbound calls and still retain each users Internal Caller ID Name for internal calls, yet this is impossible on a system costs thousands more....I must be missing something.

Paolo Bevilacqua Fri, 10/15/2010 - 06:16

[email protected]

And the plot thickens...

After discussions with two Bell engineers we are told that due to CRTC regulations/tariffs they are unable to put the name on a PRI in Ontario..... Seems to me that this is technically possible but due to red tape or bureaucracy we are our of luck!!

That is my understanding also. In Canada, Telco will not pre-set calling name, at least in certain Provinces.

I also find it odd that on a UC500 I can set the Caller ID Name for outbound calls and still retain each users Internal Caller ID Name for internal calls, yet this is impossible on a system costs thousands more....I must be missing something.

Actually, you cannot do that natively on UC500 either.

As a solution, I have developed a TCL/IVR script that allows to set outbound calling name based on a variery of criteria. E.g. you can have different calling names for different extensions "groups", etc.

However, it works only on a H.323 or SIP setup, it cannot work with MGCP, please don't ask if it can be made work with MGCP, because it can not.

If interested, my scripts page is www.ciscoscripts.com, or you can contact me at the address present in my profile.

HEATH FREEL Mon, 10/18/2010 - 13:08

Thanks Paolo,

That is helpful - I will look into your scripts to see if that will help. Although I don't like the idea of having to reconfig for H323 - it may be the only solution.

Thanks,

Heath

9bboice Fri, 04/08/2011 - 08:31

Hi Heather,

I know it's 6 months later, but I ran into your EXACT issue with an install in Ontario with Bell Canada.  After messing with it a bit, I noticed the "ASCII Display (Internal Caller ID)" setting of the line was being sent out in the Display IE (DMS-100 sw type).  Since all the interal phone to phone calls use the DN setting "Display (Internal Caller ID)" for calling name, our work around was to put the user name in "Display (Internal Caller ID)" and the company name in "ASCII Display (Internal Caller ID)" on everyones line.  Hope this helps someone at least!

Actions

This Discussion

Related Content