router confgiuration question

Answered Question
Sep 30th, 2010
User Badges:

i have a 1841 RTR that's getting a hand-off from an ATT RTR so it should be easy to setup.  well i'm missing something because my LAN cannot see the ATT port.

the LAN IP is 192.168.90.X

and the ATT IP is 12.4.184.X

i configured the fas0/0 (interface going to the ATT RTR) as 12.4.184.182 and the fas0/1 (the LAN port) as 192.168.90.254

well i cannot get the laptop connected to fas0/1 to talk to the ATT RTR.

i've pasted the config for your reference.


Current configuration : 2076 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname KDCU_RTR
!
boot-start-marker
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/0
logging count
logging buffered 4096
!
no aaa new-model
clock timezone CST -6
clock summer-time CST recurring
ip cef
!
!
!
!
no ip domain lookup
ip domain name yourdomain.com
multilink bundle-name authenticated
!
!
username grivers privilege 15 password 7 082A5B4D014857
username tcrane privilege 15 password 7 082A5B4D014857
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
description Connection to KWCH
ip address 12.4.184.182 255.255.255.248
ip nat outside
ip virtual-reassembly
speed auto
full-duplex
!
interface FastEthernet0/1
description Link to KDCU LAN
ip address 192.168.90.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
router eigrp 100
  network 12.0.0.0
network 192.168.0.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 12.4.184.177
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging history informational
snmp-server community KWCHnet RO
snmp-server location CW Site
snmp-server contact KWCH IT Dept
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps ipsla
snmp-server enable traps syslog
snmp-server host 10.30.46.162 KWCHnet
!
!
control-plane
!
banner login ^CCC WELCOME TO THE ROUTER ^C
!
line con 0
exec-timeout 15 0
password 7 15191C0F0C
login local
line aux 0
password 7 000F04050C
login local
line vty 0 4
exec-timeout 15 0
privilege level 15
password 7 000F04050C
login local
transport input telnet
line vty 5 15
exec-timeout 15 0
privilege level 15
password 7 104D000A0618
login
transport input telnet
!
scheduler allocate 20000 1000
end

Correct Answer by Federico Coto F... about 6 years 9 months ago

The first and second lines are the same.

I mean... both refer to a translation for the 192.168.90.1 to 12.4.184.178

Since this is a static translation that you have, you will always see the second line (because static NAT will always show under the NAT table even if there's no traffic flowing).


So, everything is working now?


Federico.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Federico Coto F... Thu, 09/30/2010 - 14:19
User Badges:
  • Green, 3000 points or more

Hi,


You have NAT configured under the interfaces but no NAT rules.


Add this:


ip access-list extended NAT

  permit ip 192.168.90.0 0.0.0.255 any


route-map NAT

  match ip address NAT


ip nat inside source route-map NAT interface f0/0 overload


That should take care of it.


Federico.

garyrivers Thu, 09/30/2010 - 14:24
User Badges:

I inserted the lines and I have a PC connected to the fas0/1 int and I'm still unable to ping 12.4.184.182 (the fas0/0 int).

Federico Coto F... Thu, 09/30/2010 - 14:30
User Badges:
  • Green, 3000 points or more

Interesting...


Questions:

1. ping 12.4.184.x succesfull?

2. ping 12.4.184.x source 192.168.90.254 succesfull?

3. sh ip nat trans --> showing NAT working (when attempting to reach the ATT port from the local machine)?


Federico.

garyrivers Thu, 09/30/2010 - 15:22
User Badges:

so i'm trying to static up the PC to the .178 IP

i inserted the following and did a screen shot of the "sh nat trans" and attached it to this reply.

Thoughts?

Attachment: 
Reza Sharifi Thu, 09/30/2010 - 17:10
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Plug your PC to interface FastEthernet0/1

Give it IP addreaa of 192.168.90.100 with default gateway of 192.168.90.254


Now, can you ping 192.168.90.254?

if yes, can you ping 12.4.184.182?


HTH

Reza

garyrivers Fri, 10/01/2010 - 07:18
User Badges:

well, that seemed to work,  thanks.

but please refer to the attached, the first line is showing that the PC is getting translated as planned but how do i remove the second line in the "sh ip nat trans" output?

Attachment: 
Correct Answer
Federico Coto F... Fri, 10/01/2010 - 07:36
User Badges:
  • Green, 3000 points or more

The first and second lines are the same.

I mean... both refer to a translation for the 192.168.90.1 to 12.4.184.178

Since this is a static translation that you have, you will always see the second line (because static NAT will always show under the NAT table even if there's no traffic flowing).


So, everything is working now?


Federico.

garyrivers Fri, 10/01/2010 - 08:22
User Badges:

okay, i was just concerned that the 2nd line was telling me something else.

it's is working like a champ.  Thanks for your assistance. Gary

Actions

This Discussion