Upgrade from 7.1.1 to 8.0.4 and big problem with Remote Phone

Unanswered Question
Oct 1st, 2010

I just upgrade UC520 to 8.0.4 package, and now my Phone Cisco7906 at remote Home lost audio stream.

The Cisco7906 can register with UC520, can make and receive call but there was no audio.

Tried to test another phone Cisco7960G, the problem still the same

But the software phone Cisco Communicator with same condition version, making call and receiving call was OK

For the 03 cases above the remote phone was setup with mtp command in ephone configuration.

I think there is problem with audio stream port 2000 with these hardware phone with remote connection

The local phone at the main office are working well (Cisco7906, Cisco7940)

I have used UC520 more than 2 years, and my setup was as follow :

UC520 in the main office with EASY VPN Server and SPLIT Network enable for Data, VOICE VLAN subnet

Cisco877 in remote Home, with EASY VPN client. IP Phone was in the LAN side of Cisco877 and was NAT to using this VPN to connect to UC520

With firmware 7.1.1 in UC520 before, the Cisco7906 at remote Home was working well, but now with firmware 8.0.4 it didn't work anymore.

I wonder if this is bug with new firmware 8.0.4 ?!

Please help to fix this problem, or advise can I downgrage back UC520 to 7.1.1 ?

Thank you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
greenturtlesteak Sat, 10/02/2010 - 08:51

It sounds like you lost the mtp command for your remote ephone. Try checking off teleworker for this phone in CCA or add the command in manually via CLI.


tuandatnv Sat, 10/02/2010 - 17:05

I have checked mtp command many time, enter it manually via CLI, but the problem still the same.

I used to use codec G729 with transcoding with remote phone, and tried to remove this command (codec g729r8 dspfarm-assist) from ephone setup

but the problem is still the same.

The system work with softphone Cisco Communicator but not with Cisco Hardware phone 7906 and 7960, eventhrough the setup for those phones nearly the same

Here is a setup of those ephones, and only ephone 21 (softphone) work, the others can registered, but when make or receive call, there was any audio.

(As I remembered, with firmware 7.1.1 this problem happened with Cisco7960, so I had to be use 7906 in remote side, now with firmware 8.0.4 these problem happened with both Cisco7960 and 7906)

ephone  20

device-security-mode none

mac-address 001E.4A34.9B4A

ephone-template 16

username "tuanbeo"

codec g729r8 dspfarm-assist

type 7960

button  1:13




ephone  21

device-security-mode none


mac-address 001D.BAB5.F2CB

ephone-template 16

username "tuanbeo1"

codec g729r8 dspfarm-assist


type CIPC

button  1:15




ephone  22

device-security-mode none


mac-address 001E.4A92.25C9

ephone-template 16

username "tuanbeo2"

codec g729r8 dspfarm-assist


type 7906

button  1:14


Please advise debug command for SCCP call and help to solve this problem
Thank you
Nathan Compton Tue, 10/05/2010 - 06:45

Is the no audio issue occuring between phones registered to the UC520, or external calls?  Another thing is try using 711ulaw or 729 without the dsp-farm assist.

What is the status on your dspfarms?  "show dspfarm" will check this.

There are a few debugs I know off the top of my head that can check problems with the dsp farms.  You can try the following debugs to see if DSPs are being activated correctly:

debug dspapi all

debug dspfarm events

One correction I wanted to make on your first post is that SCCP uses port 2000, but the audio stream does not.  The audio stream is RTP which has a very wide range of ports.


Adam Compton

tuandatnv Sun, 10/10/2010 - 16:58

The audio missing occured with both registered and external incoming and outgoing calls.

The problem happen with Cisco Hardware phone (7906 and 7960), but I suppose this problem could happen with other hardware phone such 7940 also.

The softphone (Cisco Communicator) in the same remote LAN side is working fine, and now I have to use softphone instead.

I had tried with both G711 and G729 Codec, and only softphone work, the Cisco hardware phone always lost the audio, althrough the ring, connect and disconect status were working.

When using G729 Codec with transcoding with both softphone and hardware phone, I could see the transcode resource was used (dspfarm command)

I supposed the problem would be cisco hardware phone firmware problem, which did not received and send audio stream with correct ports when the audio stream was NAT through VPN remote IP Address, but the soft phone Cisco Communicator can do it OK !

Please advise command to detect the audio stream data at both UC520 and remote VPN Router 877

Thank you

Tuan Nguyen

Nathan Compton Sun, 10/10/2010 - 17:45

if you do the command "show ephone registered" on the UC500, what IP address is the phone registering with? 

tuandatnv Sun, 10/10/2010 - 18:04

It was registered with remote VPN address of my Cisco877, bellow are information :

ephone-21[20] Mac:001D.BAB5.F2CB TCP socket:[1] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 15/12 max_streams=5
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:6
IP: * 2356 CIPC  keepalive 41 max_line 8 available_line 8
button 1: cw:1 ccw:(0 0)
  dn 15 number 206 CH1 cc(03)   IDLE         CH2 cc(03)   IDLE        
Preferred Codec: g729
Lpcor Type: none Username: tuanbeo1

ephone-22[21] Mac:001E.4A92.25C9 TCP socket:[11] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 17/17 max_streams=5
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1 caps:9
IP: * 17309 7906  keepalive 39 max_line 1 available_line 1
button 1: cw:1 ccw:(0 0)
  dn 14 number 205 CH1 cc(03)   IDLE         CH2 cc(03)   IDLE        
Preferred Codec: g729
Lpcor Type: none Username: tuanbeo2

The CIPC phone  (ephone-21) can work OK, but 7906 (ephone-22) lost audio

From remote CIPC and 7906 I can make a call to any numbers (internal and external to FXO or SIP trunk) and to each other, but when make call and receiving call with remote 7906, I lost audio stream from both side

I just hear the information regarding the same problem from the post

UC540 AND SR520 Teleworker Bug

  with link bellow:


Thank you for your help and support

Tuan Nguyen

tuandatnv Sun, 10/10/2010 - 18:30

When read more carefull with the post

UC540 AND SR520 Teleworker Bug

and compare with my problem

I wonder if it is problem with harware phone SCCP version 17/17 ? Because the Soft phone CIPC with SCCP version 15/12 seem to work fine !

My Phone Cisco7906 when working with UC520 firmware 7.1.1 (which offer older firmware load for 7906) was OK also.

I would like to mention that Cisco7960 (and maybe Cisco7940) also have this problem seen UC520 firmware 7.1.1


Tuan Nguyen

tuandatnv Sun, 10/10/2010 - 18:45

Please advise how to copy old firmware of Cisco7906 to UC520 (which files need to copy to and where to copy to) and reconfig UC520 so the Cisco7906 can downgrade its firmware for testing

Thank you

Tuan Nguyen

Nathan Compton Sun, 10/10/2010 - 19:12

The reason I asked what IP address that the phone registered with, is that it should be registering with an IP from the EZVPN server pool.  If the phone does not register with an ip from the pool it won't work.

As far as changing the software on the phone,  Here is a guide on upgrading the firmware:


It will work the same way with you going down a version.


Adam Compton


This Discussion

Related Content